Closed Bug 525594 Opened 11 years ago Closed 9 years ago

Update AMO's Plugins page

Categories

(addons.mozilla.org Graveyard :: Plugins, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED WONTFIX
4.x (triaged)

People

(Reporter: fligtar, Unassigned)

References

()

Details

(Whiteboard: [2010Q1])

Attachments

(1 file)

Attached image wireframe
The Plugins page on AMO is the 6th most visited page on the site, with 60,000 pageviews every day. It looks pretty bad and is outdated.

We should:
* Update the design of the page to match our new style
* Integrate new Plugin Check service and links
* Update list of available plugins and make it dynamic

Each plugin in the list will have its name, summary, and a download link that will go the vendor's download page (homepage URL for the add-on listing).

The list will pull all STATUS_PUBLIC add-ons of type ADDON_PLUGIN and sort them alphabetically. For plugins we are able to check through the Plugin Check service, we should display the installed version and whether that version is up-to-date or outdated. If outdated, the entire row should be distinguished as needing action.

Please see the attached mockup for my proposed basic layout. I'll send over to chowse for designs after feedback on the proposal here. I'm targeting this for the first release of Q1.
We should put some thought into keeping plugins on this page in sync with PFS2 data, whether that means generating a static page from PFS2 data or auto-managing addons of type ADDON_PLUGIN from PFS2 plugin releases.  

Not entirely sure how that would work yet, since the data model diverges enough to be annoying.  (eg. plugins have no GUIDs; versions detected change for the same plugin depending on browser version and detection algo; PFS2 will have a cross-browser plugin directory)
Blocks: 375052
clouserw: Just saw you added this as a blocker to bug 375052.  That's one more kink in trying to keep our plugin databases in sync.  In PFS2 / Plugin Check, we just use the vendors' own descriptions of their plugins.  Those generally aren't localized, so we'd be providing a service to those vendors by doing it for them. Might be worth putting some thought into what plugin vendors think about that, and how to keep things maintained / synched up.
I added it as a blocker for consideration.  I don't want to be in the business of syncing up 3rd party localized changes on the site manually.  On the other hand, if we treated plugins more like "listed" add-ons (on the back end) we could make the companies an author and if they wanted to localize they could.
Blocks: 305521
Blocks: 308871
Blocks: 385832
Blocks: 426239
No longer blocks: 426239
Blocks: 439540
Blocks: 440281
Blocks: 444109
Blocks: 527883
Blocks: 489519
Blocks: 512747
Severity: normal → enhancement
Priority: -- → P3
Whiteboard: [2010Q1]
Target Milestone: --- → 4.x (triaged)
FYI: I'm working on a plugin directory project right now, so we might want to see where that goes with respect to helping out this page.
Duplicate of this bug: 495522
We're removing the Plugins page in bug 686970.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.