[UI] Implement appropriate items in context menu

VERIFIED FIXED in M18

Status

()

Core
Editor
P4
major
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Judson Valeski, Assigned: Charles Manske)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][p:4][PDT Check])

(Reporter)

Description

18 years ago
create a table, right click it to bring up the context menu, select properties
and nothing happens.

Comment 1

18 years ago
*** Bug 43308 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
This is also a problem on Macintosh.
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: PC → All

Updated

18 years ago
Severity: normal → major
Keywords: nsbeta2
Priority: P3 → P2
Target Milestone: --- → M17

Comment 3

18 years ago
setting to m17 and nominate for nsbeta2
(Assignee)

Comment 4

18 years ago
Changing summary to relect larger issue: table items in the context menus
are not complete. 
1. The "Insert", "Delete", and "Select" table submenus need to be added instead
of the single "Table" item. Command handlers need to be hooked up in the XUL.
2. Clicking on "Table Properties..." currently crashes on Windows.
3. Table items should only be visible when selection is or is inside a table.

Keywords: crash
Summary: Can't bring up table properties on linux → Implement table items in context menu

Comment 5

18 years ago
Please create separate bugs for each issue mentioned and resubmit any 
nominations.
Whiteboard: [NEED INFO]

Comment 6

18 years ago
Putting on [nsbeta2-] radar and adding nsbeta3 keyword. Not critical to beta2. 
Yes, it is a regression and yes it looks bad, but we have no indication that any 
other sites show this behavior.
Keywords: nsbeta3
Whiteboard: [NEED INFO] → [nsbeta2-]

Comment 7

18 years ago
we need to finalize our context menu spec and then go back through and finalize 
the menu items in the app. The spec will be completed during the UI review
Keywords: crash, nsbeta2 → correctness
Whiteboard: [nsbeta2-]
Target Milestone: M17 → M18

Comment 8

18 years ago
setting to nsbeta3+
Whiteboard: nsbeta3+

Updated

18 years ago
Summary: Implement table items in context menu → [UI] Implement table items in context menu

Updated

18 years ago
Whiteboard: nsbeta3+ → [nsbeta3+]

Comment 9

18 years ago
adding priority to status whiteboard
Priority: P2 → P4
Whiteboard: [nsbeta3+] → [nsbeta3+][p:4]

Comment 10

18 years ago
reassign to Charley
Assignee: brade → cmanske
Status: ASSIGNED → NEW
Summary: [UI] Implement table items in context menu → [UI] Implement appropriate items in context menu

Comment 11

18 years ago
We decided on this layout in a UI meeting:

        Undo
        Redo
        ------------
        Cut
        Copy
        Paste
        Clear
        ------------
        Select All
        ------------
        Remove text styles      
        Create link... (text or image)
        Remove link     (If in a link)
        -------------
        Foo properties...
        -------------
        Table insert >   (If in a table, these)
        Table select >
        Table delete >
        Join cells
        Split cells


Remove preview in browser
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 12

18 years ago
In build 2000-08-09-09m18 I see that if you try and select the table item (of 

course you can't really do that, but you highlight it and then click off when you 

nect invoke this contect menu the table item is already selected and as you mouse 

over you can have more than one highlighted at a time. I actually expect that 

this revamp of the menu will fix this too but I thought I'd mention it.

Comment 13

18 years ago
Per PDT, menu items that appear must work or be pulled out ASAP. 
Whiteboard: [nsbeta3+][p:4] → [nsbeta3+][p:4][PDT 9/1]

Comment 14

18 years ago
Updating [PDT 9/1] to [PDT Check]
Whiteboard: [nsbeta3+][p:4][PDT 9/1] → [nsbeta3+][p:4][PDT Check]

Comment 15

18 years ago
*** Bug 49846 has been marked as a duplicate of this bug. ***

Comment 16

18 years ago
*** Bug 50327 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 17

18 years ago
This is simple but tedious work and should rightly be left for last priority, 
but must be done before shipping.

Comment 18

18 years ago
*** Bug 49848 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 19

18 years ago
Work is done -- waiting for review.
Whiteboard: [nsbeta3+][p:4][PDT Check] → [nsbeta3+][p:4][PDT Check][checking in 9/5]
(Assignee)

Comment 20

18 years ago
checked in 9/5/00
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta3+][p:4][PDT Check][checking in 9/5] → [nsbeta3+][p:4][PDT Check]

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 21

18 years ago
wired up but I still see uncessary items for different objects.

For example, when I insert an image and right mouse click on it
to bring up the context menu, I see these options listed:

Join with Cell to the Right
Table or Cell Background Color

I will file separate bug

Comment 22

17 years ago
*** Bug 55745 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.