Last Comment Bug 442399 - remove LiveConnect from the tree
: remove LiveConnect from the tree
Status: RESOLVED FIXED
:
Product: Core Graveyard
Classification: Graveyard
Component: Java: Live Connect (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: mozilla1.9.2a1
Assigned To: Johnny Stenback (:jst, jst@mozilla.com)
:
:
Mentors:
Depends on: 435334 444963 445039 445063
Blocks: 450116 488824
  Show dependency treegraph
 
Reported: 2008-06-27 17:05 PDT by Johnny Stenback (:jst, jst@mozilla.com)
Modified: 2010-10-16 12:12 PDT (History)
18 users (show)
jaas: wanted1.9.2+
jst: wanted1.9.1-
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch to remove liveconnect from the tree. (221.93 KB, application/octet-stream)
2009-06-26 13:03 PDT, Johnny Stenback (:jst, jst@mozilla.com)
no flags Details
Source changes. (26.79 KB, patch)
2009-06-26 13:06 PDT, Johnny Stenback (:jst, jst@mozilla.com)
jaas: review+
bob: review+
brendan: superreview+
Details | Diff | Splinter Review

Description Johnny Stenback (:jst, jst@mozilla.com) 2008-06-27 17:05:01 PDT
Once the new Java plugin is more readily available (on all major platforms etc), OJI and LiveConnect needs to go away. Loads of unmaintained code full or complexity and problems we no longer want or need with the new NPRuntime enabled Java plugin.

This is a tracking bug to track the removal of this code. Make other related and more specific bugs block this tracking bug.
Comment 1 Johnny Stenback (:jst, jst@mozilla.com) 2008-06-27 17:10:52 PDT
Also see http://wiki.mozilla.org/Mozilla_2/Kill_LiveConnect for more information.
Comment 2 Johnny Stenback (:jst, jst@mozilla.com) 2008-09-18 16:55:46 PDT
We can't do this for 1.9.1 as there's no Java plugin for the Mac available yet that doesn't depend on this. The current target is the release following 1.9.1.
Comment 3 thomas.comiotto 2008-11-18 03:33:59 PST
Removing LiveConnect will also break firefox extensions that use it (e.g. PiggyBank). Extension developers that require java will be left with http://pcscholl.de/2007/08/23/java-applets-in-xul (pretty ugly, heh?) alone.
Comment 4 Kenneth Russell 2008-11-18 12:16:48 PST
The intent is that the new NPRuntime Java Plug-In in Java SE 6 Update 10 will provide the facilities to allow current Firefox extensions using Java to continue to work. Support is present in Firefox 3 and the new Java Plug-In for the window-scope "java" and "Packages" keywords. However, it appears there are issues that still need to be solved where it was previously assumed that LiveConnect calls coming from Firefox extensions had additional privileges, and we currently don't have a mechanism in the new Java Plug-In for granting such privileges to Firefox extensions. It isn't clear to me that simply granting all permissions to calls coming from a chrome:// document is the best solution, though it may be.
Comment 5 Josh Aas 2009-03-30 12:48:19 PDT
Making this bug about LiveConnect, opening a new bug about OJI.
Comment 6 Josh Aas 2009-03-30 12:52:32 PDT
OJI removal is bug 485984.
Comment 7 Boris Zbarsky [:bz] (still a bit busy) 2009-04-23 10:41:32 PDT
So... the landing for bug 485984 incidentally turned off building of LiveConnect.
Comment 8 Josh Aas 2009-04-23 10:56:45 PDT
I can't say I intended to do that but it seems like we should just leave it unless we have a specific reason to re-enable it. We should disable xpcom plugin loading and remove LiveConnect from the tree altogether very soon.
Comment 9 thomas.comiotto 2009-04-23 13:05:43 PDT
How to use java from FF extensions then? Is there a way you can confirm that works?
Comment 10 Kenneth Russell 2009-04-23 14:27:05 PDT
With Java SE 6 Update 12 and later (already shipping) we have confirmed that extensions like FireGoose which use Java are working with the new NPRuntime Java Plug-In. Slight syntactic changes may be needed to JavaScript code which accesses Java for a few constructs which are no longer supported.
Comment 11 Johnny Stenback (:jst, jst@mozilla.com) 2009-06-26 13:03:12 PDT
Created attachment 385453 [details]
Patch to remove liveconnect from the tree.

This is the whole deal (gzip'ed as it's over 2Mb), removals n' all. I'll attach a patch that only lists the directories removed and shows the changes to the code separately in a bit.
Comment 12 Johnny Stenback (:jst, jst@mozilla.com) 2009-06-26 13:06:07 PDT
Created attachment 385454 [details] [diff] [review]
Source changes.

This is the changes to the tree to remove liveconnect, not including the removal of the directories as that makes the patch too big for bugzilla. In addition to these changes, the following directories will be removed:

  js/src/liveconnect/
  js/tests/lc2/
  js/tests/lc3/
  js/tests/src/
Comment 13 Ryan VanderMeulen [:RyanVM] 2009-06-26 14:58:59 PDT
Does removed-files.in need to be updated as well?
Comment 14 Johnny Stenback (:jst, jst@mozilla.com) 2009-06-26 15:40:50 PDT
Yes! I didn't know about that, to be honest, but yes, we need to add a line containing:

@DLL_PREFIX@jsj@DLL_SUFFIX@

to that file and any liveconnect libraries laying around will get deleted. Even better! Thanks!
Comment 15 Bob Clary [:bc:] 2009-06-28 10:42:16 PDT
Comment on attachment 385454 [details] [diff] [review]
Source changes.

...

>diff -r ac3c29f427bf js/tests/README-jsDriver.html
>--- a/js/tests/README-jsDriver.html	Fri Jun 26 08:20:31 2009 -0700
>+++ b/js/tests/README-jsDriver.html	Fri Jun 26 09:03:01 2009 -0700

...

>@@ -315,26 +305,18 @@
>         <br>
>       <dt><b>EXAMPLES</b></dt>
>       <dd>
>-          <code>perl jsDriver.pl -e smdebug -L lc*</code><br>
>-          Executes all tests EXCEPT the liveconnect tests against the
>+	XXX
why the XXX?

>+          <code>perl jsDriver.pl -e smdebug -L ecma3*</code><br>

ecma_3

>+          Executes all tests EXCEPT the ecma3 tests against the

ecma_3

>           SpiderMonkey debug shell, writing the results
>           to the default result file.  (NOTE: Unix shells take care of wildcard
>-          expansion, turning <code>lc*</code> into <code>lc2 lc3</code>.  Under
>-          a DOS shell, you must explicitly list the directories.)
>+          expansion, turning <code>ecma3*</code> into

ecma_3

>+	  <code>ecma3 ecma3_1</code>.  Under a DOS shell, you must explicitly

ecma_3 ecma_3_1

In the full patch, you need to remove browser.js in the lc{2,3} (sub)directories

r+ with those nits.
Comment 16 Brendan Eich [:brendan] 2009-06-29 23:40:55 PDT
Comment on attachment 385454 [details] [diff] [review]
Source changes.

Yay!

/be
Comment 17 Johnny Stenback (:jst, jst@mozilla.com) 2009-06-30 18:21:06 PDT
I fixed the things that Bob pointed out in the patch and committed this. R.I.P. LiveConnect.

http://hg.mozilla.org/mozilla-central/rev/516dfcdf9a57

Note You need to log in before you can comment on or make changes to this bug.