scrolling = yes not implemented: forced scrollbars don't show up [behaves like scrolling="auto"][frames]

RESOLVED WORKSFORME

Status

()

Core
Layout: HTML Frames
P3
normal
RESOLVED WORKSFORME
18 years ago
4 years ago

People

(Reporter: Jake Goena, Assigned: John Keiser (jkeiser))

Tracking

({html4, testcase})

Trunk
Future
html4, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: see comment #24 for 4 testcases)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; Win98; en-US; m14) Netscape6/6.0b1
BuildID:    2000033112

If a <FRAME> tag has  SCROLLING set to "YES", it acts as if it were set to "AUTO"

#################################Example##########################
<frameset  cols="179,*">
<frame name="nav" src="admin/nav.html" marginwidth="0" marginheight="0"
scrolling="yes" frameborder="no">
<frame name="main" src="admin/main.html" marginwidth="0" marginheight="0"
scrolling="auto" frameborder="no">
</frameset>
#############################################################


Reproducible: Always
Steps to Reproduce:
1.Load the page
2.
3.


Actual Results:  The scrollbar did not show up	

Expected Results:  showed the scroll bar.

Comment 1

18 years ago
Using the code below and some test pages, I confirmed that this bug still exists
as of nightly build 2000070408.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
Yep, I seem to remember that we only support scrolling=auto and scrolling=no.  
CC'ing Eric Vaughan as he might be interested.
Status: NEW → ASSIGNED
Target Milestone: --- → M17

Comment 3

18 years ago
Eric, does this seem like something that should be fixed for beta3/final?  I'm 
leaning towards marking this Future.

Comment 4

18 years ago
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another 
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration.
Target Milestone: M17 → Future

Comment 5

17 years ago
*** Bug 48991 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
*** Bug 66335 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
QA Contact update
QA Contact: petersen → amar

Comment 8

17 years ago
*** Bug 89130 has been marked as a duplicate of this bug. ***

Updated

17 years ago
OS: Windows 98 → All
Hardware: PC → All
Summary: Forced scrollbars don't show up. → scrolling = yes not implemented: forced scrollbars don't show up.

Comment 9

17 years ago
The Mozilla "bouncing scrollbars" feature creates an insolvable problem in some 
existing e-commerce site designs.

The problem cannot be worked around because of the combination of 2 "features":
1) the width of a page cannot be calculated by any means
   (even the browser does not know it until the page is fully loaded)
2) FRAME: "scrolling = yes not implemented: forced scrollbars don't show up"

The "bouncing scrollbars" breaks frames designs that are as basic as having 2 
rows with proportionally aligned content.
Proportional alignment is a necessity wherever a window is resizable or the 
screen size is not fixed, both of which are fundamental boundary conditions on 
the web.

As commercial e-commerce site providers, we are extremely disappointed that some 
misguided Mozilla designers are prepared to break compatibility with all other 
browsers in the market (Priority 3, Target Milestone Future).

We are also disappointed that such a basic arithmetic failure can get beyond the 
design stage.

We recognise and appreciate the efforts of the Mozilla team in the area of DOM 
and CSS standards compliance.

However, for us, these CSS and DOM related improvements are 
completely overshadowed by more basic issues such as this.
Bulk reassignin HTML FRAME/IFRAME bugs to Eric.
Assignee: pollmann → evaughan
Status: ASSIGNED → NEW
This needs to be reassigned, I bet (unless evaughan has a fix already, or is
about to hack one up), and pulled into 0.9.8 or 0.9.9.  Based on mail from
bht@actrix.gen.nz, I'm nominating for mozilla1.0, and cc'ing jst and jkeiser in
the hopes that they can help.

/be
Keywords: mozilla1.0
Bulk re-assigning all of Eric's HTMLFrame bugs to John.
Assignee: eric → jkeiser

Comment 13

16 years ago
Setting scrolling=no on a frame with javascript 
(getElementById('frameID').scrolling='no') doesn't work either. It behaves 
as scrolling=auto, but it does have the value of 'no' 
(alert(getElementById('frameID').scrolling))!

Comment 14

16 years ago
*** Bug 153985 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
Just confirming that this is still present in 1.1 alpha. Also adding some words
to summary to make bug easier to find.
Summary: scrolling = yes not implemented: forced scrollbars don't show up. → scrolling = yes not implemented: forced scrollbars don't show up [behaves like scrolling="auto"][frames]
http://www.thanatos.be/fotos.php?album=Activiteiten
click Boomplantactie (first picture) and see a window popping up which is too
small (though I specified the image height + 90 px), in Internet Explorer it's
displayed correctly. I tried adding scrollbars by putting scrollbars=yes but it
doesn't seem to work either...

Comment 17

15 years ago
My observation defining scrollbars in window.open is that 'no' means no , 'auto'
means no and 'yes' means auto. My test page may be useful at
http://www.alanfirminger.freeserve.co.uk/test/scrollbards.html

Comment 18

15 years ago
This bug is blocking proper functioning of the following site:
http://nhgz.com/html/?page=dates.php
Forcing the scrollbars to be shown is necessary to centering the frame properly
on all links throughout the site.
I am reporting it on the behalf of the owner of the site (whom I have talked to).

Like Comment #9, this too seems like such a basic feature that I believe it's
priority should be moved up.

P.S. We've passed mozilla1.0 already, correct?

Comment 19

15 years ago
"html4" keyword belongs here.
Can someone add it?

Updated

15 years ago
Keywords: html4

Comment 20

15 years ago
Yet another site, that is gonna need support for this feature:
http://www.strategyinformer.com/

Comment 21

15 years ago
Sorry about that, but I made a mistake.
http://www.strategyinformer.com/ does not need this.

Comment 22

15 years ago
This bug not only affects frames, but also iframes, see 

http://www.mozilla.org/quality/browser/standards/html/iframe_scrolling_yes.html

for an example that it is not working :(.

Updated

14 years ago
Blocks: 7954

Comment 23

14 years ago
FWIW, scrollbars will be rendered with this CSS rule in framed documents:

:root
{
	overflow: scroll;
	height: 100%;
}

Comment 24

14 years ago
scrolling="yes" is not rendered in 1.7 branch builds but, as far as I can see,
scrolling="yes" is supported in Mozilla 1.8a5 build 2004102405; XP Pro SP2 here.
Can someone confirm this?

FIXED

Comment 25

13 years ago
I checked again with Mozilla 1.8a5 build 2004112306 and scrolling="yes" is
supported and rendered in frames and iframes. It is not rendered in Firefox 1.0
final release rv: 1.7.5 build 20041107 but scrollbars will be rendered if the
author uses the css rule:
:root
{
	overflow: scroll;
	height: 100%;
}
http://www.mozilla.org/quality/browser/standards/html/frame_scrolling_yes_rows.html
http://www.mozilla.org/quality/browser/standards/html/frame_scrolling_yes_cols.html
http://www.mozilla.org/quality/browser/standards/html/iframe_scrolling_yes.html
http://www.w3.org/MarkUp/Test/HTML401/current/tests/sec16_2_2-BF-03.html
all render accordingly, correctly.

Resolving as WORKSFORME since I don't know which patch (possibly in bug 76197?)
fixed this.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: testcase
Resolution: --- → WORKSFORME
Whiteboard: see comment #24 for 4 testcases
You need to log in before you can comment on or make changes to this bug.