make licensing information available about add-ons

VERIFIED FIXED in 5.0.5

Status

addons.mozilla.org Graveyard
Policy
--
enhancement
VERIFIED FIXED
10 years ago
2 years ago

People

(Reporter: Timo Lindfors, Assigned: osunick)

Tracking

unspecified
5.0.5

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.11 (Debian-2.0.0.14-0etch1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/2008040400 Firefox/2.0.0.11 (Debian-2.0.0.14-0etch1)

I find it that at the moment it is very difficult to find free software extensions from http://addons.mozilla.org/ for the following reasons:

1) The advanced search option does not support limiting search to only free software extensions

2) A large number of extensions seem to be non-free

3) Copyright information is generally hidden in the source code of the extensions and requires the user to manually unzip the xpi file and grep for "copyright" or something similar. Examples of such cases include e.g.

3.1) https://addons.mozilla.org/en-US/firefox/addon/3006
3.2) https://addons.mozilla.org/en-US/firefox/addon/3863

I suggest the following:

1) Add "license" tag to every extension just like every extension now has a "Platform" tag. 

2) Enhance the search engine to support searching by "license".

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
Well, first of all, we should be specific here. All add-ons on AMO are free to use and 90% or so have "open" (but not necessarily free to use) source.

Suggestion #1 a duplicate of bug 330051. The end result of the discussion is that specifying a license in a field in a consistent way across all add-ons is not as simple as it sounds, and doing so via the description field is adequate. There are many different licenses, with infinite variations, so it's not realistically a matter of just checking a box somewhere.

Now, I do think a simplistic "open-source" (set of) flags might be useful to add for developers to select which can be searched for. Maybe flags indicating status as none, free to use, copyleft, copyright, etc.? (and optionally a text space to paste the current license as-is)

Admittedly, not that many users would care about this, so I don't know if it's worth the effort or added complexity. As stated in bug 330051, developers already have the option to enable the online source viewer if the choose. (though many choose not even if their source is open)

Updated

10 years ago
OS: Linux → All
Hardware: PC → All
(Reporter)

Comment 2

10 years ago
Yes, I tried to avoid confusion of the term "free software" by using "per FSF" in the bug title. To make this even more specific can I somehow retitle this report to mention http://www.gnu.org/philosophy/free-sw.html explicitely?

I agree that copyright issues are not easy. This is why it would be good if they were done in a cooperative fashion so that duplicate effort of checking copyright information would be avoided. Sourceforge and freshmeat have simple license tags. They are not very accurate but they at least allow me to exclude projects that admit being non-free so that I only need to check the licenses of those projects that claim to be free.

I am not sure how many users care about free software firefox extensions but many people who I've asked have been suprised to hear that most extensions are not free software and assumed the contrary. Even I thought this before I noticed I did not in fact have legal rights to redistribute fixed version of iMacros from my homepage.

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: please make finding free software (per FSF) extensions easier → make licensing information available about add-ons

Updated

9 years ago
Duplicate of this bug: 451967

Comment 4

9 years ago
At a minimum, I think it makes sense to have an optional text field a developer can dump their license into and have it show a link on the public page, similar to how we do the privacy policy now.  It wouldn't be searchable but it'd avoid the complexity that has been worried about in previous discussions.

Updated

9 years ago
Duplicate of this bug: 428675

Comment 6

9 years ago
I've written up some ideas about we might represent the various types of add-ons in a document @ https://wiki.mozilla.org/User:Bhashem/AddonClasses. This doesn't address all aspects of this bug but it's a start.
Target Milestone: --- → 4.0.4
-> 4.0.5 - we should add a text field to start and draft some wireframes for how we should expand on it.
Target Milestone: 4.0.4 → 4.0.5
Target Milestone: 4.0.5 → 5.0.1
Boriss - could you suggest some ideas on how to add this to the site?
Assignee: nobody → jboriss
Target Milestone: 5.0.1 → 5.0.3
Assignee: jboriss → nnguyen
Requirements need to be thought out in more detail before we start designing UI.
(Assignee)

Updated

9 years ago
Target Milestone: 5.0.3 → 5.0.1
(Assignee)

Comment 10

9 years ago
Can anyone think of examples of pay or license restricted add-ons (from an end user perspective?)

If not, I'd be wary of having too much emphasis placed on developer licenses as it could be quite confusing for consumers.  For instance- cooliris is definitely not open source, but is also free to use.

As we explore ideas like monetary donations, we should revisit this.
Well, I do think we should make licensing info accessible. It able to spark creativity, which we live off at AMO and stand for as Mozilla. In that context, I think we should promote openly licensed content on AMO, so people know what they can build off and contribute to.

On the other hand, I agree with you: Rubbing a code license into every consumer's face first thing on the page may result in them thinking they can't *use* copyrighted add-ons for free, quite the opposite of what we want to do.

I think I like the idea of mentioning different kinds of contributions (donations, code contributions) that you are hinting at here.
(Reporter)

Comment 12

9 years ago
(In reply to comment #11)
> *use* copyrighted add-ons for free, quite the opposite of what we want to do.

Note that the majority of free software (as per FSF) add-ons are copyrighted.
(Assignee)

Updated

9 years ago
Target Milestone: 5.0.1 → 5.0.2

Updated

9 years ago
Duplicate of this bug: 480429
We did implement source code licenses (bug 483897), so this is fixed.
Blocks: 483897
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: 5.0.2 → 5.0.5
Verified.
Status: RESOLVED → VERIFIED

Comment 16

9 years ago
Looks great, just want to say thanks for the work!
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.