Drop support for type="timed" for textboxes

RESOLVED FIXED in Firefox 59

Status

()

RESOLVED FIXED
11 years ago
a year ago

People

(Reporter: dao, Assigned: dao)

Tracking

(Blocks: 2 bugs)

Trunk
mozilla59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
It seems that all of our timed textboxes are search / filter fields. We should:

1. use type="search" for those textboxes,
2. maybe map type="timed" to the search binding for one major release,
3. eventually remove support for type="timed".
(Assignee)

Updated

11 years ago
Depends on: 449375, 449661, 449664, 449669
(Assignee)

Updated

11 years ago
No longer depends on: 449664
(Assignee)

Updated

11 years ago
Depends on: 405892
(Assignee)

Updated

11 years ago
Depends on: 449690
(Assignee)

Updated

11 years ago
Summary: Remove the timed textbox binding → Drop support for type="timed" for textboxes
Target Milestone: --- → mozilla2.0
(Assignee)

Updated

11 years ago
Depends on: 450733
Depends on: 451002
It seems weird to assume a specific function (search) from a UI behavior.  

Are there changes in functionality implied in the switch from timed to search?  

FYI, I'm using a timed textbox in a non-search related dialog (the autoconfig dialog for account creation in thunderbird).  

I would change to "search" if I still get the timed-like behavior, but it feels odd.

(aside: MDC needs to be updated if this happens: http://developer.mozilla.org/index.php?title=En/XUL/Attribute/Textbox.type&highlight=textbox+search)
(Assignee)

Comment 2

11 years ago
(In reply to comment #1)
> It seems weird to assume a specific function (search) from a UI behavior.

It's just an observation. The vast majority of timed textboxes are used for searching / filtering.
Your autoconfig dialog is in fact the first and only exception that I know of. It's a valid use case, though. I'm not sure if that justifies keeping the binding in toolkit. In such rare cases the desired behavior could be achieved easily using oninput and a custom timer. I would advise against using type="search".
Depends on: 451852
Depends on: 471778

Comment 3

10 years ago
timed is a general behavior, it has nothing to do with the specialization of the textbox (such has search).  Timed textbox are useful when associated with 'number' textbox for updating  numerical property in 'real-time'. 

Support for timed textbox could be enabled when 'timeout' attribute is specified.
Target Milestone: mozilla2.0 → ---
(Assignee)

Updated

2 years ago
Blocks: 1387013
(Assignee)

Updated

a year ago
Blocks: 1397874
(Assignee)

Updated

a year ago
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Keywords: meta
Comment hidden (mozreview-request)
(Assignee)

Updated

a year ago
Attachment #8940317 - Flags: review?(enndeakin)
Duplicate of this bug: 1422369

Comment 6

a year ago
mozreview-review
Comment on attachment 8940317 [details]
Bug 449045 - Drop support for type="timed" textboxes.

https://reviewboard.mozilla.org/r/210598/#review216690
Attachment #8940317 - Flags: review?(enndeakin) → review+

Comment 7

a year ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/eef0978b42ad
Drop support for type=timed textboxes. r=enn

Comment 8

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/eef0978b42ad
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox59: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.