Closed Bug 450038 Opened 11 years ago Closed 11 years ago

"Help | Shredder Help" doesn't redirect to a help site of the applications locale

Categories

(Thunderbird :: Help Documentation, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b1

People

(Reporter: whimboo, Assigned: sipaq)

References

Details

Attachments

(1 file)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.2pre) Gecko/2008072822 Thunderbird/3.0a2 ID:2008072822

Using the above version of Thunderbird which is the candidate build of alpha2 I don't get German help pages when clicking on "Help | Shredder Help". Instead I get redirected to http://www.mozilla.com/en-US/. No idea how many other locales are affected. But as long as we don't have an official support site for Thunderbird any locale should have an URL to a translated version. Where are they located right now?
Flags: blocking-thunderbird3?
Summary: [de] "Help | Thunderbird Help" doesn't redirect to a German help site → "Help | Shredder Help" doesn't redirect to a help site of the applications locale
We don't have a story for this yet, but I think there are already similar bugs filed.
Whiteboard: dupeme?
(In reply to comment #0)
> Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.2pre)
> Gecko/2008072822 Thunderbird/3.0a2 ID:2008072822

That doesn't look like the right UA for the German build, but that could be a different problem.

> Using the above version of Thunderbird which is the candidate build of alpha2 I
> don't get German help pages when clicking on "Help | Shredder Help". Instead I
> get redirected to http://www.mozilla.com/en-US/. No idea how many other locales
> are affected. But as long as we don't have an official support site for
> Thunderbird any locale should have an URL to a translated version. Where are
> they located right now?

I just found this in the seamonkey files:

http://bonsai-l10n.mozilla.org/cvslog.cgi?file=l10n/de/mail/chrome/messenger-region/region.properties&rev=HEAD&mark=1.17

http://bonsai-l10n.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=region.properties&branch=&root=/l10n&subdir=l10n/de/mail/chrome/messenger-region&command=DIFF_FRAMESET&rev1=1.16&rev2=1.17

So it looks like the mozilla-world.org redirects which were probably in place at the time of the alpha 2 source, are no longer in place.
This Bug is for 2.0.0.*, too.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 448134
Having problems finding bugs where I'm already cc'ed. :/
Status: RESOLVED → VERIFIED
Flags: blocking-thunderbird3?
Sorry, not a dupe. We should use this bug as tracker for other locales, because I'm able to reproduce this also for French. Mostly every locale should be redirected to a localized version of the help documentation or a support site.
Status: VERIFIED → REOPENED
Depends on: 448134
Resolution: DUPLICATE → ---
IMO is up to the new Mozilla Messaging team to decide/communicate where the in-product links should go to.
The help link is here:
http://mxr.mozilla.org/mozilla/search?string=mailnews.hints_and_tips.url&find=mail&tree=mozilla 

Here's what the existing localizations make out of it:
http://mxr.mozilla.org/l10n/search?string=mailnews.hints_and_tips.url

(I know these are all old cvs trunk links, but AFAIK there haven't been any changes to those yet and I don't know how to produce similar links for hg.mozilla.org.)

Most localizations just point to the same place that en-US does. These are:
fr, ne-NP, gu-IN, mk, ga-IE, eu, af, hi-IN, el, tr, mn, en-GB, pl, da,
ka, he, pt-PT, ta, be, sl, nb-NO, zh-TW, es-ES, bn-IN, es-AR, ro,
nn-NO, pa-IN, sr, lt, si, fi, sv-SE

Some point to their own content:
de, ko, ca, ja, ja-JP-mac, hu, cs, zh-CN

The rest either points to broken or 404 pages on Mozilla sites:
sq, sk, nl, uk, bg, pt-BR, ru, fy-NL, it 
This certainly blocks tb3, and it might want to block 3.0b1 as well.
Flags: blocking-thunderbird3.0b1?
Flags: blocking-thunderbird3+
Feels right, yup.
Flags: blocking-thunderbird3.0b1? → blocking-thunderbird3.0b1+
OS: Mac OS X → All
Whiteboard: dupeme?
David & co,

So what's the way forward here?

At the moment I believe that most of the locales have already fixed their links and just picking up the latest would fix this bug.

Alternatively, is it get the MoMo website set up and redirects enabled, and point help at the site? or something different?
Whiteboard: [needs owner][needs proposal]
As can be seen from the 1.8 mxr query, we have ton's of links for Thunderbird 2.0.0.x that are broken and not fixed.

We should really have a story for those, too.

I'm not confident that just changing them over to mozilla-europe for now wouldn't break things the next day, just like mozilla-world just silently broke.
Simon, is this something you'd be willing to drive for 3.0b1?
Assignee: nobody → bugzilla
Status: REOPENED → NEW
I'll setup a post to localizers in md.l10n
Status: NEW → ASSIGNED
Doing ~ what firefox does (but url pointing to mome + possibly redirects) sounds like the best option to me.
http://mxr.mozilla.org/seamonkey/source/browser/base/content/utilityOverlay.js#676
Depends on: 440495
Whiteboard: [needs owner][needs proposal] → [needs proposal]
Target Milestone: --- → Thunderbird 3.0b1
Switching for b1 flags to target milestones, to avoid flag churn.
Priority: -- → P2
Blocks: 309371
Duplicate of this bug: 453158
Whiteboard: [needs proposal] → [needs input sipaq]
I filed Bug 453795 to get redirects set up for all affected languages on the 1.8 branch (TB2). This should also fix the immediate issue for TB3 builds.

In the long run, we need a localizable site structure on mozillamessaging.com and a fully customizable support string, 

  e.g. http://www.mozillamessaging.com/%locale%/%app%/support

and then set up redirects to localized content directly on mozillamessaging so that we aren't depending any longer on Mozilla IT.
Depends on: 453795
gozer, could you take a look at comment 18 and see if that URL is ok, or do you want something different?
Whiteboard: [needs input sipaq] → [needs input gozer]
There are really 2 different URLs of interest.

First, the ones baked in into the client itself, these should always be of the form:

http://(.*\.)?live.mozillamessaging.com/[xxx]

So, a suggestion in this case could be:

http://support.live.mozillamessaging.com/%locale%/%app%/%buildid%

The idea with these is that we hopefully should never need to change what the TB builds end up requesting.

Second, is where we actually host the content, and the urls like above just end up redirecting there, so for that purpose:

http://www.mozillamessaging.com/%locale%/%app%/support

is a fine place to *actually host* the content.
3.0b1 flag is going away in favour of 3.0 flag and milestone combination.
Flags: blocking-thunderbird3.0b1+
So the proposal here is that we change the URLs to use mozillamessaging.com redirects by default.

Currently we have no support page on mozillamessaging.com (although we could redirect to http://www.mozilla.org/support/thunderbird/ for now).

Are we doing this for TB 3.0b1? I am not convinced that we have enough of the l10n website structure in place to make this reasonable, and I think we also haven't thought about methods for allowing localizers to either localize that page or how to request redirects to thier own sites.

I think for TB 3.0b1 we have the following (reasonable) choices:

a) Leave the Thunderbird Help option as it is, redirecting to http://www.mozilla.org/support/thunderbird/
b) Change the en-US link to point to the mozillamessaging site redirects and possibly move the content or just point to the old page.

If we want to do option b, then we should do it by Tuesday 23:59 PDT as otherwise it'll be a late string change which I'd prefer to avoid.
Whiteboard: [needs input gozer] → [needs input]
Per our status meeting today, the string freeze is tomorrow, we need to change a string so that we can point to mozillamessaging.com for the redirects for beta 1. This will probably move to being hard coded for beta 2.

There is no content/redirects existing at this moment in time. We will sort out the default redirect (i.e. to en-US content) out asap, certainly before beta 1 (I'll raise a bug tomorrow).

We also need to resolve how we're going to set up redirects for different locales etc. At worst, locales can still localize the url.

Simon, can you talk to David Ascher/gozer and others on that point please.
Attachment #338930 - Flags: review?(dmose)
Comment on attachment 338930 [details] [diff] [review]
[checked in] Change support url to point to Mozilla Messaging site

Looks good; r=dmose.
Attachment #338930 - Flags: review?(dmose) → review+
Attachment #338930 - Attachment description: Change support url to point to Mozilla Messaging site → [checked in] Change support url to point to Mozilla Messaging site
Comment on attachment 338930 [details] [diff] [review]
[checked in] Change support url to point to Mozilla Messaging site

Checked in, changeset id: 343:4c8b7768fc76
Whiteboard: [needs input] → [needs redirects setting up][needs documentation]
I have set up bug 455843 for moving the current support content from the www.mozilla.org site to www.mozillamessaging.com (where it can be localised).

I believe what is remaining for this bug is to inform the localiser teams of what has been decided etc, and come to a decision/set up methods for doing the individual redirects and or setting up new content on mozillamessaging.com.

This may already be covered elsewhere, but I don't see anything for it at the moment.
Blocks: 455843
Whiteboard: [needs redirects setting up][needs documentation] → [needs documentation]
Whiteboard: [needs documentation] → [needs update sipaq about l10n status]
It is believed that all the worked that's needed for beta 1 has been done, moving the target milestone out.
Target Milestone: Thunderbird 3.0b1 → Thunderbird 3.0b2
This bug is considered fixed. We still need to figure out the l10n capability for website pages, please can Simon/Pascal figure that out elsewhere and file appropriate bugs to set it up.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Whiteboard: [needs update sipaq about l10n status]
Duplicate of this bug: 369445
You need to log in before you can comment on or make changes to this bug.