Closed Bug 452254 Opened 11 years ago Closed 6 years ago

Register for audio/video .ogg and .pdf file handlers if nothing else has

Categories

(Firefox :: Installer, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox31 --- verified
relnote-firefox --- 31+

People

(Reporter: gerv, Assigned: robert.strong.bugs)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

If there is no registered handler on the system for the Ogg Vorbis/Theora MIME types, Firefox should register for them. 

This would mean that X tens of millions of Windows users would suddenly have an application installed which would play Ogg files if they double-clicked on them. This would be good for the spread of free media formats.

Gerv
No longer depends on: 452253
Component: Video/Audio → OS Integration
Product: Core → Firefox
QA Contact: video.audio → os.integration
Version: unspecified → Trunk
This might be a different issue, but would implementing this affect whether audio/ogg, video/ogg, etc. show up in the Applications prefpane list and thus whether the user is able to choose to override Firefox playing OGG files?

I think that's quite important because as it is currently, if for example I want to use the VLC plugin in Firefox to play OGG videos in the browser rather than the native Firefox support, there's no way that I can see of changing that.
Attached patch patch (obsolete) — Splinter Review
Something like this, I guess.  Unfortunately I can't test it, as I don't have a win32 build environment.

Btw, I applaud Mozilla's commitment to patent-free codecs.  Your efforts are much appreciated.
We will likely want to also do oga... I'll take a look at what this will entail tonight.
Alex, what are the chances of getting a set of Windows icons for this? We'd need them for both ogg audio and ogg video. Thanks
After a quick look into this we should register file handlers for oga, ogg, and ogv if there aren't already file handlers for these types for Win32 on install, update, and when setting as the default browser.

Instead of using the FirefoxHTML handler in the registry we should use a new one so we can have a different icon than the Firefox html document icon.

I'll look into what it will take to have the OS hand off the audio/ogg and video/ogg mime types.

What about application/ogg?

Are there plans to support ogx?
(In reply to comment #5)
> Instead of using the FirefoxHTML handler in the registry we should use a new
> one so we can have a different icon than the Firefox html document icon.

Maybe the one from http://en.wikipedia.org/wiki/File:XiphophorusLogoSVG.svg helps.  Although arrangements for a copyright license might be necessary.

> I'll look into what it will take to have the OS hand off the audio/ogg and
> video/ogg mime types.
> 
> What about application/ogg?

application/ogg properly identifies the container already (the probe is easy, I can write the NSIS magic to inspect the file if you like).  What do you need audio/ogg and video/ogg for?  I thought this was just a matter on how users name the file.

> Are there plans to support ogx?

AFAICT by supporting Vorbis & Theora you already do.
NSIS just adds the settings to the registry and wouldn't inspect the files.

file types in the registry have an associated mimetype and perceived type where oga would either have audio/ogg or perhaps application/ogg as the mimetype and would have audio as the perceived type.

I would also like to have the mimetype handled by Shiretoko when other apps try to open this mimetype and aren't able to.

I tried opening a local ogx file and Shiretoko asked me to save it. Can you post a link to a download of a sample ogx file?
(In reply to comment #7)
> I tried opening a local ogx file and Shiretoko asked me to save it. Can you
> post a link to a download of a sample ogx file?

According to http://wiki.xiph.org/index.php/MIME_Types_and_File_Extensions#.ogx_-_application.2Fogg any OGG with multiple streams (e.g. video + audio) qualifies as OGX.
I took a look at the file registrations made by installing http://xiph.org/dshow/ and they only registered .oga, .ogg, and .ogv and since I wasn't able to find any sample .ogx files I don't think we should add a file registration for .ogx.
Nominating as "wanted for 3.1". A small change but important in promoting open formats in general (and therefore open formats on the web) because it makes it much easier for people to play them.

Can we do this on the Mac also? Would that be an entirely different change?

Gerv
Flags: wanted-firefox3.1?
It has been a while since I've looked at how this would need to be done on Mac OS X so I don't know atm. Getting the Win32 changes in will be a big enough stretch for me so I'd prefer to have someone more familiar with Mac OS X do this for Mac OS X.
>Alex, what are the chances of getting a set of Windows icons for this? We'd
>need them for both ogg audio and ogg video.

If we have icons already checked in before the freeze then we can just do file drop ins before RC1.  Depending on the time between Beta 3 and RC1, I think we will be ok.

>Maybe the one from http://en.wikipedia.org/wiki/File:XiphophorusLogoSVG.svg
>helps.  Although arrangements for a copyright license might be necessary.

Here's what I propose:
-We hire a high end design firm to create a new logo for ogg.  If we have enough time we combine this with community brainstorming, similar to the Ubiquity process.
-We free the logo so anyone else can use it
-We try to get xiph to uplift the artwork for ogg, to help make it a more universal symbol for the format.
Also, I noticed this on xiph.org:

>The Xiph Fish Logo and the Vorbis.com many-fish logos are trademarks (™) of >Xiph.Org.

So it looks like original artwork is going to be a requirement for our licensing.  This isn't totally uncharted territory in that we did a similar thing with RSS in the creation of the Web Feed logo, although that didn't really have an organization behind it similar to this case.  We should of course try to get a sense of how xiph feels about us attempting to evangelize a new iconic symbol for ogg.
(In reply to comment #13)
> Also, I noticed this on xiph.org:
> 
> >The Xiph Fish Logo and the Vorbis.com many-fish logos are trademarks (™) of >Xiph.Org.
> 
> So it looks like original artwork is going to be a requirement for our
> licensing.

I don't think that's a problem.  You'd have to ask a lawyer to be sure, but using Xiph's trademarks to refer to Xiph's format looks entirely like Fair Use to me.

Of course, you could ask the Xiph Foundation too.  There's no reason to believe they'll have a problem with their trademark being used this way.

_Copyright_, OTOH, looks like an entirely different issue.  I think copyright-wise their logos are basically unlicensed.  But it's probably not hard to get them to use GPL / MPL / whatever suits your needs.
I agree with Robert that this would be appropriate use. In addition, we (Xiph) generally give explicit permission to use our trademarks on compatible implementations. Since you're using the Xiph reference implementation, I expect using the fish on any icons makes sense for everyone.

I don't think we have a problem releasing a logo file under a free copyright license. Just don't use the file from that wikipedia page; it's a bad trace of an old version. I'll ask around and see what we can do. What license(s) would be acceptable?

An alternative is just to use the firefox logo, specialized to show it's an audio or video file. This is the approach VLC takes with ogg files.
I've confirmed Xiph is ok with using the Xiph fish trademark to indicate ogg files and support for playing them. It might be appropriate to add the text "The Xiph Fish logo is a trademark of Xiph.org" to about:license.

Let me know what you want and I'll attach a properly licensed vector art file. In the meantime, a version of the current logo is available in http://people.xiph.org/~xiphmont/logos/xiphFish.pdf

I agree with Robert in #9: it's worth making file icon(s) and associations for .ogg, .ogv, and .oga, but not .ogx. They should be associated with application/ogg, video/ogg and audio/ogg media types.
Note: I will definitely try to get this done for Firefox 3.1 Win32 but no promises... I'll try to put it all together this weekend.

Since it is likely that someone else will need to do this for Mac OS X and Linux I'm going to make this bug about Win32 and file new bugs for Mac OS X and Linux.
Assignee: nobody → robert.bugzilla
Robert: let's just duplicate some of our existing icons as placeholders until we figure out exactly what icon we want to include, that will allow us to do a file drop before RC1 without any code changes.
It looks like we probably aren't going to get new icons for this, at least not in time for 3.1, so tagging for cleanup with 3.2 (assuming we aren't installing codecs for the local players by then).
Whiteboard: [icon-3.2]
(In reply to comment #19)
> It looks like we probably aren't going to get new icons for this, at least not
> in time for 3.1, so tagging for cleanup with 3.2 (assuming we aren't installing
> codecs for the local players by then).

Even if you won't be making a decision about the icons for 3.1, will you still add the file associations?  I think it's very important that you do, it would be a pity if that had to be post-poned because of the icons.
nominating this for consideration of blocking 3.5.  If video is going to be a first class citizen in Firefox then it seems like this really ought to happen.
Flags: blocking-firefox3.1?
Firefox is not, and should not, set out to become a default media player. While I'd probably approve a fix, I don't think we'd hold release for one.
Flags: wanted-firefox3.5?
Flags: wanted-firefox3.5+
Flags: blocking-firefox3.5?
Flags: blocking-firefox3.5-
This is pretty unconventional, but just to brainstorm: what if we registered as the default player, but then on open navigated the user to a help page suggesting some actually decent players (like VLC).
Alex: you're a usability guy. Have you ever used VLC? 

rs: I think we probably missed the boat on this for 3.6. Are you still working on it?

Gerv
>Alex: you're a usability guy. Have you ever used VLC? 

I'm not really statistically significant :)

Overall I agree with both Gerv (if no one is registered, we clearly help the format by registering ourselves so users can at least double click on files), and also with beltzner (we aren't a full featured media player and shouldn't try to be).  What do people think of playing the file in a chromeless window with a notification bar that promotes other media players capable of playing the files?

But even that is kind of a half step and requires user intervention, I think the ideal solution would be that Firefox correctly installs the right codecs so the system's default media player can handle the files, and takes care of the registration as well. So after you install Firefox, everything Just Works.
Faaborg: we ship our own versions of the codecs which aren't suitable for system-wide installation. So if we were to do your second suggestion, that would increase our download size (unless we downloaded them later) and might well be seen as the sort of stealth installation of software which we have publicly objected to when it's done by others.

I don't think we need to worry that other, better, media players, if installed after us, will have any trouble wresting the file associations from us. We could even make it known that we were happy for software which can play Ogg to do this without asking the user. Even if we didn't, people will just click "OK" on the startup dialog they all use: "can ownz media formatz plz?". 

The trouble with the chromeless window approach is that, while registering for filetypes is a few lines of code, that sort of thing (plus the management of the "recommended" list) would be significantly more effort.

We could do:

"Firefox is playing this video because it is the only program installed on your system which can. Click here to install codecs so your normal media player can play them" and link to DirectShow/QT codecs from Xiph. Rather than plugging new media players.

Gerv
(In reply to comment #24)
> Alex: you're a usability guy. Have you ever used VLC? 
> 
> rs: I think we probably missed the boat on this for 3.6. Are you still working
> on it?
nope though I am fine with adding it.
Jim, forgot this bug was assigned to me... are you ok with doing this since you did webm?
Assignee: robert.bugzilla → nobody
Component: Shell Integration → Installer
QA Contact: shell.integration → installer
It's not identical to this, but I filed and fixed bug 650451, which is about having Firefox associate media types on Mac.  When I filed that ticket, it was because chromium had set a default association.
Attached patch patch rev1Splinter Review
Gavin, do you think we should still do this for oga, ogg, ogv, and pdf (bug 746102)? If so, do you have a problem with doing it with using our file icon since artwork has been the bottleneck? Note: it was done for webm quite some time ago using our file icon.
Assignee: jmathies → robert.strong.bugs
Status: NEW → ASSIGNED
Attachment #8398838 - Flags: feedback?(gavin.sharp)
Attachment #8398838 - Flags: feedback?(gavin.sharp) → feedback+
Comment on attachment 8398838 [details] [diff] [review]
patch rev1

awesome, I've removed all adobe products from my system so I appreciate the addition of pdf.
Attachment #8398838 - Flags: review?(jmathies) → review+
Pushed to fx-team
https://hg.mozilla.org/integration/fx-team/rev/4e1172fa51ea
Summary: Register for audio/ogg and video/ogg MIME types if nothing else has → Register for audio/video .ogg and .pdf file handlers if nothing else has
Target Milestone: --- → Firefox 31
https://hg.mozilla.org/mozilla-central/rev/4e1172fa51ea
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Added to the release notes with:
"Register for audio/video .ogg and .pdf file handlers under Windows if nothing else has"
Note updated to "In Windows audio/video .ogg and .pdf files handled by Firefox if no application specified"
I think we should try to use different icons for these files. I've filed bug 100783.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

I tried to verify this with Firefox 31.0 beta 9 and found the following behavior:
* at update from older version (30.0 beta 9) or clean install (custom/standard) without setting the browser as default, the .oga, .ogv, .ogg and .pdf files are not associated with Firefox: icon is blank, double click on file shows "Windows can't open this file" dialog, but drag & drop the file in a browser window opens the file
* at clean install with setting the browser as default or setting the browser as default from Options>Advanced, the .oga, .ogv, .ogg and .pdf files are associated with Firefox and double clicking opens them with Firefox
* setting other browser (e.g. Chrome) as default (after the .oga, .ogv, .ogg and .pdf files were associate with Firefox) leaves those files associated with Firefox
* uninstalling Firefox _clears_ the file association, if other Firefox versions are installed but _not_set_ default
* uninstalling Firefox _leaves_ the file association, if other Firefox versions are installed and _set_ default

Are all these this expected?
Flags: needinfo?(robert.strong.bugs)
Yes it is and thanks!
Flags: needinfo?(robert.strong.bugs)
Status: RESOLVED → VERIFIED
Keywords: verifyme
requesting clarification regarding “audio/video .ogg and .pdf files handled by Firefox if no application specified (Windows only)”.
Thought Firefox defaulted to 'Preview in Firefox' & this was done a while ago.
Rgds.
Sorry, I'm not sure what you're asking here. Does the new support not work for you?
This is for file handlers... what you are referring to are in content handlers.
Depends on: 1049521
Depends on: 1197191
You need to log in before you can comment on or make changes to this bug.