Default composition font choice lost around signature

RESOLVED DUPLICATE of bug 250539

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 250539
9 years ago
7 years ago

People

(Reporter: Aaron Kelley, Unassigned)

Tracking

unspecified
x86
Windows Vista
Bug Flags:
blocking-thunderbird3 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1 (.NET CLR 3.5.30729)
Build Identifier: version 3.0a2 (2008072418)

Using a plain text signature, it is easy to have Thunderbird lose your default composition font choice if you do not start typing your new message right away.  This is an annoying bug that can be reproduced under Thunderbird 2.0.0.16 and Thunderbird 3.0 Alpha 2.

Reproducible: Always

Steps to Reproduce:
1. Choose a non-standard font as the HTML composition font in Tools -> Options, Composition tab.
2. Have an account with a plain text file specified for the signature.
3. Create a new mail message using this account.
4. Click in the message body where you should start typing, at the top of the message.  Notice that your font choice is preserved.
5. Click down near the signature (that should have been added by default).  Notice that your font choice is now lost.
6. Click back up at the top.  Your font choice is still lost.

(See attached screen shot, animated GIF.)

Actual Results:  
Thunderbird is not respecting my composition font choice...  It's been lost, and I have to either select the font from the list again or close the message window and open a new one to get the font back.

Expected Results:  
Thunderbird should respect my composition font choice.
(Reporter)

Comment 1

9 years ago
Created attachment 336219 [details]
Animated GIF discribing the problem; 10 second frames
(Reporter)

Updated

9 years ago
Flags: blocking-thunderbird3?

Comment 2

9 years ago
I don't think this is a blocker. xref bug 204632 (which suggest the workaround is to use a html sig file for html composition)
Flags: blocking-thunderbird3? → blocking-thunderbird3-

Updated

9 years ago
Blocks: 394732
(Reporter)

Comment 3

9 years ago
Note:
Using an HTML signature does not solve or workaround this problem.

With an HTML signature, you can specify the font to be used in the signature -- this is what was being discussed in the bug you mentioned.

The problem I am bringing up has to do with the font of the actual body of the message not respecting the choice you made as the default composition font.

Comment 4

8 years ago
I still see this in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090404 Lightning/1.0pre Shredder/3.1a1pre ID:20090419051533

Very frustrating plus we need to change this bug to 'Confirmed'.

Comment 5

8 years ago
I can confirm this in T

Comment 6

8 years ago
It seems there are many ways to trigger this bug. Here's a list I obtained from a quick search of Compose Window bugs:

Bug 248377 (NEW, > 5 years old)
Bug 489216
Bug 386324
Bug 480815
Bug 452987 (This bug)
Bug 485646
Bug 475448

All of these bugs relate somehow to the font reverting to Variable Width following some form of innocent navigation in the Compose window.

Updated

8 years ago
Duplicate of this bug: 492628

Updated

8 years ago
Duplicate of this bug: 502986
This issue is true, but I think that is basically a dupe of bug #250539.

Feel free to reopen it if I'm wrong (see for example bug #250539 comment #65).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250539

Updated

7 years ago
No longer blocks: 394732
You need to log in before you can comment on or make changes to this bug.