autocomplete for all existing about: URIs after typing "about:"

NEW
Unassigned

Status

()

Firefox
Address Bar
P3
enhancement
10 years ago
4 months ago

People

(Reporter: jan klopper, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3

It would be really nice to have about: completion for the address bar, currently finding the possible options is hard since they are undocumented in the interface.

If you want to find a specific about: page, but do not know the exact name its hard to locate it.

Reproducible: Always

Steps to Reproduce:
1. type about: in the address bar
2. notice you do not know the precise name for the plugins name
3. go onto the web and try to formulate a search query which helps you out without knowing the name of the page you are looking for


Expected Results:  
Type about: in the address bar and have a list of the available pages

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 417965
(Reporter)

Comment 2

10 years ago
I didn't mean previously visited about: pages, but since there's presumably a list of available about: pages, An autocomplete function would be "awesome" (pun intended).

Comment 3

10 years ago
Un-duping. Bug 417965 requests that autocomplete work on visited about: URIs. This bug requests autocomplete for _all_ about: URIs after typing the "about:", without having to visit them at all first. Interesting idea.
Status: RESOLVED → UNCONFIRMED
OS: Linux → All
Hardware: PC → All
Resolution: DUPLICATE → ---
Summary: about: completion for Awesomebar → autocomplete for all existing about: URIs after typing "about:"
(Reporter)

Comment 4

10 years ago
Dave, thanks.

The "about:" could even be a page with links pointing to the available about pages.

Comment 5

10 years ago
(In reply to comment #4)
> The "about:" could even be a page with links pointing to the available about
> pages.

There is already an "about:" page. There used to be an about:about which did this.
(Reporter)

Comment 6

10 years ago
Hmm, that page now just breaks for me,

Firefox can't find the file at jar:file:///usr/lib/xulrunner-1.9.0.3/chrome/toolkit.jar!/content/global/aboutAbout.html.

This on Ubuntu (so this might be Ubuntu specific, im not sure.

The correct url seems to be:
jar:file:///usr/lib/xulrunner-1.9.0.3/chrome/toolkit.jar!/content/global/about.xhtml

Which only links to a few about pages: licence, buildconfig and credits

Comment 7

10 years ago
"about:" is that page; "about:about" does not exist. (bug 349451)

Comment 8

10 years ago
Confirming as an enhancement request.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Duplicate of this bug: 539557
Duplicate of this bug: 417965
i'm not sure if the additional code needed to support this is worth the gain. and about:about exists.

How often users have the need to "discover" about: pages? usually you go to an about: page on request (either support, options tweaking, reading an article on Firefox, filing a crash bug) all of these tasks presume you know where you're going, and discovering about:mozilla and about:robots exist does not help your task at all.

clearly "uiwanted".
Keywords: uiwanted

Comment 12

8 years ago
(In reply to comment #11)
> and about:about exists.

Firefox just gives "The URL is not valid and cannot be loaded." which seems to be the expected behavior based on bug 349451 comment 46.

> How often users have the need to "discover" about: pages? usually you go to an
> about: page on request (either support, options tweaking, reading an article on
> Firefox, filing a crash bug) all of these tasks presume you know where you're
> going, and discovering about:mozilla and about:robots exist does not help your
> task at all.

In the autocomplete list you could sort the most likely to be needed ones like about:support, about:crashes, about:plugins, etc. up top and leave the about:robots and the like at the bottom, though further autocompleting for example "about:rob" would of course be expected to narrow it down further.
Now that there's a already a whitelisted set of about: pages as part of about:about, the behavior should be to show the available pages in the pulldown once you have typed "about:" in the location bar.
Keywords: uiwanted

Updated

8 years ago
Duplicate of this bug: 598448

Updated

7 years ago
Duplicate of this bug: 644586

Comment 16

7 years ago
Another partial solution would be to simply treat them the same as other URIs: have autocompletion on for about: URIs.

If I've visited http://mozilla.org/ it appears for autocompletion when I write either the title or the URL. If I've visited about:config, it should use that URI for autocompletion the same way.

Updated

6 years ago
Duplicate of this bug: 798767

Updated

5 years ago
Duplicate of this bug: 856301

Updated

4 years ago
Duplicate of this bug: 1022740

Updated

4 years ago
Duplicate of this bug: 1043427
bug 1043427 isn't really the same; it asks to remember about: URLs in the awesomebar just like normal browsing history is remembered.

Comment 22

4 years ago
(In reply to Kumar McMillan [:kumar] (needinfo for quickness) from comment #21)
> bug 1043427 isn't really the same; it asks to remember about: URLs in the
> awesomebar just like normal browsing history is remembered.

That would be bug 417965. They're two different solutions to the same issue. The decision in that bug was to move to this one. Technically, you could redupe to that one instead if you'd prefer, however I chose to dupe to this open bug rather than to an old WONTFIX. (duping is half about pointing the reporter/CCed to the intended existing bug on the topic, so duping to a bug no longer in use isn't ideal for issues which are not settled)
regardless we don't plan to add about uris to history, at a maximum they will be added as special results in the locationbar.

Updated

4 years ago
Duplicate of this bug: 1096104
Duplicate of this bug: 1407979

Updated

4 months ago
Duplicate of this bug: 1436971

Updated

4 months ago
Blocks: 1425024
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.