Closed Bug 468072 Opened 11 years ago Closed 2 years ago

Check add-on compatibility *BEFORE* running automatic updates

Categories

(Firefox :: Extension Compatibility, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: bertrand.denoix, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 MultiZilla/1.8.3.4e SeaMonkey/1.1.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

When using the automatic updates, there is no simple way to know what add-ons will be flagged as without any compatible version (installed or downloadable). The update confirmation dialog should list these so that the user can tell what is going to happen.

Reproducible: Always

Steps to Reproduce:
1.Install add-on (say, Firebug)
2.Wait for auto-update
3.Discover Firebug has been disabled



Tell me: "This update will install Firefox 3.0.4. The following add-ons aren't compatible with this version of Firefox, and there is currently no upgrade version: Firebug 1.0.5, Copy Links 0.1.4. Proceed with install? Yes/Retry in 3 days/No"
Duplicate of this bug: 664948
It is a necessary feature in the rapid development cycle Mozilla community now employs.

In Romania at least there are a lot of grumpy users because they find out only after update that their favourite add-ons don't work any more. 

Most of them don't know about ftp.mozilla.org to install the older version and all the links on mozilla.org point to the last version only (even pages about old releases - changelog).

Is there any plan to develop such a feature? Or any hint on where to start developing such a feature?
As a data point, four of the eight extensions I currently have installed claim to be incompatible with the latest version of Seamonkey. This is pretty hopeless.
At EU MozCamp, it's been revealed the plan is to automatically declare all add-ons compatible with latest versions of Firefox. At least, this was my understanding.

Then it will be a community effort to report incompatible add-ons. Is this right?
(In reply to Tiberiu C. Turbureanu from comment #5)
> At EU MozCamp, it's been revealed the plan is to automatically declare all
> add-ons compatible with latest versions of Firefox. At least, this was my
> understanding.
> 
> Then it will be a community effort to report incompatible add-ons. Is this
> right?

Pretty much, yes: https://wiki.mozilla.org/Features/Add-ons/Add-ons_Default_to_Compatible
Status: UNCONFIRMED → NEW
Ever confirmed: true
According to other bugs, incompatible add-ons are listed before updating Firefox.

For the other parts, see also:
* Bug 663506 - If a user has incompatible add-ons, increase the update nag time
* Bug 670302 - Provide some indication whether there are incompatible add-ons on the first page before clicking the update button
* Bug 708396 - Updates should not be offered if AMO is down and the user has incompatible add-ons
* Bug 715607 - Update the flow for users with incompatible add-ons (now that we are default to compatible)
* Bug 762586 - Firefox disabled GWT
* Bug 791485 - Allow marking add-ons "must have" to avoid incompatible updates
* Bug 814830 - Unable to cancel update when warned about an incompatible add-on
This will rarely be valid with WebExtensions, so closing.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Rarely, or never?
You need to log in before you can comment on or make changes to this bug.