"This website does not supply identity information" popup partially blocks ability to drop urls into toolbar

VERIFIED FIXED in mozilla1.9.3a1

Status

()

Core
XUL
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: ibatterb, Assigned: Neil Deakin)

Tracking

1.9.0 Branch
mozilla1.9.3a1
Points:
---
Bug Flags:
wanted1.9.1 +
wanted1.9.0.x +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311  Firefox/2.1 ; ooglebot 2.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

For sites that do not supply identity information (presumably non-ssl connections?), a popup displays whenever the mouse cursor is over the site's favicon area, left of the URL. All good so far.

However, when the favicon is dragged (to place the URL onto a toolbar), the popup partially covers the toolbar, and the user is therefore required to hold the mouse buttond own and wait approximately 4-5 seconds for the popup to clear before it can be dropped. A novice user would probably not realise that they had to do this, and an experienced user would likely get frustrated.

Even if the user moves in and clicks and drags the icon away quickly so that their mouse cursor doesn't even hover over the icon for more than a fraction of a second, the "this site does not..." popup still appears a moment later, despite the mouse cursor now being some distance away.

Would it be possible, once the drag operation is underway, for any popup that has been displayed to be cancelled, since the user clearly isn't interested in that information while they're trying to drag and drop the URL.



Reproducible: Always

Steps to Reproduce:
1. Try to drag and drop a URL favicon onto a folder or space in the toolbar directly below the URL itself.
2. Watch the site information popup appear and block the drop target 
3. Wait, while still holding the mouse button down, for it to clear
4. Complete the drop.
Are you sure that you still get this with FF3.0.7 ?
This should be fixed in 3.0.7 (bug 312852)
(Reporter)

Comment 2

9 years ago
Confirmed - the problem is still present in 3.0.7, (downloaded win32 build yesterday)

And apologies for not finding 312852.. I obviously didn't hit on the right search terms.
(Reporter)

Comment 3

9 years ago
Have also just tested on ubuntu 8.04 /  firefox 3.0.7, and see the same problem
(Reporter)

Comment 4

9 years ago
And that's consistent with the comments in bug 312852:

"To be a bit more specific. This bug will be fixed with the upcoming Firefox
3.1b3 and for Firefox 3.2."
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 312852
look at the comments #174 (aproval for 1.9.0.7) and #176 (checkin) and the status whiteboard (verified 1.9.0.7) set by Al Billings in comment #180
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Duplicate of this bug: 493102
Seems like Linux slipped through our verifications for bug 312852. Can someone verify that this problem only occurs on Linux systems? I see it with 3.0.7, Shiretoko and Minefield. But I'm not able to reproduce it on Windows and OS X.
Blocks: 312852
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 3.0 Branch
(Reporter)

Comment 9

9 years ago
I still see it still present in both linux and windows XP

- ubuntu 9.04, firefox 3.0.10
- win xp, firefox 3.0.8
- win xp, firefox 3.0.10
(Reporter)

Comment 10

9 years ago
I thought this isn't going to be fixed until 3.1 though - I'm curious why some people are reporting it fixed in 3.0.x builds
(In reply to comment #9)
> I still see it still present in both linux and windows XP

Do you have any extensions installed which could cause this problem on XP? Can you please run Firefox in Safe Mode to test if it happens too with all extensions disabled? http://support.mozilla.com/kb/Safe+Mode
(Reporter)

Comment 12

9 years ago
Ran in safe mode on xp ("firefox -safe-mode") and saw no change to the behaviour.. the tooltip still appears and blocks the bookmark toolbar.
Ok, I'm able to reproduce this behavior with the following steps for all platforms and Firefox 3.0.10:

1. Open any web page (HTTP/HTTPS)
2. Move the mouse quickly over the favicon and grab it on-the-fly
3. Move around while still holding the left mouse button

With step 3 you will notice that after around 1s the tooltip is shown over the toolbar which blocks the drop action for a couple seconds.

This behavior doesn't happen for recent 3.5 nightly builds. And only on Linux all versions are affected.

Matrix:

            Firefox 3.0.10            Shiretoko          Minefield
OS X              x                       -                  -
Windows           x                       -                  -
Linux             x                       x                  x
Severity: minor → normal
Component: Toolbars → XUL
Product: Firefox → Core
QA Contact: toolbars → xptoolkit.widgets
Version: 3.0 Branch → 1.9.0 Branch
Flags: wanted1.9.0.x?
Flags: blocking1.9.1?
Flags: blocking1.9.0.12?
Hmm, ok. I guess I'll have another look at this.
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Flags: blocking1.9.1? → wanted1.9.1+
Highly annoying, but not a "blocker" for security updates. If we get the trunk fixed we will take a look at approving the patch.
Flags: wanted1.9.0.x?
Flags: wanted1.9.0.x+
Flags: blocking1.9.0.12?
Duplicate of this bug: 501340

Comment 17

9 years ago
I am using version 3.0.12 and the problem's still there; Very annoying I must say!
Is this still an issue on trunk? I think bug 395668 might have fixed this.

Comment 19

9 years ago
It partially fixed the issue.. it still blocks ability to drop but if I move my cursor out of the popup it disappears..
Neil, do we send mouse move events during dragging (after dragstart) on linux?

Updated

8 years ago
Duplicate of this bug: 506783
Duplicate of this bug: 527231
(Assignee)

Comment 23

8 years ago
Created attachment 411130 [details] [diff] [review]
fix

The issue here is because drag and drop is asynchronous on Linux and the mousemove continues to be handled when a drag is started. This patch stops propagation of the mousemove event.

Not sure how correct this is. Thoughts?
Assignee: mstange → enndeakin
Attachment #411130 - Flags: review?(Olli.Pettay)
Comment on attachment 411130 [details] [diff] [review]
fix

Based on the current HTML5 draft this is ok.
Attachment #411130 - Flags: review?(Olli.Pettay) → review+
(Assignee)

Comment 25

8 years ago
http://hg.mozilla.org/mozilla-central/rev/4ec74781e3ec
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → FIXED
Thanks Neil!
Duplicate of this bug: 527850
Verified fixed on trunk with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20091110 Minefield/3.7a1pre

Neil, can we ask for approval for 1.9.2 on that patch?
Status: RESOLVED → VERIFIED
Target Milestone: --- → mozilla1.9.3a1

Comment 29

8 years ago
this problem of Not being able to drag from location box to tabbed folder on bookmark bar still persists in 3.6b6pr 28 December 2009!!!!!
openSuSE 11.2, KDE 4.3.4 All patches using Mozill (FireFox) Namoroka: Mozilla/5.0 (X11; U; Linux i686; uk; rv:1.9.2b6pre) Gecko/20091227 Namoroka/3.6b6pre.

Stop trying to **** us, it's Not fixed.

Landis
(In reply to comment #29)
> Stop trying to bullshit us, it's Not fixed.

Please calm down and follow the etiquette: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

As you can see in the Target Milestone the bug has been fixed for 1.9.3 which corresponds to Firefox 3.7. No patch has been checked in for Firefox 3.6 and given the current status it will not be fixed in 3.6.

Comment 31

8 years ago
Thank you and I'm sorry... 
Too many things went wrong at the same time today.
favicons going away, unable to Help>about, bookmark manager> search turns up empty of Anything.. Slow, blah, blah, blah..

Landis.

Updated

8 years ago
Duplicate of this bug: 550720

Updated

8 years ago
Duplicate of this bug: 564405

Updated

8 years ago
Duplicate of this bug: 589425

Updated

8 years ago
Duplicate of this bug: 589425
You need to log in before you can comment on or make changes to this bug.