All users were logged out of Bugzilla on October 13th, 2018

Traditional chinese characters aren't displayed completely

RESOLVED WONTFIX

Status

()

P2
normal
RESOLVED WONTFIX
9 years ago
8 years ago

People

(Reporter: skempe, Unassigned)

Tracking

({regression})

unspecified
ARM
Windows CE
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.2 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nv], URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: firefox build for WinCE

Some of the traditional chinese characters are missing from the latest firefox build. Internet explorer shows all the chracters. 

firefox build 29th May & later builds --> issue observed (uses GL acceleration)
firefox build 28th May --> issue not observed

Reproducible: Always

Steps to Reproduce:
1.install and run firefox
2.open tw.yahoo.com on wince and on desktop firefox
3.compare both side by side (look above the search text field)
(image twyahoo.JPG showing the issue is attached) 
Actual Results:  
Check the characters above the serach text filed.  on firefox wince you'll notice only on character while on desktop firefox you'll notice two characters. 
The same thing will be noticed on the left hand side under "My".
Internet Explorer on the same WinCE setup shows both the characters. 

Expected Results:  
All characters should be displayed

This is a regression
(Reporter)

Comment 1

9 years ago
Created attachment 387601 [details]
shows the differences between firefox and IE
(Reporter)

Updated

9 years ago
OS: Other → Windows CE
Hardware: Other → ARM

Updated

9 years ago
Keywords: regression
Interesting, this actually worked at some point?

We're going to have some font issues with CJK due to font compression that's in use on Windows CE, but that should've affected builds both before and after the GL accel work.  I'll take a look.
Assignee: nobody → vladimir
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [nv]
I think this isn't just CJK, the "pronunciation" bit at the top of many Wikipedia articles also has blocked-out characters like the screenshot here. EG, http://en.wikipedia.org/wiki/Franz_Schubert

Maybe the CE fonts are just missing a lot of unicode characters?
(Reporter)

Comment 4

9 years ago
>>Interesting, this actually worked at some point?
If I install Non GL accelerated firefox on the same device then I'm able to see all the characters. 

>>Maybe the CE fonts are just missing a lot of unicode characters?
Also the attachement by me has Internet explorer on top on firefox (GL accelerated) on the same device. IE shows all the characters while firefox is missing them.
Component: General → General
Product: Firefox → Core
QA Contact: general → general
I'm not sure about this bug and GL build, behavior shown in the attachment 387601 [details] is similar with bug 490285.

Comment 6

9 years ago
qq.com is completely unreadable, which is an alexa topsite.
Probably it's same issue with bug 489752, and mainly depends on bug 490267.
If not, please remove dependency I've added.
Depends on: 490267

Comment 8

9 years ago
flagging onto triage radar for blocking1.9.2
Flags: blocking1.9.2?

Updated

9 years ago
Depends on: 479548, 488626, 491305

Updated

9 years ago
No longer depends on: 488626
If bug 490267 is FIXED, is this now FIXED as well?
Flags: blocking1.9.2? → blocking1.9.2+
Priority: P1 → P2
Nope, not fixed. Characters on tw.yahoo.com and qq.com are still just all solid rectangles, as is the Wikipedia bit in comment 3. 

Although I think it's improved, on some pages I'm seeing less of the rectangles. [In particular, the down-arrow next to "more" at the top of google.com/firefox used to just display as a block.]

Updated

9 years ago
Duplicate of this bug: 517124
Vlad, what's the story, here? Do we need to fix this for release, or can we get it for a security and stability release afterwards?
Vlad/Dolske: answer for comment 12?
I believe after should be fine; haven't had a chance to look into this.
Going to remove blocking, but will take a patch for a minor release.
Flags: blocking1.9.2+ → blocking1.9.2-
WinCE/Windows Mobile support has been removed from the main build system, Spidermonkey, mobile installer, in-app updater and so on (see bug 614720, bug 554087 and all their dependants). Until such point where MS decide to release a Windows Phone 7 NDK and the decision is made to port to that platform, this is WONTFIX.

Filter bugmail on WinCEMassWONTFIX.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.