Last Comment Bug 508760 - Remove MSVC6 support from the tree
: Remove MSVC6 support from the tree
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Windows 95
: -- trivial (vote)
: mozilla11
Assigned To: Serge Gautherie (:sgautherie)
:
: Gregory Szorc [:gps]
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on: 511395 616761 617947 712552 712554
Blocks: 508809 C192ConfSync 508808 600218
  Show dependency treegraph
 
Reported: 2009-08-06 02:40 PDT by Masatoshi Kimura [:emk]
Modified: 2012-03-22 20:44 PDT (History)
7 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.8-fixed


Attachments
(Av1) configure.in [Checkin: Comment 7 & 29] (2.19 KB, patch)
2009-08-06 07:52 PDT, Serge Gautherie (:sgautherie)
ted: review+
dveditz: approval1.9.1.8+
Details | Diff | Splinter Review
(Bv1) xpcom/ds/*.cpp [Checkin: Comment 10] (1.80 KB, patch)
2009-08-08 04:46 PDT, Serge Gautherie (:sgautherie)
doug.turner: review+
Details | Diff | Splinter Review
(Cv1) xpcom/io/*.cpp [Checkin: See comment 15] (1.83 KB, patch)
2009-08-09 08:37 PDT, Serge Gautherie (:sgautherie)
doug.turner: review+
Details | Diff | Splinter Review
(Dv1) widget/src/windows/*.cpp [Checkin: Comment 17] (909 bytes, patch)
2009-08-13 15:12 PDT, Serge Gautherie (:sgautherie)
doug.turner: review+
Details | Diff | Splinter Review
(Ev1) js/src/* [Checkin: Comment 19] (1.42 KB, patch)
2009-08-18 06:42 PDT, Serge Gautherie (:sgautherie)
graydon: review+
Details | Diff | Splinter Review
(Fv1) layout/svg/base/src/* [Checkin: Comment 21] (1.08 KB, patch)
2009-08-18 17:37 PDT, Serge Gautherie (:sgautherie)
longsonr: review+
Details | Diff | Splinter Review
(Gv1) /extensions/metrics/src/*.h [Superseded by bug 616761] (2.30 KB, patch)
2009-08-20 16:24 PDT, Serge Gautherie (:sgautherie)
no flags Details | Diff | Splinter Review
(Hv1-CC) configure.in [Checkin: Comment 25] (1.14 KB, patch)
2010-01-25 08:33 PST, Serge Gautherie (:sgautherie)
bugspam.Callek: review+
Details | Diff | Splinter Review
(Iv1) /toolkit/xre/*.cpp [Checked in: Comment 36] (1.53 KB, patch)
2010-12-07 08:09 PST, Serge Gautherie (:sgautherie)
benjamin: review+
benjamin: approval2.0+
Details | Diff | Splinter Review
(Jv1) nsEventQueue.h [Checked in: Comment 38] (721 bytes, patch)
2010-12-09 13:02 PST, Serge Gautherie (:sgautherie)
benjamin: review+
Details | Diff | Splinter Review
(Kv1) nsNavHistoryResult.cpp (1.47 KB, patch)
2011-04-14 14:34 PDT, Serge Gautherie (:sgautherie)
asaf: review+
Details | Diff | Splinter Review
(Kv1a) nsNavHistoryResult.cpp: Remove VC6 workaround [Checked in: Comment 44] (1.70 KB, patch)
2011-12-18 07:33 PST, Serge Gautherie (:sgautherie)
no flags Details | Diff | Splinter Review

Description Masatoshi Kimura [:emk] 2009-08-06 02:40:55 PDT
MSVC6 didn't build the tree far past. It will just confuse readers.
Serge, are you interested in this?
Comment 1 Serge Gautherie (:sgautherie) 2009-08-06 04:26:45 PDT
(In reply to comment #0)
> MSVC6 didn't build the tree far past. It will just confuse readers.

Ftr,
https://developer.mozilla.org/en/Windows_Build_Prerequisites
says VC6 is
*'Yes (Official)' for 1.8.0 and 1.8.1.
*'No' for 1.9.0 and 1.9.1+.

> Serge, are you interested in this?

Maybe. What should be done?
Comment 2 Masatoshi Kimura [:emk] 2009-08-06 06:52:35 PDT
As a first step, we could remove _CC_SUITE=6 and _CC_MAJOR_VERSION=12 code path from configure.in. Then configure will complain "This version of the MSVC compiler, 12.0.x.x , is unsupported."
Then we could remove all MSVC6-specific hacks.
http://mxr.mozilla.org/mozilla-central/search?string=vc6
Comment 3 Ted Mielczarek [:ted.mielczarek] 2009-08-06 07:22:27 PDT
I think Mook was still building with VC6+patches at some point, but I also think I'm fine with killing off that support. You can't even get your hands on VC6 legally these days.
Comment 4 :Mook 2009-08-06 07:46:29 PDT
Nah, I was doing VC71 + patches / various forms of mingw.  Neil(Away) was the one doing VC6.  CCing him... or at leas _a_ Neil; sorry if I picked up the wrong one :)

See also: https://developer.mozilla.org/en/VC6_Build_Instructions
Comment 5 Serge Gautherie (:sgautherie) 2009-08-06 07:52:26 PDT
Created attachment 392938 [details] [diff] [review]
(Av1) configure.in
[Checkin: Comment 7 & 29]
Comment 6 neil@parkwaycc.co.uk 2009-08-06 07:56:29 PDT
(In reply to comment #4)
> See also: https://developer.mozilla.org/en/VC6_Build_Instructions
That's only relevant for Firefox 3.0 - all my Mercurial builds use VC7.1 or 8.
Comment 7 Serge Gautherie (:sgautherie) 2009-08-08 04:13:12 PDT
Comment on attachment 392938 [details] [diff] [review]
(Av1) configure.in
[Checkin: Comment 7 & 29]


http://hg.mozilla.org/mozilla-central/rev/59c456691798
Comment 8 Serge Gautherie (:sgautherie) 2009-08-08 04:46:30 PDT
Created attachment 393359 [details] [diff] [review]
(Bv1) xpcom/ds/*.cpp
[Checkin: Comment 10]
Comment 9 Doug Turner (:dougt) 2009-08-08 08:57:28 PDT
Comment on attachment 393359 [details] [diff] [review]
(Bv1) xpcom/ds/*.cpp
[Checkin: Comment 10]

looks fine.  push it to try and check the wince build.  I was just worried about the REG_QWORD change.
Comment 10 Serge Gautherie (:sgautherie) 2009-08-08 16:04:34 PDT
Comment on attachment 393359 [details] [diff] [review]
(Bv1) xpcom/ds/*.cpp
[Checkin: Comment 10]


http://hg.mozilla.org/mozilla-central/rev/b97303f89a50


(In reply to comment #9)
> push it to try and check the wince build.

Passed (all) as try-3485c3d712d6.
Comment 11 Serge Gautherie (:sgautherie) 2009-08-09 08:37:44 PDT
Created attachment 393433 [details] [diff] [review]
(Cv1) xpcom/io/*.cpp
[Checkin: See comment 15]

Passed as try-844bdb830ca4.

I know nothing about WinCE/WinMo,
so I figured out this patch and comment from a search on internet...

Yet, I wonder if the following would be right and better:
{
804 #ifndef WINCE
...
829 #endif
...
#ifndef WINCE_WINDOWS_MOBILE // or #ifndef WINCE ?
835         case Win_LocalAppdata:
836         {
837             return GetWindowsFolder(CSIDL_LOCAL_APPDATA, aFile);
838         }
#endif
839 #endif  // XP_WIN
}
Comment 12 Doug Turner (:dougt) 2009-08-10 14:04:08 PDT
Comment on attachment 393433 [details] [diff] [review]
(Cv1) xpcom/io/*.cpp
[Checkin: See comment 15]

I think you want WINCE (since it is also not defined on Windows CE, not just undefined on windows mobile.)
Comment 13 Serge Gautherie (:sgautherie) 2009-08-10 15:05:20 PDT
Comment on attachment 393433 [details] [diff] [review]
(Cv1) xpcom/io/*.cpp
[Checkin: See comment 15]

Noted for WINCE.
What do you think about comment 11?
Comment 14 Masatoshi Kimura [:emk] 2009-08-10 15:24:44 PDT
GetProductDirectory will be broken if you #ifdef-out LocalAppData.
Comment 15 Serge Gautherie (:sgautherie) 2009-08-10 15:51:13 PDT
Comment on attachment 393433 [details] [diff] [review]
(Cv1) xpcom/io/*.cpp
[Checkin: See comment 15]


http://hg.mozilla.org/mozilla-central/rev/794867a3e942
Cv1, with comment 12 suggestion(s).
Comment 16 Serge Gautherie (:sgautherie) 2009-08-13 15:12:22 PDT
Created attachment 394388 [details] [diff] [review]
(Dv1) widget/src/windows/*.cpp
[Checkin: Comment 17]

Passed as sgautherie.bz@free.fr-try-16eb200df084.
Comment 17 Serge Gautherie (:sgautherie) 2009-08-17 15:55:42 PDT
Comment on attachment 394388 [details] [diff] [review]
(Dv1) widget/src/windows/*.cpp
[Checkin: Comment 17]


http://hg.mozilla.org/mozilla-central/rev/98b255a26506
Comment 18 Serge Gautherie (:sgautherie) 2009-08-18 06:42:12 PDT
Created attachment 395049 [details] [diff] [review]
(Ev1) js/src/*
[Checkin: Comment 19]
Comment 19 Serge Gautherie (:sgautherie) 2009-08-18 10:43:11 PDT
Comment on attachment 395049 [details] [diff] [review]
(Ev1) js/src/*
[Checkin: Comment 19]


http://hg.mozilla.org/mozilla-central/rev/02773bf9abae
Comment 20 Serge Gautherie (:sgautherie) 2009-08-18 17:37:24 PDT
Created attachment 395207 [details] [diff] [review]
(Fv1) layout/svg/base/src/*
[Checkin: Comment 21]

Succeeded on TryServer.
Comment 21 Serge Gautherie (:sgautherie) 2009-08-19 06:19:24 PDT
Comment on attachment 395207 [details] [diff] [review]
(Fv1) layout/svg/base/src/*
[Checkin: Comment 21]


http://hg.mozilla.org/mozilla-central/rev/6d400c5fa1f3
Comment 22 Serge Gautherie (:sgautherie) 2009-08-20 16:24:18 PDT
Created attachment 395714 [details] [diff] [review]
(Gv1) /extensions/metrics/src/*.h
[Superseded by bug 616761]

Succeeded as try-8cebe326f61c.
Comment 23 Serge Gautherie (:sgautherie) 2009-08-20 16:26:16 PDT
Comment on attachment 395714 [details] [diff] [review]
(Gv1) /extensions/metrics/src/*.h
[Superseded by bug 616761]


This reverts part of bug 334044 and bug 335120.
Comment 24 Serge Gautherie (:sgautherie) 2010-01-25 08:33:26 PST
Created attachment 423359 [details] [diff] [review]
(Hv1-CC) configure.in
[Checkin: Comment 25]

Do it for bug 506493 now that c-1.9.1 has branched.
Comment 25 Serge Gautherie (:sgautherie) 2010-01-25 20:19:39 PST
Comment on attachment 423359 [details] [diff] [review]
(Hv1-CC) configure.in
[Checkin: Comment 25]


http://hg.mozilla.org/comm-central/rev/6ae5e74f759e
Comment 26 Serge Gautherie (:sgautherie) 2010-01-25 20:35:15 PST
Comment on attachment 395714 [details] [diff] [review]
(Gv1) /extensions/metrics/src/*.h
[Superseded by bug 616761]


Looking for an active reviewer...
Comment 27 Serge Gautherie (:sgautherie) 2010-01-25 20:52:18 PST
Comment on attachment 392938 [details] [diff] [review]
(Av1) configure.in
[Checkin: Comment 7 & 29]


"approval1.9.1.8=?":
Zero risk, build config only.
Comment 28 Daniel Veditz [:dveditz] 2010-01-26 10:14:29 PST
Comment on attachment 392938 [details] [diff] [review]
(Av1) configure.in
[Checkin: Comment 7 & 29]

don't see a lot of point (people haven't figured that out in 8 updates?), but Approved for 1.9.1.8, a=dveditz for release-drivers
Comment 29 Serge Gautherie (:sgautherie) 2010-01-26 10:36:13 PST
Comment on attachment 392938 [details] [diff] [review]
(Av1) configure.in
[Checkin: Comment 7 & 29]


http://hg.mozilla.org/releases/mozilla-1.9.1/rev/85ba2075840b
Comment 30 Serge Gautherie (:sgautherie) 2010-01-26 10:38:56 PST
Comment on attachment 423359 [details] [diff] [review]
(Hv1-CC) configure.in
[Checkin: Comment 25]


Looking for
"approval-thunderbird3.0.2=?":
Zero risk, build config only.
Comment 31 Mark Banner (:standard8, limited time in Dec) 2010-01-26 11:57:27 PST
Comment on attachment 423359 [details] [diff] [review]
(Hv1-CC) configure.in
[Checkin: Comment 25]

I don't care about this for 1.9.1. There's no advantages here, from what I can tell any issues should be caught by the mozilla-1.9.1 changes, and the mozilla build page says VC 6 isn't supported for 1.9.1 anyway.
Comment 32 David Baron :dbaron: ⌚️UTC-10 2010-02-01 16:39:11 PST
Comment on attachment 395714 [details] [diff] [review]
(Gv1) /extensions/metrics/src/*.h
[Superseded by bug 616761]

Please find somebody else to review this.
Comment 33 Serge Gautherie (:sgautherie) 2010-02-01 16:46:18 PST
Comment on attachment 395714 [details] [diff] [review]
(Gv1) /extensions/metrics/src/*.h
[Superseded by bug 616761]


Brendan, I have no idea who to ask for this review :-/
Comment 34 Serge Gautherie (:sgautherie) 2010-10-01 08:35:29 PDT
Comment on attachment 395714 [details] [diff] [review]
(Gv1) /extensions/metrics/src/*.h
[Superseded by bug 616761]

Brendan: Benjamin cancelled review, I'm still looking for a reviewer...
Comment 35 Serge Gautherie (:sgautherie) 2010-12-07 08:09:17 PST
Created attachment 495834 [details] [diff] [review]
(Iv1) /toolkit/xre/*.cpp
[Checked in: Comment 36]

Unlike (old) comment 15, I'm not adding an |#ifdef WINCE| anymore: see bug 614720.
(But I could if you want one ftb.)
Comment 36 Serge Gautherie (:sgautherie) 2010-12-09 07:52:42 PST
Comment on attachment 495834 [details] [diff] [review]
(Iv1) /toolkit/xre/*.cpp
[Checked in: Comment 36]

http://hg.mozilla.org/mozilla-central/rev/37c63f75ff2f
Comment 37 Serge Gautherie (:sgautherie) 2010-12-09 13:02:50 PST
Created attachment 496590 [details] [diff] [review]
(Jv1) nsEventQueue.h
[Checked in: Comment 38]

Passed on
sgautherie.bz@free.fr – Thu Dec 9 08:01:08 2010 PST
http://hg.mozilla.org/try/rev/b1bb787b73cd
Comment 38 Serge Gautherie (:sgautherie) 2011-04-14 04:05:47 PDT
Comment on attachment 496590 [details] [diff] [review]
(Jv1) nsEventQueue.h
[Checked in: Comment 38]

http://hg.mozilla.org/mozilla-central/rev/c72ec462f70c
Comment 39 Serge Gautherie (:sgautherie) 2011-04-14 14:34:32 PDT
Created attachment 526108 [details] [diff] [review]
(Kv1) nsNavHistoryResult.cpp

Succeeded as
http://tbpl.mozilla.org/?tree=MozillaTry&rev=e6d22b368e6b
Comment 40 Serge Gautherie (:sgautherie) 2011-12-17 07:30:57 PST
Mano, ping for review.
Comment 41 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2011-12-18 03:53:54 PST
Comment on attachment 526108 [details] [diff] [review]
(Kv1) nsNavHistoryResult.cpp

Ugh, sorry! r+apology=mano.
Comment 42 Serge Gautherie (:sgautherie) 2011-12-18 07:33:57 PST
Created attachment 582664 [details] [diff] [review]
(Kv1a) nsNavHistoryResult.cpp: Remove VC6 workaround
[Checked in: Comment 44]

Kv1, unbitrotted.
Comment 43 Dão Gottwald [:dao] 2011-12-18 11:22:50 PST
Comment on attachment 582664 [details] [diff] [review]
(Kv1a) nsNavHistoryResult.cpp: Remove VC6 workaround
[Checked in: Comment 44]

http://hg.mozilla.org/integration/mozilla-inbound/rev/e48f73ccaf1c
Comment 44 Marco Bonardo [::mak] 2011-12-19 05:29:15 PST
https://hg.mozilla.org/mozilla-central/rev/e48f73ccaf1c

Are there still parts to land here?
Comment 45 Serge Gautherie (:sgautherie) 2011-12-20 22:34:15 PST
(In reply to Marco Bonardo [:mak] from comment #44)
> Are there still parts to land here?

I filed 2 more blocking bugs on remaining occurrences.

R.Fixed, for this very bug (assigned to me).
Comment 46 Serge Gautherie (:sgautherie) 2012-03-22 20:44:44 PDT
V.Fixed, per MXR search.

Note You need to log in before you can comment on or make changes to this bug.