Last Comment Bug 514512 - Command key conflict between "New Task" and "Get New Messages" (both Accel+D)
: Command key conflict between "New Task" and "Get New Messages" (both Accel+D)
Status: RESOLVED DUPLICATE of bug 636291
:
Product: Calendar
Classification: Client Software
Component: Lightning: SeaMonkey Integration (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 914151 smtabmail 527467 555929
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-03 13:05 PDT by Karsten Düsterloh
Modified: 2013-09-09 06:57 PDT (History)
15 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Karsten Düsterloh 2009-09-03 13:05:29 PDT
With SeaMonkey's tabmail implementation now in place, Lightning mostly works in SM as well - but for consistency reasons, we had to change the command key for "Get New Messages" from Accel+T to Accel+D, which collides with Lightning's "New Task".
(Accel+T now clones the current tab in SM, which Thunderbird doesn't currently.)

Since Accel+D isn't particularily bound to the "New Task" text, I propose changing the "New Task" command key to Accel+H, which is free in both SM and TB.
(And  Accel+Shift+H is free as well.)

Command keys are a rare resource, but there are some other keys free in both SM and TB which I don't favour:
* Accel-B:
  Used by SM's Bookmark Manager (in the browser), which is planned to cover 
  mail bookmarks as well
+ various Accel+shift+something
Comment 1 Philipp Kewisch [:Fallen] 2009-09-03 13:13:36 PDT
Argh. This sucks again. We already needed to move new event from Ctrl+N to something totally unrelated, I think its Ctrl+I or so.
Comment 2 Stefan [:stefanh] 2009-09-03 13:38:22 PDT
You don't want to use Accel+H since Cmd+H is the standard mac shortcut for "Hide this Application", used in the application menu (and Cmd+Shift+H is mapped to  "Hide others").
Comment 3 Karsten Düsterloh 2009-09-03 13:46:45 PDT
*argl*
Maybe we could take Accel+J then?
It was free in both SM and TB until recently when SM assigned it to the download manager, which doesn't makle much sense in the MailNews context anyway.
Neil?
Comment 4 Philipp Kewisch [:Fallen] 2009-09-03 14:03:53 PDT
Ctrl+I and Ctrl+J would then actually kind of make sense.
Comment 5 neil@parkwaycc.co.uk 2009-09-03 14:18:01 PDT
(In reply to comment #3)
> Maybe we could take Accel+J then?
> It was free in both SM and TB until recently when SM assigned it to the
> download manager, which doesn't make much sense in the MailNews context anyway.
I guess that's OK, but how were you proposing to remove it from MailNews?
Comment 6 Stefan [:stefanh] 2009-09-03 14:19:00 PDT
If you go for Accel+J, I think it should be removed completely from download
manager since it's just confusing having a shortcut do different tasks.
Comment 7 Philip Chee 2009-09-03 17:51:05 PDT
I don't think anyone is going to confuse the Download Manager with MailNews tabmail.
Comment 8 Jens Hatlak (:InvisibleSmiley) 2009-09-03 23:24:52 PDT
(In reply to comment #7)
> I don't think anyone is going to confuse the Download Manager with MailNews
> tabmail.

I think the point is that the Download Manager is accessible via the Tools menu from both the browser and MailNews. Having Accel+J listed there /will/ confuse people so I agree with Stefan.
Comment 9 Sven Grull 2009-09-04 00:42:38 PDT
There is another conflict Ctrl-Shift-C is used for opening Lightning but is also used for mark all messages read. Should I open a new bug for this issue or will it be handled in this bug?
Comment 10 Thomas D. (currently busy elsewhere; needinfo?me) 2009-11-15 07:35:46 PST
(In reply to comment #9)
> There is another conflict Ctrl-Shift-C is used for opening Lightning but is
> also used for mark all messages read.

In Thunderbird, this problem has been solved, Ctrl+Shift+C is no longer used for "mark all messages read", it's now Shift+C. So within TB, ctrl+shift+c opens lightning in a new tab as expected.

Lightning shouldn't use Ctrl+J for "New task":
- Firefox is using Ctrl+J for "Download Manager"
- SeaMonkey is using Ctrl+J for "Download Manger" (to be consistent with FF)
- Thunderbird will also use Ctrl+J to open "Saved Files" (TB Download Manager, implemented by bug 408647)

Download Manager/Saved Files is an essential functionality as we can expect users to have more and more downloaded attachments they'll want to handle.
Furthermore, with tabs in the mail apps, there might be more content-related downloads from inside the mail apps from addons.
Comment 11 Thomas D. (currently busy elsewhere; needinfo?me) 2009-11-15 10:21:42 PST
(In reply to comment #2)
> You don't want to use Accel+H since Cmd+H is the standard mac shortcut for
> "Hide this Application", used in the application menu (and Cmd+Shift+H is
> mapped to  "Hide others").

Stefan, can you clarify the behaviour of the mac: Under which condition will Ctrl+H hide the application:
a) when focus is anywhere inside the application, or
b) only when application menu has been focussed by user?
Comment 12 Stefan [:stefanh] 2009-11-15 13:19:06 PST
(In reply to comment #11)
> (In reply to comment #2)
> > You don't want to use Accel+H since Cmd+H is the standard mac shortcut for
> > "Hide this Application", used in the application menu (and Cmd+Shift+H is
> > mapped to  "Hide others").
> 
> Stefan, can you clarify the behaviour of the mac: Under which condition will
> Ctrl+H hide the application:
> a) when focus is anywhere inside the application, or
> b) only when application menu has been focussed by user?

You mean Cmd+H since that is what accel+H will map to (on mac, you don't use Ctrl in this context). Anyway, the answer to your question is a), it's basically a global shortcut, see http://developer.apple.com/mac/library/documentation/UserExperience/Conceptual/AppleHIGuidelines/XHIGMenus/XHIGMenus.html#//apple_ref/doc/uid/TP30000356-CIHDGFJB
Comment 13 Stefan [:stefanh] 2009-11-15 13:42:36 PST
Just to clarify a bit:
On mac, the menubar is not attached to a window - when you run an application the menubar is at the top of your screen instead (I guess you could describe it as you have a menubar at the top of your desktop). This means that as long as you have the application in focus, the Cmd+H combo will hide the application.
Comment 14 Thomas D. (currently busy elsewhere; needinfo?me) 2009-11-15 13:46:32 PST
OK, so we really can't use Ctrl+H for Lightning's "New task". Anything else we can use?
Comment 15 Philipp Kewisch [:Fallen] 2010-03-08 23:48:56 PST
This bug is only relevant for Seamonkey, not Thunderbird right?
Comment 16 Thomas D. (currently busy elsewhere; needinfo?me) 2010-03-09 05:11:20 PST
Philipp, it'll be relevant for TB if/as soon as we implement bug 527467: Ctrl+[Shift+]+D for "Get/Download [All] Messages". Just like Seamonkey and FF, Thunderbird will implement Ctrl+T for opening a new tab (Bug 458069); so TB needs a new shortcut for "Get [All] Messages" which is currently Ctrl+[Shift+]+T, for which Ctrl+[Shift]+D has been proposed.
Comment 17 Stefan Sitter 2011-04-30 02:28:03 PDT
After fixing Bug 527467	Thunderbird now uses Ctrl+[Shift]+D too. 
Lightning has to find a new solution for both Thunderbird and SeaMonkey.
Comment 18 Philipp Kewisch [:Fallen] 2011-07-21 07:23:14 PDT
Moving back to seamonkey, Thunderbird thankfully decided to use different keys after all.
Comment 19 xolaware.llc 2011-08-02 09:10:51 PDT
i'm confused.  i have TB5, and the Cmd-D/Cmd-Shift-D does not appear to do anything ... and there is no key to "Get Messages" for either current account or all accounts.  what is Cmd-D/Cmd-Shift-D supposed to do?  was ctrl-d/ctrl-shift-d implemented for non-mac environments, but not for mac?!?
Comment 20 Ilari Halminen 2012-12-30 07:43:35 PST
There is a related bug: Bug 534175 - Eliminate all key shortcut conflicts between Lightning and SeaMonkey
Comment 21 Philip Chee 2013-03-23 09:12:23 PDT
Fixed in Bug 636291

*** This bug has been marked as a duplicate of bug 636291 ***

Note You need to log in before you can comment on or make changes to this bug.