missing page and image "Properties" menu item

RESOLVED WONTFIX

Status

()

--
major
RESOLVED WONTFIX
9 years ago
8 years ago

People

(Reporter: drew.savagealien, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20090908 Minefield/3.7a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20090908 Minefield/3.7a1pre

Right click context menus for images and web pages have no Properties item

Reproducible: Always

Steps to Reproduce:
1. Right click page or image
2. Look at bottom of menu
3. No Properties! :(
Actual Results:  
No properties menu item

Expected Results:  
Properties menu itme

Bring it back please? I miss it for images especially as I want to see location and dimensions of an image
We took this out in Bug 513147
Severity: major → normal
Depends on: 513147
OS: Windows 7 → All
Version: unspecified → Trunk
Given by bug 513147 that was an intended change which will put this bug in a wontfix state.
Blocks: 513147
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
No longer depends on: 513147
Keywords: regression
Resolution: --- → WONTFIX
(Reporter)

Comment 3

9 years ago
I overlooked that bug as it was directed at Link Properties.
Is there a planned feature to replace Image and Page Properties functions?
Just use the page info dialog which is reachable via the Tools menu. The second tab has the information you are searching for.
(Reporter)

Comment 5

9 years ago
That's a much better window, actually, and I know it's been around for a long time. Embarrassingly enough, I couldn't find it when I looked after first seeing Properties item was gone. Did I mention embarrassing? 
Will it be replacing Properties in the context menus? Seems most intuitive to have it accessible from there.
Just right click on the page, and select view page info :)
(Reporter)

Comment 7

9 years ago
Hahaha.. D'oh.. Very true! Funny how the eye filters out something when it's exactly what you're looking for, but is different in appearance.

Only one problem with that solution and that is it doesn't work when viewing images.
When viewing an image the location is shown in the location bar and the dimensions are included inside the window title.

Comment 9

9 years ago
(In reply to comment #4)
> Just use the page info dialog which is reachable via the Tools menu. The second
> tab has the information you are searching for.

This is not a viable alternative. When you have 50 images in the page, or even much less, you have *no* idea which URL points to the image you want. Till now, we had an easy way to get meta-data about images and links, and you remove this feature because you want to save 48 Kb of code.


(In reply to comment #8)
> When viewing an image the location is shown in the location bar and the
> dimensions are included inside the window title.

You can view, right, but you cannot copy then paste!


I just think you are plain wrong this time.
Severity: normal → major

Comment 10

9 years ago
Also, if your plan is to remove rarely used items from the context menu, I suggest you remove the "Send Link..." item instead. I'm pretty sure it's less used than the "Properties" item.
> because you want to save 48 Kb of code

Just to be clear, 48Kb of code is is huge.  That's the amount of code it takes to implement <object> (in C++, where code tends to be much larger than JS!).

And I seem to recall that "Send Link" is on the proposed chopping block too.
(In reply to comment #9)
> This is not a viable alternative. When you have 50 images in the page, or even
> much less, you have *no* idea which URL points to the image you want. Till now,
> we had an easy way to get meta-data about images and links, and you remove this
> feature because you want to save 48 Kb of code.

If you'll permit me to restate your point, I think you're saying that you estimate the maintenance cost of 1300 lines of unowned code and the UI cost of an extra context menu entry as being collectively lower than the value of providing more direct built-in access to image metadata on pages with many images than page info provides. Is that fair?

I think it's pretty clear that I disagree, that I think this kind of use case (as well as the one you posted in the other, resolved bug about copying mailto link metadata) is better suited to a purpose-built extension than a generic in-product feature, given its niche appeal (though for the generic version, https://addons.mozilla.org/en-US/firefox/addon/14228/ has already been created).

> (In reply to comment #8)
> I just think you are plain wrong this time.

Yes, that you think as much is clear. It seems unhelpful for us to go back and forth on that point, though, since statements like this don't often lead to a meeting of minds. Are there areas where we *can* come closer to agreement?

(In reply to comment #10)
> Also, if your plan is to remove rarely used items from the context menu, I
> suggest you remove the "Send Link..." item instead. I'm pretty sure it's less
> used than the "Properties" item.

Seems like a bit of a non-sequitur, but sure, if you feel strongly about it, I suggest you file a bug. As with the properties dialog, the assessment will be focused on whether we think the feature serves a large portion of our users, what the cost is of keeping it, and what downstream impacts removal might have. I suggest Firefox::Menus, and put [killthem] in the status whiteboard, if you want it tracked along with the other removal bugs.

Comment 13

9 years ago
(In reply to comment #12)
> Are there areas where we *can* come closer to agreement?

Right clicking on an image should still display "Properties", and this item should point to the existing "Media" tab in Page Info, with the image item preselected, so that you immediately get the metadata you want. This way, you don't need to duplicate the code/UI; all you need is Properties pointing to the right place. I doubt it would take 48 Kb of code to implement, and it would make everybody happy.
Frederic, that sounds good. Can you please file a bug on that?

Comment 15

9 years ago
(In reply to comment #14)
> Frederic, that sounds good. Can you please file a bug on that?

Sure, assuming it has a chance to be accepted. Johnathan?
Duplicate of this bug: 516172
"Copy image location" from the context-menu works fine too, but it it a strange feeling that Internet Explorer still has the feature.

Comment 18

9 years ago
(In reply to comment #11)
> > because you want to save 48 Kb of code
> 
> Just to be clear, 48Kb of code is is huge.  That's the amount of code it takes
> to implement <object> (in C++, where code tends to be much larger than JS!).

And can anyone explain why that simple Properties dialog took so much code to implement? Couldn't it have been much more compact than that?

Comment 19

9 years ago
Anyone wants to create an addon which will REIMPLEMENT it?...
Is there some diff files between 3.7 and 3.6 which will help to reimplement the dialog?...
(In reply to comment #19)
Something wrong with the one mentioned in comment #12?: https://addons.mozilla.org/en-US/firefox/addon/14228/

Comment 21

9 years ago
Thanks for the link, I have,'t seen it but... It is not working (

Comment 22

9 years ago
(In reply to comment #14)
> Frederic, that sounds good. Can you please file a bug on that?

bug 517902
Duplicate of this bug: 522763
Duplicate of this bug: 523046

Comment 25

9 years ago
I just want to know, how exactly it was determined that this feature was "rarely used". As far as I know the project doesn't have any metrics or telemetry features like Microsoft has. 

Please don't tell me that it was just some intuition/experience of a developer.
(In reply to comment #25)
That's what Test Pilot is for, but it wasn't used in this case as far as I know.

https://testpilot.mozillalabs.com/
Duplicate of this bug: 524348
Duplicate of this bug: 537087
Duplicate of this bug: 542013

Updated

9 years ago
Duplicate of this bug: 543000

Updated

9 years ago
Duplicate of this bug: 547326

Comment 32

9 years ago
This is ridiculous and SO, SO unexpected to come from FIreFox.
Righ-Click on images, links MUST have "Properties" link.
This is something that ABSOLUTELY EVERY SOFTWARE piece has.

Take ONE single security related example: 
You use web email, you receive phishing email with the link that will DOWNLOAD VIRUS. Using right-click properties, you can EASILY see that the actual URL would have different domain AND you can see the whole string. Right now, there is NO way to do it, but to copy the link and paste in the note pad. GOD forbid pasting that into new tab of browser. I actually have my note pad file open at all times only because of that. 


I created an account here to report this BUG !!!! after some 5 years of using Firefox and you are saying this is not a bug and done intentionally?

I am sorry, but like this developers or not, the "properties" item on right click menu item is EVERYWHERE, on every piece of software, on every operating system. This is VERY basic thing.

Please tell me if it safe to downgrade to previous versions of FireFox, or if I should now waste my time by switching and getting used to different browser?

Comment 33

9 years ago
(In reply to comment #4)
> Just use the page info dialog which is reachable via the Tools menu. The second
> tab has the information you are searching for.
This will NOT do the job. The issue here on webpage elements, which can be iether image or link. All previous versions, ALL BROWSERS, ALL software pieces have it and it MUST be there, PERIOD.
Try at least making a plugin to add this menu item on right-click dropdown and I predict, you are going to watch such plugin to claim to the top of "most downloaded"

Comment 34

9 years ago
Here is the Element Properties plugin:
https://addons.mozilla.org/en-US/firefox/addon/14228
Works for me :o)
Poof, I almost thought I have to drop FireFox.

Updated

9 years ago
Duplicate of this bug: 547937
You need to log in before you can comment on or make changes to this bug.