Last Comment Bug 531397 - switching Layout modes breaks feed content display entirely until restart
: switching Layout modes breaks feed content display entirely until restart
Status: RESOLVED FIXED
[fixed by bug 596234]
:
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: 3.0
: x86 All
: -- normal with 5 votes (vote)
: Thunderbird 18.0
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 499407 584405 688164 778415 (view as bug list)
Depends on: 636874 596234
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-27 07:38 PST by Fernando Hartmann
Modified: 2013-04-18 02:09 PDT (History)
21 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
-
wanted
fixed


Attachments

Description Fernando Hartmann 2009-11-27 07:38:25 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091121 Thunderbird/3.0

If I set my layout to Wide View, the content of RSS feeds don't are showed.

Reproducible: Always

Steps to Reproduce:
1.With layout Classic
2.Get new RSS feeds
3.select the feed to see the content
3.The content are showed
4.Change the Layout to Wide
5.Select the feed again
6.The content are missing 
Actual Results:  
The content of RSS feeds aren't showed if You are using Wide View Layout

Expected Results:  
The contents of the RSS feed properly showed when the user use the Wide View Layout

Happens in TB 3.0 RC1
Comment 1 Ludovic Hirlimann [:Usul] 2009-11-27 07:40:02 PST
confirmed on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.5) Gecko/20091121 Thunderbird/3.0
Comment 2 Dan Mosedale (:dmose) 2009-11-30 10:59:33 PST
This bug actually happens with any change in layout, not just Classic -> Wide.  Fortunately, restarting puts Thunderbird back into a working state.
This is a rotten bug, but we can live with relnoting this for 3.0 since all that's required is a restart.  It does, however, block 3.0.1.
Comment 3 Fernando Hartmann 2009-12-01 02:51:49 PST
For the records, to me, the restart only works when I'm in Classic View. If I set the Wide View and restart TB, the RSS contents don't are showed.
With Wide View the content never are showed.
Comment 4 Mark Banner (:standard8) 2009-12-01 03:37:56 PST
(In reply to comment #3)
> For the records, to me, the restart only works when I'm in Classic View. If I
> set the Wide View and restart TB, the RSS contents don't are showed.
> With Wide View the content never are showed.

I bet you have Lightning installed. I've just done a test with and without Lightning enabled and without Lightning enabled I can restart after switching layouts and the wide view works fine.

I've raised bug 532071 on the Lightning specific issue.
Comment 5 Pádraig Brady 2009-12-10 02:20:51 PST
Restart works for me on linux (classic -> vertical caused the issue)
Comment 6 Mark Banner (:standard8) 2009-12-16 06:17:56 PST
I've been taking a look at the code. This is roughly what I've worked out so far:

- When switching messages, feeds items, etc, in normal conditions messageHeaderSink (in msgHdrViewOverlay.js) gets called into with at least the following functions: 

onStartHeaders, onEndMsgHeaders, onEndMsgDownload

- after we switch layouts, the onEndMsgDownload callback is lost. This in turn appears to not call some of the code that seems vital for display and set up of feeds (I'm not saying not calling that function is totally responsible, but it does break some things).

From what I can tell onEndMsgDownload is only called from nsMsgStatusFeedback::OnStateChange, which implies that after we've changed layouts, nsMsgStatusFeedback is no longer being called from when urls are processed.

AFAICT we're not dropping and re-initialising msgWindow (which could cause the status feedback to drop as well), so at the moment why nsMsgStatusFeedback::OnStateChange isn't getting called I don't know.
Comment 7 Andrew Sutherland [:asuth] 2009-12-16 19:13:30 PST
In UpdateMailPaneConfig in msgMail3PaneWindow we do call messenger.setWindow(null, null) then we re-establish it...

There's also XBL direct poking due to the DOM node transplantation.

I blame that.
Comment 8 alta88 2009-12-17 06:56:37 PST
Bug 492216.  also, a Tb3 checkin many months ago caused the MoreLayoutsforThunderbird extension to break, under which dynamic layout changes were no issue for rss and layout changes specifically required no restart.  but i can't figure out how to fix it..
Comment 9 Mark Banner (:standard8) 2010-04-27 13:46:21 PDT
*** Bug 499407 has been marked as a duplicate of this bug. ***
Comment 10 Mark Banner (:standard8) 2010-08-04 11:33:37 PDT
*** Bug 584405 has been marked as a duplicate of this bug. ***
Comment 11 Ludovic Hirlimann [:Usul] 2012-04-20 07:20:49 PDT
(In reply to alta88 from comment #8)
> Bug 492216.  also, a Tb3 checkin many months ago caused the
> MoreLayoutsforThunderbird extension to break, under which dynamic layout
> changes were no issue for rss and layout changes specifically required no
> restart.  but i can't figure out how to fix it..

Alta and you think you could now ?
Comment 12 alta88 2012-04-20 08:41:11 PDT
hehe.  yes, i finally did figure it out.  i blame the tabs implementation, it misses the fact that each tab needs to set the msgWindow and also reroot DOM things (among other things it misses).

installing MoreLayouts fixes bug 492216, bug 531397, bug 636874.  perhaps it should simply be uplifted.
Comment 13 alta88 2012-04-21 13:14:08 PDT
*** Bug 688164 has been marked as a duplicate of this bug. ***
Comment 14 Thomas D. (currently busy elsewhere; needinfo?me) 2012-06-23 09:28:05 PDT
(In reply to alta88 from comment #12)
> hehe.  yes, i finally did figure it out.  i blame the tabs implementation,
> it misses the fact that each tab needs to set the msgWindow and also reroot
> DOM things (among other things it misses).
> 
> installing MoreLayouts fixes bug 492216, bug 531397, bug 636874.  perhaps it
> should simply be uplifted.

Alta, does your addon also fix this?
Bug 265393 - Changing View Layout does not preserve the mail message encoding

Alta, is it possible to convert relevant parts of your addon into a patch for TB?
Would you give that a try? According to your comment 12, your addon code seems to fix a lot of bugs... ;)
Comment 15 alta88 2012-07-28 15:44:33 PDT
*** Bug 778415 has been marked as a duplicate of this bug. ***
Comment 16 Doug Parsons 2012-09-03 11:51:29 PDT
Hi. Sorry, just a tad confused with the commentary. I rely on lightning for its reminder characteristics; upgraded thunderbird once before and the calendar was broken for some time, don't want to repeat.

(1) Does Lighting still work if I upgrade to TB 15.0 ?
(1a) I may have to choose to disable it for RSS -- I would choose not, I can live without RSS better than I can live without the calendar/reminder.

Thunderbird's announcement to upgrade when you start it has a link for more information. Perhaps in the 'unresolved' section, which suggests lightning problems, should include something to my concerns expressed here.

Thanks.
-doug
Comment 17 Magnus Melin 2012-09-03 12:17:07 PDT
Yes, lightning works with tb15. (It auto-updates to a compatible version.)
Comment 18 alta88 2012-09-22 08:26:47 PDT
the patch in bug 596234 fixes this bug and bug 532071, for 3pane.  meaning a layout change does not require restart and summary/web page is displayed upon change.

tabs are still broken on layout change,  bug 636874.  use MoreLayouts.
Comment 19 Mark Banner (:standard8) 2012-10-26 11:19:36 PDT
Please be careful about altering flags, this has nothing to do with killmanjaro.
Comment 20 Jcoughlanardpatrick 2012-10-26 11:40:38 PDT
ok  i  will be carful  about altering  flags
Comment 21 Jcoughlanardpatrick 2012-10-26 11:45:53 PDT
(In reply to Mark Banner (:standard8) from comment #19)
> Please be careful about altering flags, this has nothing to do with
> killmanjaro.
Comment 22 Jcoughlanardpatrick 2012-11-06 14:10:26 PST
(In reply to Jcoughlanardpatrick from comment #21)
> (In reply to Mark Banner (:standard8) from comment #19)
> > Please be careful about altering flags, this has nothing to do with
> > killmanjaro.

how do i fix  what wrong  thank you
Comment 23 Thomas D. (currently busy elsewhere; needinfo?me) 2012-11-07 02:38:21 PST
(In reply to Jcoughlanardpatrick from comment #22)
> (In reply to Jcoughlanardpatrick from comment #21)
> > (In reply to Mark Banner (:standard8) from comment #19)
> > > Please be careful about altering flags, this has nothing to do with
> > > killmanjaro.
> 
> how do i fix  what wrong  thank you

Patrick, thanks for trying to assist. The flags are alright now, you do not have to fix anything, just do not change them in the future unless you know that you are entitled to do so. Setting the wrong flags as you did will not move this bug forward, it will just be confusing.

As you can see from the Status of this bug, it is already "Resolved FIXED".
Per comment 18, it was fixed by patches for bug 596234, which apply to TB17 and above. So if you are on the regular "release update channel", you have to wait just a little for the automatical update to TB17, where this bug 531397 will be fixed.
Comment 24 Thomas D. (currently busy elsewhere; needinfo?me) 2012-11-07 02:48:45 PST
Per comment 18, fixed by patches for bug 596234.
The patches landed in bug 596234 (which will fix this bug) are:

(from Bug 596234 Comment 67, Bug 596234 Comment 77)
https://hg.mozilla.org/comm-central/rev/4b79ea516c52
https://hg.mozilla.org/comm-central/rev/dbd153b0fa9c
-> Target Milestone: TB18

(from Bug 596234 Comment 81)
https://hg.mozilla.org/releases/comm-aurora/rev/328fbe81793e
-> status-thunderbird17: fixed

So I understand the same applies to this bug, setting flags accordingly.
Pls correct me if I'm wrong.
Comment 25 Thomas D. (currently busy elsewhere; needinfo?me) 2012-11-07 02:52:36 PST
(In reply to alta88 from comment #18)
> tabs are still broken on layout change,  bug 636874.  use MoreLayouts.

Note You need to log in before you can comment on or make changes to this bug.