Open Bug 528587 Opened 10 years ago Updated 10 years ago

Toolbar button style out of sync with reality

Categories

(Thunderbird :: Toolbars and Tabs, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

People

(Reporter: john, Unassigned)

References

Details

(Whiteboard: [223 Migration])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.5) Gecko/20091112 Thunderbird/3.0

Install Tb3 RC1 and ran it on an old profile. Used the Migration Assistant to choose "Keep my old toolbar".

Old-style buttons were left, but they went large with text. I didn't like this, so I went to customise the toolbar, only it already showed:

"Icons" with the "Use small icons" button ticked.

Reselected "Icons" and the text disappeared. Ticked and unticked "small icons" and the icons went small.


Reproducible: Didn't try

Steps to Reproduce:
1.Install Tb3 RC1
2.Run on an old profile (which used small icons and no text, I _think_)
3.Select "keep old toolbar" in Migration Assistant
4.Look in Toolbar customisation window
Actual Results:  
Settings for toolbar button style didn't match with reality

Expected Results:  
Reality
Blocks: qa-tb3.0rc1
This sounds like the opposite case of bug 522470 and should have been fixed
by bug 519505 ...
I've just set a 2.0.0.23 to use text+icons for the main toolbar, then started 3.0RC1 (WinXP) and indicated to use the old toolbar. I still see the icons in the small size with text underneath. However, in the Customize palette, "Use small icons" is no longer set. Clicking "Done" retains the small size.

Upon restart, I now have large size icons and the labels are beside the icons, with Customize dialog claiming "Icons beside text" and "Use small icons" checked. I have to change the settings to get what I've selected, then it will stick through a restart as well.

Confirming as there is obviously something going wrong.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [223 Migration]
Version: unspecified → 3.0
dupe of bug 516672? 
in retrospect I should have requested blocking on that bug
That's only covering part of what is observed here though, and bug 519505 was fixed after bug 516672 has been filed, thus may be obsoleted by now (I didn't test the scenario in that bug though).

(Quoting bug 516672)
> however, when i go to the toolbar and use right-mouse "customize..." i still
> see my settings in the "customize toolbar" dialog.

That's the opposite of my observation in comment #2, the icons still have the correct size but the settings do not reflect that. In addition, the preferences are screwed up, thus you get a different result when restarting Thunderbird.

Thus, related but not a duplicated, and highly visible I might add for the migrating user, suitable to give a not really good first impression.
Attached image Screenshot
Started testing the RC on Linux with an existing Tb2 profile, and confirmed the issue there. Can't quite remember if I was using large icons in Tb2 as the settings (but not the display) suggests, but I certainly could have been.
On the next start of Thunderbird the "Use Small Icons" tickbox was ticked, and "Icons" view selected, but the toolbar display was still as in my screenshot
You need to log in before you can comment on or make changes to this bug.