print function for Error Console

RESOLVED WONTFIX

Status

Toolkit Graveyard
Error Console
--
enhancement
RESOLVED WONTFIX
18 years ago
2 years ago

People

(Reporter: Mike Stockman, Unassigned)

Tracking

Dependency tree / graph

Details

(Reporter)

Description

18 years ago
There's no way to get any information out of the JavaScript Console. The
commands on the Edit menu (Cut, Copy) are dimmed and can't be selected, and
there's no print command on the File menu or anywhere else. Even a Save command
would be useful.

This came up because I wanted to print/copy/save a series of JS errors to show
the script's developer. I couldn't do it...

Comment 1

18 years ago
confirming bug. This doesn't seem too hard to do. Severity to minor, this is 
not such a big deal.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
mccabe or ben?
Assignee: jband → mccabe

Comment 3

18 years ago
I can take this.  Help would be wonderful.
Status: NEW → ASSIGNED
OS: Mac System 9.0 → All

Comment 4

17 years ago
*** Bug 60534 has been marked as a duplicate of this bug. ***
*** Bug 46344 has been marked as a duplicate of this bug. ***
any possible status/milestone possibilities for this puppy?
Keywords: helpwanted

Comment 7

17 years ago
I don't think the js console needs Cut or Paste, but Copy is important.

Comment 8

17 years ago
A fix for the clipboard portion of this bug in the patch in bug 67647.

Updated

17 years ago
Depends on: 67647

Comment 9

17 years ago
*** Bug 69880 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
From bug 69880: the js console should be multi-select to allow copying multiple 
items.  In that case, a Select All command should also be added to the Edit 
menu and to the context menu.  (Maybe that should be a separate bug, but either 
way, it depends on the last batch of changes to the js console going in (bug 
67647).)
cc'ing John Taylor. John, since you worked on the JS console in the past, would
you be interested in working on this?

Comment 12

17 years ago
Clipboard functionality is implemented in the patch for bug 67647, so I'm
changing the summary to just include print.
Summary: Clipboard and print functions don't exist for JavaScript Console → print function don't exist for JavaScript Console

Comment 13

17 years ago
Changing this to an enhancement, since it will be possible to print using a 
text editor once copying out of the javascript console works.
Severity: minor → enhancement
Summary: print function don't exist for JavaScript Console → [rfe] print function for JavaScript Console

Comment 14

17 years ago
Oops, "js console should be multi-select" is bug 67603.

Comment 15

17 years ago
Mass-reassigning mccabe's non-JS, non-Rhino bugs to jband (34 total). 

Would like to cc mccabe; but the mass-reassign page does not allow this. 
I'll leave it up to mccabe to decide if he wants to be cc'ed on these - 
Assignee: mike+mozilla → jband
Status: ASSIGNED → NEW

Comment 16

17 years ago
reassign to hewitt (since he's actually done some work on the JS Console)
Assignee: jband → hewitt

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: P3 → P4
Hardware: Macintosh → All
*** Bug 100042 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Component: JavaScript Debugger → XP Apps

Updated

16 years ago
Target Milestone: --- → Future

Updated

16 years ago
Component: XP Apps → JavaScript Console
*** Bug 121363 has been marked as a duplicate of this bug. ***

Updated

16 years ago
URL: N/A

Comment 19

16 years ago
*** Bug 121602 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Summary: [rfe] print function for JavaScript Console → print function for JavaScript Console

Comment 20

13 years ago
*** Bug 35279 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Summary: print function for JavaScript Console → print function for Error Console
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey
Assignee: hewitt → nobody
Status: ASSIGNED → NEW
Priority: P4 → --
QA Contact: rginda → error-console
Target Milestone: Future → ---
Depends on: 490886

Comment 21

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 22

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 23

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Updated

9 years ago
Status: UNCONFIRMED → NEW
Component: Error Console → Error Console
Keywords: helpwanted
Product: SeaMonkey → Toolkit
QA Contact: error-console → error.console

Comment 24

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
Component: Error Console
Keywords: helpwanted
Product: SeaMonkey
QA Contact: error.console → error-console

Comment 25

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
This is being moved out of Seamonkey and into Toolkit, please exclude it from the mass changes.
Status: UNCONFIRMED → NEW
Component: Error Console → Error Console
Product: SeaMonkey → Toolkit
QA Contact: error-console → error.console

Updated

9 years ago
Keywords: helpwanted

Updated

8 years ago
Blocks: 490886
No longer depends on: 490886
I'm taking the liberty of closing this, since it should have been closed somewhere around comment 12 when Copy was implemented, and the last 12 years of activity here is just bug churn.  No one's gonna implement printing for the Error Console.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.