Error Console tree should be multi-select (multiple lines of JS console)

RESOLVED WORKSFORME

Status

Toolkit Graveyard
Error Console
--
minor
RESOLVED WORKSFORME
16 years ago
10 months ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

Details

(Reporter)

Description

16 years ago
The JavaScript console should allow selecting multiple items, so the user can 
copy multiple items out at once.  (Note that copying isn't working even for 
single items yet -- see bug 53480.)  A "Select All" option should be added to 
the Edit menu with the keyboard shortcut Ctrl+A.
(Reporter)

Comment 1

16 years ago
Moving to javascript debugger component.  Cc hewitt.
Component: XP Apps: GUI Features → JavaScript Debugger
QA Contact: sairuh → rginda

Comment 2

16 years ago
*** Bug 69880 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Component: JavaScript Debugger → XP Apps
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 3

16 years ago
this is javascript console...
Assignee: ben → hewitt
Status: ASSIGNED → NEW
Component: XP Apps → JavaScript Console
QA Contact: rginda → jrgm

Updated

16 years ago
Status: NEW → ASSIGNED
Priority: -- → P3

Updated

16 years ago
OS: Windows 98 → All
(Reporter)

Updated

15 years ago
Blocks: 88057
(Reporter)

Comment 4

15 years ago
*** Bug 136674 has been marked as a duplicate of this bug. ***

Comment 5

12 years ago
I think it will be useful to have just text, without any images, xul, whatever.

Thus it will load much faster with many items, and you'll be able to select
any part of text it your's favorit text editor.

Comment 6

12 years ago
A few more keywords to help search.
Summary: js console tree should be multi-select → JavaScript console tree should be multi-select (multiple lines of JS console)
(In reply to comment #0)
> The JavaScript console should allow selecting multiple items, so the user can 
> copy multiple items out at once.  

difficult? or might this be a good first bug?


> A "Select All" option should be added to 
> the Edit menu with the keyboard shortcut Ctrl+A.

Bug 88057
Assignee: hewitt → js-console
Status: ASSIGNED → NEW

Updated

11 years ago
Summary: JavaScript console tree should be multi-select (multiple lines of JS console) → Error Console tree should be multi-select (multiple lines of JS console)
*** Bug 343826 has been marked as a duplicate of this bug. ***

Updated

9 years ago
Duplicate of this bug: 421056
(Assignee)

Updated

9 years ago
Product: Core → SeaMonkey
Assignee: error-console → nobody
Priority: P3 → --
QA Contact: jrgmorrison → error-console
Target Milestone: Future → ---
Depends on: 489736
Patches will be in bug 489736 (current one already fixes this).
Assignee: nobody → highmind63
Status: NEW → ASSIGNED
Hrm, didn't realize this before, is this a Seamonkey-only bug? If so, restore the component, and unassign...
Component: Error Console → Error Console
Product: SeaMonkey → Toolkit
QA Contact: error-console → error.console

Comment 12

8 years ago
SeaMonkey 2.0x (1.9.1) switched to using the toolkit Error Console. The SeaMonkey component is for legacy bugs in SeaMonkey <= 1.1 and will probably be moved to the graveyard once 2.0 is released.
No longer depends on: 489736
(In reply to comment #10)
> Patches will be in bug 489736 (current one already fixes this).

Adding dependency to bug 489736.
Depends on: 489736
No longer blocks: 88057
Depends on: 305206
No longer depends on: 489736
Pushing out old bugs that I won't have time to actually get to. Feel free to use/extend any patches attached...
Assignee: highmind63 → nobody
Status: ASSIGNED → NEW

Updated

6 years ago
Duplicate of this bug: 621019
Depends on: 88057
No longer depends on: 305206
Duplicate of this bug: 862658

Comment 17

4 years ago
Selecting multiple entries, selecting all entries and even copying all selected entries is now possible with the new console.
The Error Console has been removed in favor of the Browser Console (see Bug 1278368), and the component is going to be removed.  If this bug is also relevant in the Browser Console, please reopen and move this into Firefox -> Developer Tools: Console.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX

Comment 19

10 months ago
I am mass-reopening and re-componenting every single one of the Toolkit:Error Console bugs that appear to have been closed without anyone even *glancing* at whether they were relevant to the Browser Console.

If you want to close a whole bunch of old bugs -- FOR ANY REASON -- it is YOUR RESPONSIBILITY to check EVERY SINGLE ONE OF THEM and make sure they are no longer valid.  Do not push that work onto the bug reporters.

(It's okay to close bugs that haven't been touched in years when they don't have enough information for you to figure out whether the problem is still relevant to the current software - the reporter probably isn't coming back to clarify.  But that is the ONLY situation where it is okay.)

(I'm going to have to do this in two steps because of the way the "change several bugs at once" form works.  Apologies for the extra bugspam.)
Status: RESOLVED → REOPENED
Component: Error Console → Developer Tools: Console
Product: Toolkit → Firefox
Resolution: WONTFIX → ---
This one is WFM with the new browser console.
Status: REOPENED → RESOLVED
Last Resolved: 10 months ago10 months ago
Resolution: --- → WORKSFORME

Updated

10 months ago
Component: Developer Tools: Console → Error Console
Product: Firefox → Toolkit
(Assignee)

Updated

10 months ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.