Opening a new tab goes next to current tab instead of the end of the tab list (behavior change)

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: quanah, Unassigned)

Tracking

3.6 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6 (.NET CLR 3.5.30729)

In FF 3.5, when opening a link in a new tab, the new tab would come at the end of all open tabs.  Now it appears to go to the immediate right of the tab you're opening the link from.  This behavior is extremely annoying, it would be nice for this to at least be configurable.

Reproducible: Always

Steps to Reproduce:
1. Open up multiple pages in tabs
2. Google some term in the first tab
3. Open up links from those results, see the new tab be immediately to the right, instead of at the end of the list
Actual Results:  
New tab is immediately to the right of the current tab

Expected Results:  
New tab is at the end of all current tabs
This is a new features which has been implemented with bug 465673. There will be no UI option but it can be changed in about:config with browser.tabs.insertRelatedAfterCurrent.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 262459
Duplicate of this bug: 544703
Not really a dupe of bug 465673. This one is about the feature change in the last version and not about an option to switch between both modes. That makes it invalid.
Blocks: 465673
OS: Windows XP → All
Hardware: x86 → All
Resolution: DUPLICATE → INVALID
Version: unspecified → 3.6 Branch
Why would there be no UI option for this?
(In reply to comment #6)
> Why would there be no UI option for this?

See bug 262459 and bug 514799.
So the answer is... "because we don't want there to be one"?

A major change in UI behavior like this, combined with the memory hog that Firefox has become in the last few releases, is excactly the thing that will get me to drop this browser.
I was going to open a bug about this.. and I saw there are multiple bugs already opened on this issue. 

The new feature is simply HORRIBLE. Imagine you have ~10 tabs opened. You open a link in a new tab... then what? You automatically click on the last tab. It's not it. So, you start searching through all your opened tabs to see where the hell is the new one. You'd say: it's right next to your active tab. Thanks a lot, you think I actually remember which of my 10+ tabs was the last active one?

Do you know how annoying this is? The more tabs you have opened, the harder it is to find the newly opened tab. Sometimes you're lucky and it's loading slowly, so you can spot it by the loading icon. But most of the times, the new tab loads quickly, and then it's hell finding it. Not to mention if you open several tabs.. it completely messes up any order/logic you had on the browser when opening up those tabs.

Please remove this feature or at least add a custom option to disable it.
Duplicate of this bug: 554040
As someone pointed out, there is a user-configurable option to disable this "feature". It's called

browser.tabs.insertRelatedAfterCurrent 

In the URL field, enter     about:config

In the filter field, enter  insertrelated

Double-click the resulting 
line to set its value to    false

Quit Firefox and launch again
Importance is too low, in my opinion.  And this "user configurable option" is not available for those with little to no computer experience.  about:config says that it may void your warranty, and is not something a normal user is able to use.

Issues this also has:

Opening tabs in current window become unordered.  Before the most recent
upgrade, tabs would open up from left to right in the order you opened them up.

Go to Tools->Options->Tabs, and there is no option to use the currently
implemented tab opening technique vs. the originally implemented tab ordering.

It should ask if you would like your preferences similar to IE or Firefox on
first start-up, if tab ordering is to be able to be defautly working like it is
now.

This issue is a direct result of fixing issue https://bugzilla.mozilla.org/show_bug.cgi?id=465673.  This, however, was not a bug, nor causing issues and should be reverted.
(In reply to comment #13)
> Go to Tools->Options->Tabs, and there is no option to use the currently
> implemented tab opening technique vs. the originally implemented tab ordering.

Is sounds like you guys really want bug 514799 fixed to make Comment 12 easy.
Which adding UI like this is something IE does and has been marked WontFix.

> It should ask if you would like your preferences similar to IE or Firefox on
> first start-up, if tab ordering is to be able to be defautly working like it > is now.

File a new bug to ask for that enhancement.
Frankly even I am a bit surprised as to why are the Devs so conservative when it comes to providing users with options - either through options panel or about:config. I cant imagine why some Tab based options should not be provided... like option to Open New Tabs from URL bar/Search Bar/History/Bookmarks etc. Similarly the option to open Links next to current tab or at end...these are basic browsing functionalities... depending on addons for this just doesnt make sense...Addons should be to extend the functionality of the browser.. not fill up gaps in options/usability.
Duplicate of this bug: 552340
Thank you, ronin.achilles.  Bug https://bugzilla.mozilla.org/show_bug.cgi?id=554690 has been opened per request of Dale.  Please use this bug instead to response to this one.
What's "conservative" about pushing an update that involves a major change in 5+ years of browser behavior without even a UI preference for whether the behavior should change or not?
(In reply to comment #17)
> Thank you, ronin.achilles.  Bug
> https://bugzilla.mozilla.org/show_bug.cgi?id=554690 has been opened per request
> of Dale.  Please use this bug instead to response to this one.

That is just another dupe of bug 514799.   I thought you were going to open a bug for asking a user on startup what option they want on default.
The issue opened has been updated to include this, via issue I had originally opened regarding this.  Further comments about having access to the original FF tab ordering being replaced by a new (unwanted by many) "feature" should use that issue.
Duplicate of this bug: 558267
I wonder who is habilited to decide to implement new features without consulting end users ?
When everyone knows the way to use a tool and suddenly this usage changes it's very disturbing for most of people. As much disturbing as many have thought it was a bug, not a "feature"
So, the discussion is about opening a new tab and fining the new tab being opened immediately right to the current tab.
But, I don't see that behavior on my FF 3.6.3

I  would love to have that feature because it improves grouping of similar tabs at a single place. It will only take a day or two to get used to this feature. I do not know why this is being called as a bug.

By the way, how to get this activated on my computer? The default behavior doesn't provide me with this feature!!
It should currently be implemented.  If you right click on a link in a page and open it as a new tab, it does open to the right.  I haven't tried this on icecat, but I remember it had legacy functionality from time to time.

I consider it a bug since the order in which I open tabs is lost after clicking between tabs.  So open a link 3 times on one page, select another tab to view it, then go back to that same tab & open another link, the 4th tab doesn't show where it should.
Okay, but why is not working on my browser. I upgraded to 3.6.3 just yesterday.
Check and make sure browser.tabs.insertRelatedAfterCurrent is
true in about:config.
I checked the config, it is set to true. But, the tabs always open at the right-end of the tabs.
You should probably open a separate issue if you are experiencing this.  This would defiantly be a new bug I have not seen.

Don't forget to list your browser information, as well as steps to produce the issue.  Be detailed, but to the point.  That's got me a few times on issues I've opened :)
You need to log in before you can comment on or make changes to this bug.