Drag select past an image, page jumps down

RESOLVED WORKSFORME

Status

()

Core
Selection
P3
normal
RESOLVED WORKSFORME
18 years ago
7 years ago

People

(Reporter: Jeffrey Baker, Unassigned)

Tracking

({ecommerce, testcase})

Trunk
mozilla1.7beta
ecommerce, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [awaiting info], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Go to the URL above, and drag scroll from any point down.  If you drag over an
image, the page scrolls down about a page.  Very wierd and I haven't seen it
anywhere else.

Linux 2000-09-28-08 M18

Comment 1

18 years ago
asking blake to please test this and see if he can reproduce on linux
Whiteboard: [awaiting info]

Comment 2

18 years ago
unable to reproduce this with Mozilla trunk build 200010036 on redhat6.2  I
tried scroll selecting in both directions with no page skipping or jumping.
Page selected and scrolled as expected.
(Reporter)

Comment 3

18 years ago
I can still reproduce this on Linux 2000-10-03-06.  Go to the URL, grab the
cursor right around where is says "Jay" in bold type, and drag the selection
past the "yes/no" images.  The page jumps down about one page.  Scroll up past
another set of "yes/no" images and the page jumps all the way down to the bottom.

Comment 4

18 years ago
This won't get fixed for RTM, so Future. We'll address this in a future release.
Target Milestone: --- → Future

Updated

17 years ago
Keywords: ecommerce
(Reporter)

Comment 5

17 years ago
sfraser, I know it's been many moons since your comment, but when you made it
did anyone actually have any insight into the bug?  If I can get one tiny grain
of an idea, I can spend some time to make a patch for this.  I've been poking
around in the selection code a lot lately.

Comment 6

17 years ago
I'm sorry, I don't have any insights here. mjudge or anthonyd would be the ones.

Comment 7

17 years ago
changing selection qa to tpreston.
QA Contact: blaker → tpreston

Comment 8

16 years ago
I just realized that I submitted a duplicate bug to this. However, I'm
encountering the problem in Release Candidate 1 under Windows XP. I'm not sure
of the protocol as this is my first bug. Should I mark mine as a duplicate of
this bug or should I just leave it as is since it is on a different OS?
(Reporter)

Comment 9

16 years ago
-> all/all per previous comment
OS: Linux → All
Hardware: PC → All
(Reporter)

Comment 10

16 years ago
*** Bug 140689 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
Created attachment 81457 [details]
testcase

This is a test case for this bug. Open the html file with Mozilla and follow
the included instructions. I ran into this bug in RC1 for WinXP.

Comment 12

16 years ago
Bug 59366 seems to be similar (or identical) to this bug.
(Reporter)

Comment 13

16 years ago
*** Bug 59366 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
*** Bug 176159 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
*** Bug 205178 has been marked as a duplicate of this bug. ***
*** Bug 191252 has been marked as a duplicate of this bug. ***

Comment 17

15 years ago
*** Bug 219922 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Keywords: testcase

Comment 18

14 years ago
The testcase and amazon.com website now work as expected on the following UA:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040317
Firefox/0.8.0+

Was this fixed inadvertently at some point? Maybe it needs to be marked as WFM
if people can confirm that it works.

I'm reassigning this to the default owner/QA (since both are
formerly-netscape.com.tld).
Assignee: mjudge → selection

Comment 19

14 years ago
(In reply to comment #18)
> The testcase and amazon.com website now work as expected on the following UA:
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040317
> Firefox/0.8.0+
I have firefox on Mac OSX with UA Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) 
Gecko/20040206 Firefox/0.8
and it still shows that problem.
Let e know if there is a later binary that I can test.
hope this helps. 

Comment 20

14 years ago
(In reply to comment #19)

> Let e know if there is a later binary that I can test.

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/Firefox-mac.dmg.gz

Comment 21

14 years ago
(In reply to comment #20)
> 
>
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/Firefox-mac.dmg.gz

super Duper great news! the above binary fixes the problem.
cheers.
spundun.
ohhh almost forgot. UA is Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7b) Gecko/20040317 Firefox/0.8.0+

Comment 22

14 years ago
Still visible with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8 and with Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.7b) Gecko/20040224.

WFM with a current build: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)
Gecko/20040317 Firefox/0.8.0+ (Steffen).

Marking as WFM based on confirmations for Windows, Mac and Linux!
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Target Milestone: Future → mozilla1.7beta

Comment 23

14 years ago
Amazon and IMDb works now, but I can still see the bug at tomshardware.com.
Go to http://www20.tomshardware.com/graphic/20040414/index.html and make sure
that the page contains an ad in the middle of the article.  (Reload until the
ad appears.)  Then start a drag select from the first paragraph in the article
and move the mouse down.  Once you reach the ad, the page will jump.  (For some
reason, the article pictures will not trigger the bug, so you will not be able
to reproduce the bug without an embedded ad.)

Reopen bug?

Comment 24

14 years ago
Since it's another problem, please file a new bug. It would be most helpful if
you can attach a reduced testcase to the new bug.

Comment 25

14 years ago
OK, reduced testcase submitted as bug 240964

Comment 26

14 years ago
*** Bug 213840 has been marked as a duplicate of this bug. ***

Comment 27

14 years ago
*** Bug 156805 has been marked as a duplicate of this bug. ***

Comment 28

14 years ago
*** Bug 176159 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.