Open Bug 549680 Opened 11 years ago Updated 10 years ago

Preview from Dreamweaver CS3/CS4 does not work in FF3.6

Categories

(Toolkit :: Startup and Profile System, defect)

x86
macOS
defect
Not set
normal

Tracking

()

REOPENED
Tracking Status
blocking1.9.2 --- -

People

(Reporter: lynne.mb, Assigned: alqahira)

References

Details

(Whiteboard: problem with CS5 is bug 577671)

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8 GTB6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8 GTB6

Bug reported in another thread which was resolved as Bug 530046. This new bug report concerns files with no spaces in file/folder/path names which do not open when previewed from Dreamweaver.
Please see these comments in previous bug report concerning testing of this problem in pre releases and results.
https://bugzilla.mozilla.org/show_bug.cgi?id=547662#c39
https://bugzilla.mozilla.org/show_bug.cgi?id=547662#c44

Reproducible: Always

Steps to Reproduce:
1.open Dreamweaver and file with no spaces in path
2.preview with Firefox 3.6 and pre releases
3.nothing happens, no preview and no error message
Actual Results:  
FF or Minefield did not open from DW preview, no error message

Expected Results:  
I expected FF to open and preview page from DW

A lot of web designers have been describing this bug in forums, which unfortunately has been mixed up with bug 530046.
(In reply to comment #0)

> A lot of web designers have been describing this bug in forums, which
> unfortunately has been mixed up with bug 530046.

You mean bug 530064 ;-)

This was filed on request (bug 547662, comment #48). As josh points out in the same bug (bug 547662, comment #45), it's most likely caused by Dreamweaver using an applescript event (WWW!OURL) that we don't support anymore.

Looking at toolkit/xre/MacApplicationDelegate.mm#115, it seems that we only support the "normal" event.
Status: UNCONFIRMED → NEW
blocking1.9.2: --- → ?
Ever confirmed: true
Component: General → Startup and Profile System
Product: Firefox → Toolkit
QA Contact: general → startup
Version: unspecified → Trunk
Duplicate of this bug: 548650
Duplicate of this bug: 548419
It would be best for Adobe to stop trying to do this via an ancient Apple event.
We should consider taking a patch for 3.6, but a patch won't be easy. This bug should not block 1.9.2.
I have contacted Adobe about this.
What version of Dreamweaver is having this problem? Is it happening in the latest version of DW?
(In reply to comment #7)
> What version of Dreamweaver is having this problem? Is it happening in the
> latest version of DW?

The reading I've been doing, primarily in the Mozilla Firefox support forum, suggest that this is a problem for both Dreamweaver CS3 and CS4 users at a minimum. Haven't heard a peep about CS2 or before, but it's possible that the Firefox/Dreamweaver power-user crowd has largely moved on from CS2.
I am using CS3.
This will be fixed in the CS5
(In reply to comment #5)
> We should consider taking a patch for 3.6, but a patch won't be easy. This bug
> should not block 1.9.2.

Tentatively marking as wanted as we don't want to make life tough for web designers, but this comment makes me nervous.
blocking1.9.2: ? → -
It is unfortunate that we will have to go out and buy CS5 to be able to use Firefox in preview from Dreamweaver. That is going to be at least another year away. Is there going to be a patch, or do we have to stick with 3.5.8?
I wish I could get my old copy of Firefox 3.5.8 back.  I am using Dreamweaver CS3, and when I use the new Firefox it does the same thing, no preview, no error, no nothing.  Has a patch been made, where can I find it, how to I find Firefox 3.5.8?

Thanks!
Becca
This patch is completely untested. Well, toolkit/xre recompiles successfully in my 1.9.2 Camino tree, but that's not saying much.  It might eat your babies.

I pushed it to the tryserver, though that looks pretty backed up right now.
Comment on attachment 433248 [details] [diff] [review]
Completely untested patch

Also, WWW!OURL will almost certainly suffer from bug 531552, too.
Assignee: nobody → alqahira
Can Dreamweaver users please test the build with my patch: https://build.mozilla.org/tryserver-builds/alqahira@ardisson.org-dreamweaver/dreamweaver-macosx.dmg

Please note that this is a trunk build ("Minefield"), so you probably want to create a test profile to use for testing, and you may have to tell Dreamweaver to preview in Minefield (I don't know how Dreamweaver tracks browsers).
Status: NEW → ASSIGNED
so, i downloaded the cs4 trial version and the results are a bit ambigious. with a plain trunk minefield build the preview seems to work apart from that i suffer from bug 531552. it didn't work the first time, however. so, i'm not sure what's going on here - maybe i'm missing something.
(In reply to comment #17)
Just tested with DW CS4 (OS 10.6.2)
-> it works!
.. so please put it as fast as possible in the next Version of FF
while with 3.6.2 it doesn't work. :(
> 
>... and you may have to tell Dreamweaver
> to preview in Minefield (I don't know how Dreamweaver tracks browsers).

You can simply add it to the List of browser
I have tested it with CS3 and it works, but it also opens a second window, the "welcome to page", which is bug 531552 I believe.
thodem and lynne.mb@gmail.com, can you comment on the results seen by Stefan in comment 18?  

That is, does a standard Minefield build from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/firefox-3.7a4pre.en-US.mac.dmg also work (or does preview only work in the Minefield build in comment 17, which has my patch)?
(In reply to comment #21)

it didn't work with the standard Minefield build, only with the Minefiled build in comment 17!!!
Furthermore the Minefield build in comment 17 didn't work while opened first time after using the standard build in in comment 21. - but opening again then it did!
(testing always only one version at the same time)
Closing Minefield (comment 17) and opening again -> Opening Document from Dreamweaver did work always. (using always the same profile for testing)

comment 18: Yes I could reproduce this too. If Minefield opened out of Dreamweaver by "Preview Document with ..." there are two windows:
One for the dreamweaver document and one with the start document. If Minefield was already open as clicking "Preview Document with ..." there is only one window.
I can confirm the comments of thodem above.

Preview does not work at all with standard Minefield build.

Preview works with Minefield build with patch from comment 17. It opens 2 windows if Minefield is not running, the preview window and the start window. If it is already running then it just opens the preview window.
It sounds to me like this patch works. The other stuff people are mentioning consists of known and unrelated bugs.
Comment on attachment 433248 [details] [diff] [review]
Completely untested patch

pushed to mozilla-central with some extra parens

http://hg.mozilla.org/mozilla-central/rev/f160bf9cfee4

Thanks Smokey!
Attachment #433248 - Flags: review+
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Attachment #433248 - Flags: approval1.9.2.3?
This is a safe patch for a problem that significantly impacts web developers. I suggest we take it on 1.9.2.
Attached file Manual test
This is a manual (well, it could be automated if we had an AppleScript test harness) test that can be run by anyone (it doesn't require Dreamweaver) to test the functionality I added in this bug.

Open the attached AppleScript in Script Editor (AppleScript Editor on 10.6), make sure you have a valid HTML file named "test_bug549680.html" on your Desktop, change "Minefield" to the name of the app you're testing ("Namaroka" for 1.9.2 branch builds, "Firefox" for 1.9.2 releases), and run.

(The file is UTF-16-encoded because of the chevrons and because Script Editor on < 10.5 doesn't support UTF-8-encoded scripts and MacRoman is just ugh!  If you try to save it, however, Script Editor will make it MacRoman again.)

Josh: one thing I noticed when writing this test is that other Mac apps support sending the event with either a POSIX path or a file:// URL, whereas Firefox requires a file:// URL.  Oddly enough, the command-line "-url" flag supports a raw POSIX path, though.  This behavior is unrelated to the problems in this bug AFAICT, but it's probably worth filing and fixing.
Attachment #434611 - Attachment mime type: text/plain; encoding=utf-16 → text/plain; charset=utf-16
Duplicate of this bug: 556331
Hi, sorry for sounding like an idiot, but I tried downloading the file in comment 17, but I guess it's no longer on the server.  I'm having the same problem of FF 3.6.x not previewing files from Dreamweaver CS3 on Mac OS X 10.5.8.  Could someone point me in the right direction?  Thanks a lot.

-Ted
The fix for this issue have landed on trunk (development tree). Once/if the patch gets approved and committed to the 3.6.x tree, it will be available in one of the forthcoming Firefox 3.6.x release.
Thanks Stefan.  Do you have an estimated time frame for this?
Sorry, no. The fix is in the nightly development builds, though. If you want to use those (please note that they're pre-alpha4 builds, so it's an "at your own risk" usage), they're available at http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Thanks, I tried 3.7 and it sort of works.  If Minefield is not running, selecting "Preview in Minefield" in Dreamweaver CS3 will cause Minefield to start up, display the homepage, and then display the file to be previewed.  However if Minefield is already running, selecting "Preview..." will cause Minefield to come into focus, but nothing else will happen.

Guess I'll stick to 3.5.9 for now, and keep my eye on this thread.  Good luck everyone, and thanks for the help.
Comment on attachment 433248 [details] [diff] [review]
Completely untested patch

a=LegNeato for 1.9.2.5. Please ONLY land this on mozilla-1.9.2 default, as we
are still working on 1.9.2.4 on the relbranch
Attachment #433248 - Flags: approval1.9.2.4? → approval1.9.2.5+
Could someone add this to the 3.6.3/4 release notes?
Christian can.
seems the patch hasn't found the way to 3.6.4 as the problem is still in 3.6.4 !

btw: preview doesn't work with Fireworks too!
(In reply to comment #38)
> seems the patch hasn't found the way to 3.6.4 as the problem is still in 3.6.4

This won't be fixed until a version of Firefox is released that uses Gecko 1.9.2.5 or later (see comment 34); that will be Firefox 3.6.6 (because there will be no Firefox 3.6.5), sometime in July.  Or, you can use a Firefox 3.6.x nightly build today: ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-firefox-3.6.x/
Duplicate of this bug: 577671
It's NOT fixed.  I just reported this bug as 577671 and it was marked as a duplicate of this and "resolved."  But I'm running CS5, OS 10.6.4 and Firefox 3.6.6 and I can tell you the same problem continues.  Safari will open in Browser Preview, but not Firefox.
why don't you guys just admit your not going to fix this issue?

I expected more from you guys.
Firefox 3.6.6 was a "chemspill" release due to Bug 574905.
The fixed version will be Firefox 3.6.7, coming next week.
And the 3.6.7 candidate builds are available for testing from
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/3.6.7-candidates/build1/mac/
(In reply to comment #43)
> Firefox 3.6.6 was a "chemspill" release due to Bug 574905.
> The fixed version will be Firefox 3.6.7, coming next week.

After a long time waiting I don't have any hope anymore that the bug will be fixed in a official version of firefox.
I had been a fan of the firefox browsers since years, using the browser called Mozilla before
- but this long time to solve this bug did annoy me. 

In my opinion a bug is only solved if it is solved in the official version, not in a nightly build or a test version!
About comment 45, this *will* be in the next version of Firefox. You can download it in the link in comment 44, and it is a release candidate (that is, if no big issues are found those exact bits will be released as Firefox 3.6.7).
I just installed 3.6.7.  The problem is not resolved.
Just installed 3.6.8.  Problem is still not resolved.
Just installed 3.6.8.  Problem is still not resolved.
Mac OS X 10.6.4 + Firefox 3.6.8 + Dreamweaver CS3

* When Firefox is not running, the preview works as intended.
* When Firefox is running, the browser window comes to the front but nothing happens.

-> REOPEN
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Mac OS X 10.6.4 + Firefox 3.6.8 + Dreaweaver CS5

Preview doesn't work whether Firefox is running or not.
(In reply to comment #51)
> Mac OS X 10.6.4 + Firefox 3.6.8 + Dreaweaver CS5
> 
> Preview doesn't work whether Firefox is running or not.

Per comment 10, Dreamweaver CS5 does not use this AppleEvent anymore, so any problems with CS5 are a different bug.
(In reply to comment #50)
> Mac OS X 10.6.4 + Firefox 3.6.8 + Dreamweaver CS3
> 
> * When Firefox is not running, the preview works as intended.
> * When Firefox is running, the browser window comes to the front but nothing
> happens.

Can you start Dreamweaver CS3 with AppleEvent logging enabled, and preview both with Firefox closed, and then again with it already open?

From the Terminal:

export AEDebugSends=1
/path/to/Dreamweaver\ CS3.app/Contents/MacOS/ActualDreamweaverBinary

It would also be useful to see what Firefox reports in the second case (we can't log the first case, unfortunately, because to pick up the logging we have to launch Firefox ourselves from the Terminal, and we can't use Cocoa Scripting logging, which doesn't require that, because Firefox doesn't have a dictionary):

export AEDebugReceives=1
/path/to/Firefox.app/Contents/MacOS/firefox-bin

and then preview from Dreamweaver.

I suppose what everyone could be seeing is the last paragraph of comment 27, which is not related to dropping support for the AppleEvent (this bug), and the URL is getting transformed (or sent differently) when Firefox isn't open vs. when it is.
(In reply to comment #53)
Here are my logs, tested with Firefox, Safari, Chrome and Opera.

DW preview works with all browsers when the browsers are *not* running but doesn't work with Firefox 3.6.8 and Chrome when the browsers are running:

* Firefox 3.5.11 reads file:///Macintosh%20HD/Users/Kohei/Desktop/index.html successfully
* Firefox 3.6.8 does nothing
* Safari reads file:///Users/Kohei/Desktop/index.html successfully
* Chrome reads file:///Macintosh%20HD/Users/Kohei/Desktop/index.html and says the page is not found
* Opera reads file:///localhost/Users/Kohei/Desktop/index.html successfully
Since 3.6.8 Preview (remote too) works again for me.

here Preview works fine with FF 3.6.8, MacOSX 10.6.4, Dreamwever CS4!


But preview with file://somepath/index.html did work every time, only using remote like http://localhost/~user/index.html didn't work!


So it may be a different bug.
(In reply to comment #54)
> Here are my logs, tested with Firefox, Safari, Chrome and Opera.
> 
> DW preview works with all browsers when the browsers are *not* running but
> doesn't work with Firefox 3.6.8 and Chrome when the browsers are running:

Can you run the tests for Safari again, this time doing

defaults write com.apple.safari NSScriptingDebugLogLevel 1

before starting any tests?  Output from that will show up in the Console when Safari is started automatically by Dreamweaver and with the rest of the logging when you start Safari manually.  So you know what you're looking for in the Console, the NSScriptingDebugLogLevel output should look something like

Safari[50607]: Suite NSCoreSuite, apple event code 0x3f3f3f3f
Safari[50607]: Suite NSTextSuite, apple event code 0x3f3f3f3f
Safari[50607]: Suite Safari, apple event code 0x73667269
Safari[50607]: Command: NSCoreSuite.Open (lots more text after this)
etc.

Also, can you run the same suite of tests with Camino, doing 

defaults write org.mozilla.camino NSScriptingDebugLogLevel 1

before starting any tests?

==

Bizarrely enough, it looks like Dreamweaver is sending an 'odoc' event with a POSIX path as an alias when apps aren't open, and 'WWW!OURL' with a bizarre file:// URL as a string when apps are already open (not sure why the app-not-open case didn't work from the get-go with 3.6.x, given that, though).
Duplicate of this bug: 596147
(In reply to comment #54)
> DW preview works with all browsers when the browsers are *not* running but
> doesn't work with Firefox 3.6.8 and Chrome when the browsers are running:

Kohei: which version of Dreamweaver. Sounds like this bug is about CS3, but a different problem may remain in CS5

I went ahead and reopened bug 577671 since it sounds like there are two different bugs (comment 52). It's unclear to me whether this one is fixed or not though, sounds like it is for some people.
Summary: Preview from Dreamweaver does not work in FF3.6 → Preview from Dreamweaver CS3/CS4 does not work in FF3.6
Whiteboard: problem with CS5 is bug 577671
I've got CS5 and I can tell you that with 3.6.10 browser preview does not work whether Firefox is running or not running, and that Safari works just fine whether it's already open or not.
(In reply to comment #58)
> Kohei: which version of Dreamweaver. 

I have CS3.
Kohei: can you run the additional tests from comment 56 and attach the logs?
Duplicate of this bug: 607358
Sorry for the delay...

Here are logs from Safari and Camino with NSScriptingDebugLogLevel 1.

Results:

* When Camino is not running, Dreamweaver opens
  file:///Users/Kohei/Desktop/index.html with Camino
* When Camino is running, Dreamweaver opens
  file:///Macintosh%20HD/Users/Kohei/Desktop/index.html with Camino

* When Safari is not running, Dreamweaver opens
  file:///Users/Kohei/Desktop/index.html with Safari
* When Safari is running, Dreamweaver opens
  file:///Users/Kohei/Desktop/index.html with Safari
Thanks again, Kohei.  I've been very busy for a while, so I've got a lot to catch up on, but I'll try to get back to this bug sometime this week.
Is this fixed yet, because I am still running FF3.5.16 with Dreamweaver CS3 and would like to update the browser at some time?
My Dreamweaver CS3 previews fine in Safari and Netscape but nothing shows up in Firefox 3.6.13. DW CS3 previewed just fine with old Firefox 3.5 before I updated.

I'm not paying $5 for a "fix" that some said did not work, just checked Adobe site, can't find it, that solution seems to be removed.

I think the problem is Firefox 3.6.13 Running same system, MAC OS 10.6.4 on classroom macs with old Firefox 3.5, preview works.

Please email me when there's a fix, this is very annoying.
C'mon, honestly! This bug has been going on for years. Is it not possible that Adobe and Mozilla can get together and fix the dreamweaver preview issue!? Your up to FF4 and I can't upgrade beyond 3.5.16. I am a web developer, and the Firebug addon no longer supports 3.5.x. This is getting ridiculous. Not to mention the hours random people spend trying to figure out this problem when they decided to upgrade. I had upgraded Firefox versions for years before this, trouble free. Now, every time a new version comes out, I do a google search to see if you have fixed this bug. all versions of Adobe CS, FF3.6, Mac OS versions have this problem. I'm staying put until this gets fixed, and no I'm not going to pay 5$ for the 3rd party marginal addon fix. Geez.
(In reply to comment #67)
> C'mon, honestly! This bug has been going on for years. Is it not possible that
> Adobe and Mozilla can get together and fix the dreamweaver preview issue!? Your
> up to FF4 and I can't upgrade beyond 3.5.16. I am a web developer, and the
> Firebug addon no longer supports 3.5.x. This is getting ridiculous. Not to
> mention the hours random people spend trying to figure out this problem when
> they decided to upgrade. I had upgraded Firefox versions for years before this,
> trouble free. Now, every time a new version comes out, I do a google search to
> see if you have fixed this bug. all versions of Adobe CS, FF3.6, Mac OS
> versions have this problem. I'm staying put until this gets fixed, and no I'm
> not going to pay 5$ for the 3rd party marginal addon fix. Geez.

Seriously...why can't you people fix this? or do you just not want to fix it?
Does it take too much time? is it not worth the effort? WHAT? 
He's right(1world4all@gmail.com), you've been blowing smoke up our **s for years now, and you haven't solved anything. I refuse to believe that you can't fix this...it worked at one time...isn't there some way to incorporate the old with the new???
You need to log in before you can comment on or make changes to this bug.