Multiple entries of the same extension and theme appear if the installation/update is triggered more than once

VERIFIED FIXED in mozilla2.0b7

Status

()

defect
P2
normal
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: tchung, Assigned: mossop)

Tracking

Trunk
mozilla2.0b7
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [AddonsRewriteTestday][rewrite][has patch])

Attachments

(2 attachments)

Reporter

Description

9 years ago
If installing a traditional addon via AMO or websites, the new addons manager doesn't seem to detect if the addon has already been installed and queued up.  We need a way to determine the addon is already there, and not keep writing entries into the queue.

* See screenshot

Repro:
1) install nightly Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US;
rv:1.9.3a5pre) Gecko/20100430 Minefield/3.7a5pre
2) visit a AMO site and search for a compatible plugin (eg. Quick notes @ https://addons.mozilla.org/en-US/firefox/addon/13572)
3) click the Add to Firefox button, then the Install button on the popdown.
4) Repeat this step a few more times when completed
5) switch to about:addons, and verify Quick notes is duped a few times in the queue before restarting.

Expected:
- if the addon is already in the install queue, there shouldnt be multiple rows being written to it.
Reporter

Updated

9 years ago
Blocks: 550048
It's not only for installed addons but also for canceled installations. Duping to bug 558134.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 558134
No longer blocks: 550048
Sorry but bug 558134 is already marked as fixed.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Blocks: 550048
Status: REOPENED → NEW
Summary: Need detection if addon is already been installed but not yet restarted → Multiple entries of the same extension and theme appear if the installation is triggered more than once
Assignee

Updated

9 years ago
Priority: -- → P2
Feels like something the API should be handling.
Blocks: 461973
No longer blocks: 550048
Some kind of link with bug 553966 here
Depends on: 553966
Duplicate of this bug: 587967
Duplicate of this bug: 588867
Duplicate of this bug: 591738
Summary: Multiple entries of the same extension and theme appear if the installation is triggered more than once → Multiple entries of the same extension and theme appear if the installation/update is triggered more than once

Comment 9

9 years ago
This is still happening.
Duplicate of this bug: 604787
blocking2.0: --- → ?
Assignee

Updated

9 years ago
Assignee: nobody → dtownsend
blocking2.0: ? → betaN+
Assignee

Updated

9 years ago
Blocks: 587088
Posted patch patch rev 1Splinter Review
Simple approach, when an install starts check for pending installs of the same add-on in the same install location and cancel them.
Attachment #483680 - Flags: review?(robert.bugzilla)
Assignee

Updated

9 years ago
Status: NEW → ASSIGNED
Whiteboard: [AddonsRewriteTestday][rewrite] → [AddonsRewriteTestday][rewrite][has patch][needs review rs]
Comment on attachment 483680 [details] [diff] [review]
patch rev 1

>diff --git a/browser/base/content/test/browser_bug553455.js b/browser/base/content/test/browser_bug553455.js
>--- a/browser/base/content/test/browser_bug553455.js
>+++ b/browser/base/content/test/browser_bug553455.js
>@@ -543,19 +543,18 @@ function test_renotify_installed() {
>             info("Timeouts after this probably mean bug 589954 regressed");
> 
>             // Wait for the complete notification
>             wait_for_notification(function(aPanel) {
>               let notification = aPanel.childNodes[0];
>               is(notification.id, "addon-install-complete-notification", "Should have seen the second install complete");
> 
>               AddonManager.getAllInstalls(function(aInstalls) {
>-              is(aInstalls.length, 2, "Should be two pending installs");
>+              is(aInstalls.length, 1, "Should be two pending installs");
Should be one pending install?

r=rstrong with that
Attachment #483680 - Flags: review?(robert.bugzilla) → review+
Whiteboard: [AddonsRewriteTestday][rewrite][has patch][needs review rs] → [AddonsRewriteTestday][rewrite][has patch]
This actually landed: http://hg.mozilla.org/mozilla-central/rev/efd0cb45eb37
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago9 years ago
Flags: in-testsuite+
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
Verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101025 Firefox/4.0b8pre
Status: RESOLVED → VERIFIED
Target Milestone: mozilla2.0b8 → mozilla2.0b7
You need to log in before you can comment on or make changes to this bug.