Last Comment Bug 564583 - Add four new IDN TLDs to the PSL (рф, السعودية, امارات, مصر)
: Add four new IDN TLDs to the PSL (рф, السعودية, امارات, مصر)
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Peter Kasting
:
Mentors:
http://www.icann.org/en/minutes/resol...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-08 01:22 PDT by Gervase Markham [:gerv]
Modified: 2010-06-24 05:41 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.7-fixed
.11-fixed


Attachments
patch v1 (938 bytes, patch)
2010-05-25 13:05 PDT, Peter Kasting
gerv: review+
dveditz: approval1.9.2.7+
dveditz: approval1.9.1.11+
Details | Diff | Splinter Review

Description Gervase Markham [:gerv] 2010-05-08 01:22:08 PDT
(Ah, the joy of trying to get those RTL languages into the Summary line...)

ICANN has approved four new TLDs, which are IDNs. We should find out what "shape" they intend to use for their registrations, and add the appropriate entries to the PSL. They have already contacted us for IDN TLD whitelist inclusion, so we have people we can ask.

Gerv
Comment 1 Gervase Markham [:gerv] 2010-05-11 04:56:13 PDT
"Thanks for your clarification ...

For our new IDN label we will start with option1 (Flat) but might enable 3rd levels in the future (we have reserved some names for that purpose).
So the list should have the following entries:

// xn--mgberp4a5d4ar : http://www.nic.net.sa/
السعودية


BTW for .sa we are going to open 2LD registration at the end of this year. 

Here are the updated entries for .sa ccTLD:

// sa : http://www.nic.net.sa/
sa
com.sa
net.sa
org.sa
gov.sa
med.sa
pub.sa
edu.sa
sch.sa

So is there anything else I should do?

With best regards,
 
Raed I. Al-Fayez"
Comment 2 Gervase Markham [:gerv] 2010-05-11 07:10:10 PDT
Actually, there's a whole load of these in the pipeline:
http://www.icann.org/en/topics/idn/fast-track/string-evaluation-completion-en.htm

Gerv
Comment 3 Gervase Markham [:gerv] 2010-05-12 02:14:54 PDT
Dear Gervase,

After consulting our management we don't think we will use 3LD in the new IDN ccTLD for Saudi Arabia.

So there are no need to add the reserved name to the list.

With best regards,
 
Raed I. Al-Fayez
Comment 4 Sergey «Mithgol the Webmaster» Sokoloff 2010-05-13 02:33:47 PDT
This is bug 563309, bug 564213, bug 564214 and bug 564240.
Comment 5 Jo Hermans 2010-05-13 03:12:38 PDT
(In reply to comment #4)
> This is bug 563309, bug 564213, bug 564214 and bug 564240.

No, these bugs are for adding IDN-capable TLD's to the network.IDN.whitelist configuration in about:config. This bug is about the Public Suffix list, used for defining second-level TLD's, as seen in <http://publicsuffix.org/>
Comment 6 Gervase Markham [:gerv] 2010-05-25 04:51:34 PDT
pkasting: as you know, because the default rule applies, just adding these new TLDs to the PSL makes no functional difference. But we should probably do it anyway, as "placeholders". Does that make sense to you?

Gerv
Comment 7 Peter Kasting 2010-05-25 12:32:45 PDT
Actually, in Chrome this makes a great difference, because without this, people who type in these new addresses won't navigate by default.  So I'd like to see this ASAP.  I should have written a patch myself, I've just been busy with other stuff :/
Comment 8 Peter Kasting 2010-05-25 13:05:22 PDT
Created attachment 447346 [details] [diff] [review]
patch v1

Here's my attempt at a patch.  This adds the four IDNs, alphabetized by their punycode representation.  It also adds the "sa" entry for upcoming registration of 2LDs.

The reference links on these are not very great because most of the registrars don't have a ton of documentation on these TLDs.
Comment 9 Gervase Markham [:gerv] 2010-05-26 03:02:08 PDT
Comment on attachment 447346 [details] [diff] [review]
patch v1

r=gerv. Are you going to do a different part for the 10 or so others referenced in that ICANN document?

Gerv
Comment 10 Peter Kasting 2010-05-26 11:01:00 PDT
(In reply to comment #9)
> Are you going to do a different part for the 10 or so others referenced
> in that ICANN document?

Are those already approved and ready to go in the wild?  I figured we should add things once they were actually OKed or started working, I'm not sure what the status of everything in that document is.
Comment 11 Gervase Markham [:gerv] 2010-05-27 01:22:44 PDT
ICANN has approved them; I very much doubt their sponsors would give up now. And I don't see any harm in adding them.

Let's do that in a different bug. I'll check this one in soon.

Gerv
Comment 12 Gervase Markham [:gerv] 2010-05-27 02:06:43 PDT
http://hg.mozilla.org/mozilla-central/rev/bcce9cc5b31b

Gerv
Comment 13 Daniel Veditz [:dveditz] 2010-06-14 10:35:33 PDT
Comment on attachment 447346 [details] [diff] [review]
patch v1

Approved for 1.9.2.6 and 1.9.1.11, a=dveditz for release-drivers
Comment 14 Peter Kasting 2010-06-18 13:35:38 PDT
Can someone land on branch for me?
Comment 15 Reed Loden [:reed] (use needinfo?) 2010-06-18 13:43:52 PDT
(In reply to comment #14)
> Can someone land on branch for me?

Sure. In the future, just add the "checkin-needed" keyword.
Comment 16 Peter Kasting 2010-06-18 13:44:54 PDT
OK.  I normally use that to get things landed on trunk, I wasn't sure if I added it to a Status:Fixed bug if someone would go and land things on branches for me :)
Comment 17 Marco Bonardo [::mak] (Away 6-20 Aug) 2010-06-21 15:53:26 PDT
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/0c6658acbb13
Comment 18 Gervase Markham [:gerv] 2010-06-24 03:10:18 PDT
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/8f036444fdbe

Gerv

Note You need to log in before you can comment on or make changes to this bug.