Add .рф (Unicode Russian Zone) to IDN whitelist

VERIFIED FIXED

Status

()

VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: pkasting, Unassigned)

Tracking

({verified1.9.2, verified1.9.3})

Trunk
x86
All
verified1.9.2, verified1.9.3
Points:
---

Firefox Tracking Flags

(status1.9.2 .4-fixed)

Details

(Reporter)

Description

9 years ago
According to http://news.bbc.co.uk/2/hi/technology/10100108.stm , ICANN has approved three new TLDs:

Egypt: مصر
Saudi Arabia: السعودية
United Arab Emirates: امارات

I'm not totally sure when domains will be available in these and who the registries managing them are.  If they're legit, we'll need to add them to the eTLD list.

Comment 1

9 years ago
egypt        : bug 564213
saudi arabia : bug 563309
emirates     : bug 564214    	 

and the BBC forgot russia (.рф) :-)
(Reporter)

Comment 2

9 years ago
OK, let's make this one be about Russia then, since the others are on file.
Summary: New TLDs for Arabic countries? → New TLD for Russia (.рф)
The Russians have already been in touch; they are putting their documentation together.

Gerv
Hi, Gervase,

See in attachment IDN Table for TLD "РФ" (Domain xn--p1ai).
Relevant Policy Document URL: http://www.cctld.ru/en/docs/rulesrf.php

Best regards,
George Georgievsky
The table attached to the email I got basically said "Russian characters, western digits and hyphen only". And that restriction is repeated in sections 3.3.2.2 and 3.3.2.3 of the URL given above. There is a risk from ASCII/Russian mixing, but they are not permitting that. So this seems fine to me.

Gerv
Summary: New TLD for Russia (.рф) → Add .<RF> to IDN whitelist

Updated

9 years ago
Duplicate of this bug: 565619
Duplicate of this bug: 566810
Duplicate of this bug: 567117
Summary: Add .<RF> to IDN whitelist → Add .рф (Unicode Russian Zone) to IDN whitelist
Component: Networking → Networking: Domain Lists
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 9

9 years ago
Verified
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a6pre) Gecko/20100617 Minefield/3.7a6pre
Status: RESOLVED → VERIFIED
status1.9.2: --- → .4-fixed
Keywords: verified1.9.2, verified1.9.3
QA Contact: networking → networking.domain-lists

Comment 10

8 years ago
The issue is not fixed for HTTPS protocol for Russian (.РФ) domain.
When you go to some HTTPS site you can see the *.xn--p1ai domain name instead of *.рф. (I refer to blue 'secure' piece on the left of URL textbox)
(In reply to comment #10)
> The issue is not fixed for HTTPS protocol for Russian (.РФ) domain.
> When you go to some HTTPS site you can see the *.xn--p1ai domain name instead
> of *.рф. (I refer to blue 'secure' piece on the left of URL textbox)
Please file a new bug for this issue.

Comment 12

8 years ago
(In reply to comment #10)
> The issue is not fixed for HTTPS protocol for Russian (.РФ) domain.
> When you go to some HTTPS site you can see the *.xn--p1ai domain name instead
> of *.рф. (I refer to blue 'secure' piece on the left of URL textbox)

That seems to have been fixed in 4.0b9pre, but I haven't found back the bug for it.

example : https://www.аэрофлот.рф/cms/

( their certificate is actually invalid, as it belongs to *.aeroflot.ru )
You need to log in before you can comment on or make changes to this bug.