Firefox button should be hidden in full screen mode

RESOLVED FIXED in Firefox 4.0b2

Status

()

Firefox
General
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Shawn Thompson, Assigned: dao)

Tracking

Trunk
Firefox 4.0b2
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a6pre) Gecko/20100613 Minefield/3.7a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a6pre) Gecko/20100613 Minefield/3.7a6pre

Alongside the other Aero bug we've been having with full screen mode, the introduction of the Firefox Button to nightly builds has also caused an issue, causing it to still appear if the toolbar is set to auto-hide.

Reproducible: Always

Steps to Reproduce:
1. Go into full screen mode on the default theme.
2. Set the toolbar to auto-hide
Actual Results:  
The Firefox Button remains visible on the handle for retracting the auto-hidden toolbar.

Expected Results:  
The button should either not be there, or be docked on the same line as the tabs in full screen mode.
(Reporter)

Comment 1

8 years ago
Created attachment 450976 [details]
Screenshot

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
(Reporter)

Comment 2

8 years ago
Oh, and also because of this, the hot spot for the reactivation of the toolbar ends up being the line below the strip with the button on it.
(Reporter)

Updated

8 years ago
Keywords: uiwanted
(Reporter)

Updated

8 years ago
OS: Windows Vista → All
Hardware: x86 → All
This is fixed with most recent hourly, please dupe against bug 575994 since that fixed it.
Scratch that, its still not fixed, but now you cannot use autohide now that bug 575994 is there.
(Assignee)

Updated

8 years ago
Duplicate of this bug: 576063
(Assignee)

Updated

8 years ago
Duplicate of this bug: 575155
(Assignee)

Updated

8 years ago
Assignee: nobody → dao
Blocks: 570795
Status: NEW → ASSIGNED
Keywords: uiwanted
Summary: Firefox Button still appears on auto-hidden full screen toolbar → Firefox button should be hidden in full screen mode
(Assignee)

Comment 7

8 years ago
Created attachment 455402 [details] [diff] [review]
patch
Attachment #455402 - Flags: review?(gavin.sharp)
Attachment #455402 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 8

8 years ago
http://hg.mozilla.org/mozilla-central/rev/519d798e7855
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7b2
(Assignee)

Comment 9

8 years ago
(In reply to comment #8)
> http://hg.mozilla.org/mozilla-central/rev/519d798e7855

err, http://hg.mozilla.org/mozilla-central/rev/1f59c5f4d8d3
(In reply to comment #9)
> err, http://hg.mozilla.org/mozilla-central/rev/1f59c5f4d8d3

--> Bug 575449.

Comment 11

8 years ago
The button should only be hidden when the toolbar is hidden, but shown when the toolbar is not hidden, so that one can still access the appmenu when the toolbar is not hidden. In short, only hide the button when the toolbar is collapsed/hidden.
This is about full screenmode not maximized or normal mode.  Its not suppose to show at all. -  we didn't show the menubar in fullscreen mode before either.

Updated

8 years ago
Duplicate of this bug: 577439
(Assignee)

Updated

8 years ago
Blocks: 576063

Updated

8 years ago
Duplicate of this bug: 577942

Updated

8 years ago
Duplicate of this bug: 577692
You need to log in before you can comment on or make changes to this bug.