Closed Bug 584960 Opened 10 years ago Closed 10 years ago

python xpidl parser spits out Unexpected attribute '%s' without expanding %s

Categories

(Core :: XPCOM, defect)

x86
macOS
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 578478

People

(Reporter: timeless, Assigned: timeless)

Details

Attachments

(1 file)

error: Unexpected attribute '%s', ../../../../dist/idl/nsIDOMJSWindow.idl line 73:3
  [deprecated] void         captureEvents(in long eventFlags);
   ^
Blocks: 407216
Assignee: nobody → timeless
Status: NEW → ASSIGNED
Attachment #463459 - Flags: review?(jorendorff)
Blocks: 584967
Blocks: 584970
Blocks: 584971
Blocks: 584974
Blocks: 584976
Blocks: 584977
Blocks: 584981
Blocks: 584982
Blocks: 584983
Blocks: 584997
Blocks: 584998
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 578478
Attachment #463459 - Flags: review?(jorendorff) → review-
bsmedberg; right now the patch for that bug doesn't actually fix the primary bug which is that the error message doesn't fill in '%s', ignore the bit where I pretend to handle deprecated.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.