Mail message body area displays as blank; if double click header, blank window opens

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P3
normal
RESOLVED WORKSFORME
18 years ago
4 years ago

People

(Reporter: ekrock's old account (dead), Unassigned)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Seeing this on WinNT 4.0 SP4 with both 10/25 and 10/30 N6 Commercial builds.

What happens: after using Mail for a while and reading and deleting messages,
you delete a message. The next message is automatically selected, but the
message body is displayed as blank, and if you double click the header, a blank
window opens.

I think this may be related to bug 58519, "Mail Window displays a different
message body that doesn't match selected message header," since they tend to
occur at about the same time.

No reliable way to reproduce this, but it's happening frequently in 10/25 and
10/30 Commercial builds, so filing to put on radar.

cc:ing kmurray for severity and possible rtm assessment. Marking regression as
this didn't happen in previous builds.
(Reporter)

Updated

18 years ago
Keywords: regression

Comment 1

18 years ago
double clicking the header has been happening for at least a couple of months
and was rtm-'d a while ago.

Comment 2

18 years ago
This is happening in News all the time.

Comment 3

17 years ago
Works for me in the 0.9.2 builds.  Anyone still having a problem?

Comment 4

17 years ago
I'm having a similar problem in 0.9.5 (2001101201). When reading news, if I have
an item selected, then open the message pane, the message doesn't display. I
have to select a different message and then go back, then it displays fine.

Comment 5

17 years ago
By the way--I'm seeing this in the Linux version. I just noticed this bug was
marked as NT only; is it happening in other builds?

Comment 6

17 years ago
reassigning to ssu.
Assignee: putterman → ssu

Comment 7

17 years ago
Note: I've upgraded to 0.9.6 and the problem is still there. Still Red Hat Linux
7.2.

Comment 8

17 years ago
Related to Comment #4 
When reading "MAIL", if I have an item selected, then open the message pane, the
message doesn't display.  The message pane shows all "gray", the color of what
would be the header portion of the message.  I believe that if I close the
message pane and reopen it, the message will display correctly.  I will double
check on the next blank message pane I get.

I have been seeing this problem since at least Milestone 0.9.7 and on the
2002012903 nightly build running on Win98.

Comment 9

17 years ago
Confirmation: If I open a message and get an all gray message the following
steps will fix the problem.
1.
Close the message pane
2.
Re-open the message pane
The email message will now appear normal. (Header and Text readable and scrollable)

One of my co-workers said they never have this problem.  In looking at how he
works I noticed a difference between how I read mail and how he does.  I keep
the message pane closed most of the time.  When I want to view an email message
I select the thread and click on the ^==^ slider to open the message pane. 
After I have read the message I close it again.  He leaves his message pane open
and just clicks on the thread he wants to see (Not opening and closing the
message pane).

When I showed him how I work, he tried reading his mail by opening and closing
the message pane between messages and sure enough he notice the problem.  So,
perhaps the problem has to do with opening and closing the message pane.

I have not yet been able to determine why some messages have this problem and
other do not.

The problem appears to be Cross Platform.  I have had the problem in 0.9.7
Milestone and a recent nightly 0.9.8 2002012903 both running on Win98.  My
friend duplicated the problem on 0.9.6 for Mac OS/X (Fizzilla?)

Comment 10

17 years ago
The problem is still present in 0.9.9 milestone build (2002031104) for Windows.
 Running on Win98.

Comment 11

17 years ago
Bug still exists in 2002031803 Win32.

Is anyone actually working on this, or have any idea why it's happening?

Comment 12

16 years ago
  I have also experienced this problem in Win98 using Nightly Builds starting
back in late Jan (build ids -- 200201xxxx and up).  It is an intermittant
problem at best, but recently (last two weeks) got worse.  Either I would open
the mail client and the message headers would not display or if they displayed I
could not open the message itself.
  I work pretty much as Ed Lana does (described in comment #9 below), opening
and closing each message.
  The only way I was able to get the client to work again was (after backing up
my profile info) uninstalling Mozilla and reinstalling.  It took about five
attempts to get everything to work again (more due to stupid things I did vs.
what the software was doing).  But still this is unacceptable.  When one has to
uninstall and reinstall to get a product to work the frustration will move the
user onto a different product.  That while it might have less functionality will
work, and that is the bottom line, getting the damn thing to work.

Comment 13

16 years ago
I see this on Linux 1.0.0+ as well.
The only trend I can see, is that it seems to happen only to messages with
attachments, and even then not all messages with attachments.
Some work, some display a blank message pane.
After some more time working, messages that did work before ceased working.
Everything starts to work again after closing the "messenger" window, and
re-opening it.
Really annoying!
from an e-mail from former Netscape Client Director - 

-----------------------------------------------------------------
"I'm running the mail client on two machines - one at home (Win 98SE) and one at
work (Win XP) and am seeing the problem on both.  The mail server is Exchange
2000 via IMAP.

When I'm reading mail in 3 pane mode, after reading a few messages, the preview
pane gets into a state where it stops loading the new message selected. It gets
stuck with an old message. I can read new mail messages, but have to open them
in a new window. The preview pane is essentially frozen. I don't have specific
steps to get into this state but it happens a lot. The only way to get out of
this state is to quit Netscape and restart."
-----------------------------------------------------------------------

Esther/Gayatri - Has anybody on your team been able to reproduce this?
This bug might be related to http://bugzilla.mozilla.org/show_bug.cgi?id=107466

Comment 16

16 years ago
Using branch commercial build 20020610 on winxp I do not see this problem.  I
have changed my way of reading mail to match comment #8 (3-pane window, Message
pane collapsed so thread pane displays fully on right side).  I select messages
in thread pane by: Next button or down arrow on keyboard or clicking and if I
want to read the message I expand the Message pane below the thread pane.  I
then collapse the message pane when I am done reading a particular message.  I
have gone through a cleanup of my Inbox (I'm using a dredd IMAP server), by
selecting 50+ messages, deleted them and then continued reading and randomly
opening messages.  I still don't see the problem.  I will continue using Mail in
this manner for a couple of days to see if I can reproduce this.   If those who
have reported scenarios in this bug can let me know what theme you are using, if
the sidebar is shown and how you sort your messages in the thread pane that
would help me try to reproduce your setup.

Comment 17

16 years ago
This is still happening to me on a daily basis.  I have been looking at the mail
and I can't seem to find a pattern.  It happens with text mail, HTML mail, mail
with and without attachments, and mail with big headers and little headers.  I
have not tried using any of the 1.0+ nightly builds.

Window 98  / Mozilla 1.0 (Build: 2002053012)  / Modern Theme
Pop Mail / Mail Sidebar open & thread pane open (open and close mail detail pane
for each email)

Comment 18

16 years ago
I have questions for all who report seeing this problem, please answer so I can
build a test scenario.
1.) Is your email account IMAP OR POP?  I see at least 1 person mention IMAP and
one POP.
2.) One person reported their mail server is Exchange server 2000, anyone else
using Exhchange server 2000?
3.) Has anyone set up your account to have your mail location so it's shared
with Communicator 4.7?  We don't recommend this at all, but some people have
been known to do this.
4.) Has anyone tried renaming the .msf file for the inbox to see if this problem
is due to a corrupt .msf file.  The .msf file is a summary file that displays
the headers in the thread pane.  If it's a corrupt .msf file due to a problem
build it will continue with this type of behavior, new builds won't fix it.
5.) Are you using the default 3-pane layout (folder pane on left, thread and
message pane on right?
6.) Anyone using the Commercial builds?

To be sure we're talking about the same thing: 3-pane window consists of Folder
pane w/side bar below it, Thread pane (displays the message headers upper right
side of 3-pane window) and Message pane (displays the whole message lower right
side of 3-pane window under the Thread pane).
Basically those reporting are in the 3-pane mode with the message pane
collapsed, the Folder pane and Thread pane expaneded.  User navigates through
messages with down arrow keys, or Next button deleting or filing messages
randomly, expanding the message pane to view the content of the message.

Comment 19

16 years ago
> I have questions for all who report seeing this problem,
> please answer so I can build a test scenario.
> 1.) Is your email account IMAP OR POP?  
>
Mine's POP, and I also have the same problem with NNTP news.

> 2.) One person reported their mail server is Exchange
> server 2000, anyone else using Exhchange server 2000?
>
I'm not sure what server BellSouth uses, but I do know it runs on Windows 2000.

> 3.) Has anyone set up your account to have your mail
> location so it's shared with Communicator 4.7?
>
No. I don't even have 4.7 installed.

> 4.) Has anyone tried renaming the .msf file for the inbox
> to see if this problem is due to a corrupt .msf file.  The
> .msf file is a summary file that displays the headers in
> the thread pane.  If it's a corrupt .msf file due to a
> problem build it will continue with this type of behavior,
> new builds won't fix it.
>
I haven't tried this yet.

> 5.) Are you using the default 3-pane layout (folder pane on
> left, thread and message pane on right?
>
Yes.

> 6.) Anyone using the Commercial builds?
>
I've seen it with both the main releases (0.9.8, 0.9.9, 1.0) and with nightlies.
 
> To be sure we're talking about the same thing: 3-pane
> window consists of Folder pane w/side bar below it,
>
I have the side-bar closed. My folder window extends over the entire left 
column.

> Basically those reporting are in the 3-pane mode with the
> message pane collapsed, the Folder pane and Thread pane
> expaneded.  User navigates through messages with down arrow
> keys, or Next button deleting or filing messages randomly,
> expanding the message pane to view the content of the
> message.
> 
That's absolutely correct.

Comment 20

16 years ago
Thanks Shane, I have at least one reproducible case for one of the scenarios
listed above coment #8, we may have multiple bugs here (comments 12 & 13), let's
tackle one at a time.

1. launch app
2. open your POP mail account in 3-pane view, collapse the message pane
(internal testers can use the qatest04 pop mail account, please select leave msg
on server before logging in)
3. From the top of the list, navigate down through your read and/or unread
messages using arrown-down or by clicking on several headers, then using the
Delete button, delete 4 in a row (internal testers, it's OK to delete messages
from qatest04)
4. When 5th message is highlighted after delelting 4, expand the message pane
(clicking the grabber only once, clicking it mutiple times doesn't show the
problem).

Sometimes the Result: The message displays the header, but the body is grey just
like the background in the header.  Collapsing then expanding the message pane,
the message is now viewable.  
Note: Internal tester, if this doesn't happen the first time, continue with this
scenario, I'm sure you will see it within a minute or two.  Also, when expanding
the message pane, it needs to be larger than the hearder area.

Expected: To always see the message displayed.

Comment 21

16 years ago
Nominating for the reproducible scenario.  If we fix this one, we can isolate
and log new bugs if necessary for the more serrious scenarios in this bug that
haven't been reproduced yet.  Those scenarios could be part of this bug if
reporter has a slow connection and are running into this bug with a msg with a
large attachment. (ie. Original bug report sounds like it might be a dup of
fixed bug 107466.  Scenarios by Shane and Ed sounds like the reproducible case
listed above.  Robert, Lev's & comment 14 scenarios seem to be more serious,
they get progressively worse and can't recover easily.)
Keywords: nsbeta1

Comment 22

16 years ago
Discussed in mail news bug meeting.  Decided to minus this bug.
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → mozilla1.2alpha
Please unminus this bug, and fix it!!  =)

I've seen this for several months, if not years.  ie - virtually forever.  I
tried to debug it with some people on IRC but they just kept telling me to
delete my profile.

I have three computers running Mozilla (various builds) under Linux 2.4 and
Windows 98.  All have access to my IMAP account, and all have the same problem.

I was content to blame the server and wait (uw-imap), but the problem also
happens with a collegue who gets the same emails as I do using solid-pop3d and
Netscape 6 (6.2?) under Windows 98.

The message is a text dump from an error generated on a webpage.  For me,
reading any of these messages triggers the problem.  The first message is loaded
and displayed fine, then MailNews goes into "blank message only" mode.

I can recover the session by closing MailNews and reopening it, but my deleted
messages (move to trash) no longer appear as marked deleted, and reappear in my
Inbox (as new or read, I don't know, but not deleted).

Since they contain somewhat private information, I'd prefer not to post a sample
message, but I can give a possible hint: they are all composed of this form:

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<< MESSAGE START
[Perfectly Valid Headers, no MIME]

[text]

-- 8< --  -- 8< --  -- 8< --  -- 8< --  -- 8< --  -- 8< --  -- 8< --
[text of form ``foo: bar'']

[text]

[text]

-- 8< --  -- 8< --  -- 8< --  -- 8< --  -- 8< --  -- 8< --  -- 8< --

[text]

[text]
--------------------------------------------------
 [text of form ``foo: bar'', "bar" may contain embedded NULLs (0x00)]

==================================================

[text]
--------------------------------------------------
 [text of form: ``foo: bar'', "bar" may contain semicolons]

==================================================

[text]
--------------------------------------------------

==================================================


[text]
--------------------------------------------------

==================================================

[text]

[text]
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> MESSAGE END

The blank sections may contain more "foo: bar" pairs but the one message I
pulled up did not, so they are not critical to reproduction.  Actually, there is
a lot of "foo: bar" stuff and one guess would be a problem in the MIME handling.
 Of course this is just a guess, but no MIME version is specified here and there
are lots of MIME looking things.

OS should be marked as 'all' ...

Comment 24

16 years ago
I don't use mail this way, but when I tried the procedure in comment #9 I can
readily reproduce it on local mail folders.  Yet to reproduce on IMAP account.

Windows NT 4.0 SP6a  / Mozilla/5.0 (Windows; U; WinNT4.0; ja-JP; rv:1.0.0)
Gecko/20020530  / Pinball Theme

Comment 25

16 years ago
I see this problem on Mac OSX 10.1.5/Build 2002072203

When I open specific email messages either in the preview pane or as a seperate
window the message text does not display.  None of the workarounds is effective.

This is true for specific messages so I suspect that it may be related to
encoding of the messages.  I can forward the source for any of the messages on
request (I can't make attachments here)

Comment 26

16 years ago
Running Win2K Mozilla 1.0 this happens frequently after viewing an HTML message.
I would view the HTML message then click on a plain text message and the plain
text would appear blank. Click back on HTML message, can see it, click on plain
text, it's blank. Also having problems deleting the HTML message on occasion.
Press delete button and nothing happens message is still in pane, and opening
imap account in other client the message is not deleted.

Comment 27

16 years ago
I have just had the same problem on my Windows ME system, running Mozilla 1.2b
Build ID 2002110508, with 512MB SDRAM and an AMD Duron 900MHz processor.  My
mail server is a POP 3 server, but I am not sure what software my ISP (Lock-Net
Internet Services, 865-558-0100 for Tech Support) is running on their mail
server.  I have not experienced this problem on any of my other previous builds.
 Also, there ia a recurrent new message dated 12/31/69 @ 0700 from a blank
Sender with nothing in the body, also.  The problem occurred right after I
launched Mozilla, entered my Software Password, downloaded 12 new messages, then
read a couple of them.  When I tried to open the third one, I got a blank
window, and after double-clicking on the message, got another blank full page
window.  None of the remaining unread messages (after I clicked on them, they
became "read" messages, but still with nothing in them) had anything in the body
of the messages.  I restarted Mozilla, and then my whole system, with no
changes.  I deleted the recurrent message dated 12/31/69 @ 0700 several times
and emptied my trash folder, but the message keeps showing up again.  I just
downloaded the latest virus definition updates for my AVG 6.0 Free Edition
Anti-Virus software and still have the problem, with no viruses detected.

Comment 28

16 years ago
*** Bug 191571 has been marked as a duplicate of this bug. ***

Comment 29

16 years ago
I am seeing the same problem with Mozilla 1.3 on Win2k, accessing an exchange
serer via IMAP:

- occasionally, messages appear as blank, view source also shows a blank message
body
- these messages had previously been successfully read 
- when navigating to the message using the keyboard, the message header area
(Subject, From, Cc, ...) remains unchanged from the previous messsage (but the
body area goes blank)
- restarting Mozilla does not fix the problem
- I recall that removing the ImapMail directory fixed the problem (... but of
course all message headers are re-loaded)

To me, this looks like a corruption of the locally cached IMAP information.

Comment 30

16 years ago
This problem developed for me specifically after updating the ATI S3-Savage
driver on my IBM T22 (bug 101055, 139271)

Email Server - Linux Sendmail POP3
Mozilla - 1.2.1, 1.3b
Message View Method - 3 Pane with Message Pane Closed, Double Click Header to
view in New Window.
Result - New Message Window is Blank, Message Header is "not" marked as "read"

Additional:
- Open Message Pane and Single Click same Message Header displays message
correctly in Message Pane.
- With Message Pane Opened, double click on Message Header still opens an empty
window.
- Uninstall/Reinstall does not solve problem.
- Revert Video Driver does not solve problem.
- Setting a New Mail Account with IMAP does not solve problem.
- Unable to duplicte in Red Hat Linux or Mac OSX

"RESOLVED with Netscape 7.02 Install - Mozilla Reinstall Does NO Solve"


Hardware Config:
IBM Thinkpad T22
Win2k - SR2
900Mhz P3
384Mb RAM
S3 Savage IX w/MV 8Mb BIOS 4.02.50 - 64
S3 Driver v6.13.10.7050-7.90.50 1/24/03

Red Hat 8.0
Gnome
via Virtual PC 4
128Mb Allocated

Macintosh
Mac G3
OSX - 10.2.4
233Mhz
384Mb RAM
Onboard Video

PS - This is my first posting, so if I did this incorrectly, please let me know.

Comment 31

16 years ago
I was about to submit another bug entry, but this will suffice although it is
not quite the same.

When I do a message search, and double click a message or click open, a new
window opens that is completely blank except for the mailbox toolbar.  Clicking
any buttons on the toolbar has no effect.

This is with the recent 1.3 Mozilla Build in Win98 SE.  I'm trying to track down
an actual build number if that would help.

A current workaround is to click "Open File Folder" then click the message.

Comment 32

16 years ago
Duh, I found my build info.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312

Comment 33

15 years ago
Created attachment 123069 [details]
A message from an Outlook user

I get the blank message problem typically when I get messages from Outlook
users.

I have attached an example mail. I never get this problem on non-outlook sent
mail.

Comment 34

15 years ago
The same thing is happening to me.  I'm running OS-X on my Mac.  I was using
mail and everything was working fine and then it just stopped displaying the
message.  HELP!!

Comment 35

15 years ago
Adding to the long line of 'Me Too's...

I run Mozilla 1.4 at work and home.  In both cases I am using imap/ssl to
connect to my mail server (which is located on my home network).

I am seeing this problem daily when reading email from work.  Usually after a
couple hours of use.  The message body will be blank, and the header will show
the info from the last email I was able to open.  Sometimes I can click on the
'get messages' button and the message will be loaded.  This does not always
work.  This issue has always occurred within my inbox, but never happens with
messages from any of my folders.

When reading email from home (where the mail server is local) I have never had
this problem occur.

One thing comes to mind (and bear in mind that I do not know the Moz code) - it
seems like the message is getting flagged as having already been downloaded from
the server, even though it has not.  Then when I hit the 'get messages' button,
this message is skipped, because Moz believes I already have the text.

Comment 36

15 years ago
One more "me too" from me. W2K, Moz 1.5, IMAP/SSL

However, I never experienced it before 1.5 - I downgraded from 1.5rc1 to 1.4 for
precisely this reason and hoped the problem would go away in the final.

Comment 37

15 years ago
This behaviour disappears when the junk mail controls are disabled.

Comment 38

15 years ago
Disable junk mail controls did NOT eliminate this behavior for me.  (using Moz
1.4 linux).

In addition, I believe that it can be triggered by ANY mail, not just that sent
with Outlook.  Thunderbird 0.3 for example, produced a message that showed up
blank.  I had to restart mozzila to read it.

For what it's worth, when I go into Pine to read mail that has "failed" in this
way, the [N]ew flag is still set. 

Comment 39

15 years ago
It seems that I usually see this behavior on the *1st* message I attempt to read
after not interacting with MailNews for awhile.  (EG, I'm in another window for
10 minutes, switch to Moz, click a message, and see a blank with headers of the
previous message).  Subsequent clicks on other messages work fine, but the
"blank" remains that way until I restart.

Comment 40

15 years ago
I'm thinking that, for me at least, this has to do with IMAP locking.  I
often leave my computer at home checking mail.  When I get to work, my
Mozillas fight for the mailbox lock.  Here I've turned on the IMAP debugging
trace and clicked on a message which turned out blank:

5126[8df5c08]: ReadNextLine [stream=8e1c4c0 nb=26 needmore=0]
5126[8df5c08]: 8df09c8:cag.lcs.mit.edu:S-INBOX:CreateNewLineFromSocket: 9 OK UID
FETCH completed
5126[8df5c08]: 8df09c8:cag.lcs.mit.edu:S-INBOX:ProcessCurrentURL: entering
5126[8df5c08]: 8df09c8:cag.lcs.mit.edu:S-INBOX:SendData: 10 UID fetch 13464 (UID
RFC822.SIZE BODY[])
5126[8df5c08]: ReadNextLine [stream=8e1c4c0 nb=25 needmore=0]
5126[8df5c08]: 8df09c8:cag.lcs.mit.edu:S-INBOX:CreateNewLineFromSocket: * BYE
Lost mailbox lock
5126[8df5c08]: ImapThreadMainLoop leaving [this=8df09c8]

If I check the same message immediately after starting mozzila and letting it
check for new mail, I instead get:

5126[8df6540]: 8df1300:cag.lcs.mit.edu:S-INBOX:ProcessCurrentURL: entering
5126[8df6540]: 8df1300:cag.lcs.mit.edu:S-INBOX:SendData: 8 UID fetch 13464 (UID
RFC822.SIZE BODY[])
5126[8df6540]: ReadNextLine [stream=8e1cdf8 nb=0 needmore=1]
5126[8df6540]: ReadNextLine [stream=8e1cdf8 nb=56 needmore=0]
5126[8df6540]: 8df1300:cag.lcs.mit.edu:S-INBOX:CreateNewLineFromSocket: * 1452
FETCH (UID 13464 RFC822.SIZE 1375 BODY[] {1375}
5126[8df6540]: 8df1300:cag.lcs.mit.edu:S-INBOX:STREAM:OPEN Size: 1375: Begin
Message Download Stream
5126[8df6540]: ReadNextLine [stream=8e1cdf8 nb=71 needmore=0]

If -everyone- who's reporting similar behavior is running multiple clients in
this way, maybe we have a reason.  (and would the component change to Networking
IMAP or Backend (since this seems cache related; moz -thinks- it downloaded the
message, but it got interrupted)).
So we want (?) is 

if(trying to download && got a BYE from server){
   reconnect, stealing lock    //starts an unfortunate flood of headers 
   resume downloading message
}

Comment 41

15 years ago
I see this problem all the time and I also run multiple Mozillas accessing the
same inbox via IMAP.  Typically in order to resolve the issue, I have to exit
Mozilla and remove the entire directory for the account (the directory under
ImapMail on Linux).  Then Mozilla rebuilds everything the next time I connect
with that account and everything is fine again.

Comment 42

15 years ago
For me it always happens with the first message I download after starting
Mozilla. I need to switch to another folder and back to inbox, and everything is
fine.

Comment 43

15 years ago
Environment: 
Mozilla 1.6 (but I have seen the same bug on many previous generations)
WinNT SP5 or Win98SE
IMAP from Exchange server
Multiple Mozilla clients (on my different PCs) access the same IMAP account, but only one client accesses at a time.

Description:
After using Mailnews for awhile, when displaying a mail message with an attachment, when I open the mail, the body is completely blank. This occurs
whether I use the lower preview pane or double click on the header to open
a message window. View - Message Source does show the raw MIME content.  Once the body is blank on one Mozilla client, it usually is blank another client, but is NOT blank when viewed by MS Outluck. 8-(  The "blank body syndrome" is more likley to occur if I have moved the message from the Inbox to another folder.  Sometimes it seems to occur more frequently in folders with lots (2000+) messages. There seems to be no other rhyme or reason of why the message does not display.  Restarting Mozilla occasionaly allow the body to be display, but usually not.  

Deleting the .msf file sometimes helps, but usually not.

Comment 44

14 years ago
I'm experiencing this with only 1 mail client open. I'll be reading through a
list of messages and one will show up blank, with the headers showing for the
previous message. I'm wondering if this is some kind of corruption in the *.msf
files, as I recall once before that when this happened, I deleted the MSF file
for the folder that I was having the problem in and next time I opened
Thunderbird it rebuild the MSF file and I could read the message.

Sometimes I've also found I can fix the problem by right clicking on the folder
and doing Compact Folder. I've turned on IMAP logging, so I'll try and get a log
that shows the problem occuring.
Product: Browser → Seamonkey

Comment 45

13 years ago
This could be the same as

Bugzilla Bug 246966 Thunderbird does show blank page for some mails, due to
problems with storing the previous e-mail

or

Bugzilla Bug 292101 emails have lost their correct message and have text from
other messages, a few of the messages are now blank - correct messages were
present before they arrived


This seemed fixed in Thunderbird for a while, but is back in version 1.5 Beta 1
(20050928)

Should it go to "core"?

Comment 46

12 years ago
Worcester12345 in comment #45:
> 
> This seemed fixed in Thunderbird for a while, but is back in version 1.5 Beta 1
> (20050928)

how about now?

was the cause of the regression ever identified?
Assignee: ssu0262 → mail
OS: Windows NT → All
QA Contact: esther
Hardware: PC → All
Target Milestone: mozilla1.2alpha → ---

Comment 47

12 years ago
(In reply to comment #46)
> Worcester12345 in comment #45:
> > 
> > This seemed fixed in Thunderbird for a while, but is back in version 1.5 Beta 1
> > (20050928)
> 
> how about now?
> 
> was the cause of the regression ever identified?
> 

I think it is finally OK. Probably one of the two bugs I mentioned above.

Comment 48

12 years ago
closing WORKSFORME for Stefan (thanks Stefan) who doesn't have privs "Doesn't happen for me anymore. I regularly use the current stable Thunderbird and Seamonkey."

If you still have a problem, please comment in the bug.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 49

4 years ago
See also bug 232275. I'm getting a similar problem, but not really the same as either bug. Should I submit this separately?

Failure to display message bodies in the Body pane seems to happen in TB 24.6.0 in Windows 8, but only after I experimented with various TB display options. The normal window title is also missing. This has nothing to do with formatting on either Outlook or TB, since clicking on a folder in the folder pane, then any message listed in the Messages pane (with column headings) highlights the folder and message, but fails to show the body in the Body pane. To see the body, one must now double-click the message line in the Messages pane.

I think the problem is that something I did in my TB experimenting made the auto-download or auto-display feature stop working, regardless of message content. I was unable to retrace my steps enough to fix the problem.

I emphasize that this is new behavior; TB worked correctly for me for several months prior to my experimentation today.

Comment 50

4 years ago
(In reply to David Spector from comment #49)
> See also bug 232275. I'm getting a similar problem, but not really the same
> as either bug. Should I submit this separately?

If 232275 is "close enough", I'd skip filing a new bug for now because Joshua is in the process of rewriting libmime.

Comment 51

4 years ago
Turns out my problem probably not caused by libmime. Problem cause is experimenting with different layouts (Menu > View > Layout > ... Problem is empty message pane until TB is closed and reopened. Hope this helps someone.
You need to log in before you can comment on or make changes to this bug.