Closed Bug 586777 Opened 12 years ago Closed 12 years ago

Restore ctrl-space activation for on windows/linux

Categories

(Firefox Graveyard :: Panorama, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 4.0b4

People

(Reporter: Mardak, Assigned: Mardak)

References

Details

Attachments

(1 file)

We can try detecting if the event is coming from html:select or xul:tree. It seems somewhat fragile. Perhaps somehow detect if there's the multiple attribute set.
Depends on: 586753
I propose putting this on Raymond's plate.
Assignee: nobody → raymond
Changing to p1; aza wants it for tonight's nightly (which will kick off around 3am PDT).

Raymond: get some sleep first!
Priority: -- → P1
Mardak randomly blurted this into the chat: 

Mardak: tree seltype="multiple"
Mardak: http://www.hevanet.com/acorbin/xul/top.xul
Mardak: Trees, Simple from the left column
Mardak: [e.target.nodeName, e.target.hasAttribute("multiple"), e.target.getAttribute("seltype")]
Mardak: tree,false,multiple

I figure it may have bearing on this bug, or he may have just been speaking in tongues.
(In reply to comment #2)
> Changing to p1; aza wants it for tonight's nightly (which will kick off around
> 3am PDT).
> 
> Raymond: get some sleep first!

Rationale: If we don't get this in we'll be training our users muscle memory wrong. Also we'd have to rewrite/bifurcate documentation. Net-effect: before b4 we need this fixed.
Blocks: 586788
Finally, to give this some context:

* Mardak changed to a different keyboard shortcut because Control+Space can be used to select multiple elements of a list in Windows and Linux. This way we didn't break any tests.
* The new keyboard shortcut is not desirable for the reasons stated above (and more!)
* To switch back and not break tests (and maintain accessibility) we need to detect when we are in a multiple-select box (i.e., one is selected) and the not perform the Tab Candy zoom out. Else, we do.
Whiteboard: b4
Summary: Restore ctrl-tab activation for on windows/linux → Restore ctrl-space activation for on windows/linux
Attached patch v1Splinter Review
Assignee: raymond → edilee
Status: NEW → ASSIGNED
Attachment #465511 - Flags: review?(dolske)
Duplicate of this bug: 587055
Comment on attachment 465511 [details] [diff] [review]
v1

Blah. This kind of sucks to do, but such are the crowded world of keyboard shortcuts.

Aza/Dao: Would it make sense to look at changing this (in a followup) to Control-Tab? That was the key combo previously used by the, err, "Control Tab" feature (bug 465076). AFAIK there are no plans to bring that back (especially now that TabCandy is around), but maybe that key combo should be taken? ISTR some people complaining that Control-Tab no longer advanced to the next tab, though.

But perhaps that's a key combo that we don't need to worry about special-casing for other parts of the UI, and introducing inconsistent behavior?
Attachment #465511 - Flags: review?(dolske) → review+
We went with control-space because space is the biggest button around. And going into Tab Candy is rather a primal action. We were concerned about co-opting control-tab because it already has meaning around "move to next tab".

Also, control-tab requires moving your hand away from home row (at least, my hand) where as control-space does not.
Blocks: 587068
Attachment #465511 - Flags: approval2.0+
Whiteboard: b4 → b4 [fixed-tabcandy]
http://hg.mozilla.org/users/edward.lee_engineering.uiuc.edu/tabcandy-central/rev/96f0940b0fc8
Switch back to ctrl-space and check for certain nodes where we shouldn't handle it.
Mass moving all Tab Candy bugs from Mozilla Labs to Firefox::Tab Candy.  Filter the bugmail spam with "tabcandymassmove".
Product: Mozilla Labs → Firefox
Target Milestone: -- → ---
http://hg.mozilla.org/mozilla-central/rev/773be5540fcf
Switch back to ctrl-space and check for certain nodes where we shouldn't handle it.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Whiteboard: b4 [fixed-tabcandy]
Target Milestone: --- → Firefox 4.0b4
The control-space is the *most popular* used to toggle between IME and non-IME mode. Using control-space combination that would impact people who use IME to input the Chinese words.
backed out http://hg.mozilla.org/mozilla-central/rev/c14d91f2d939
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #8)
> Aza/Dao: Would it make sense to look at changing this (in a followup) to
> Control-Tab? That was the key combo previously used by the, err, "Control Tab"
> feature (bug 465076). AFAIK there are no plans to bring that back

there are: bug 565568
http://hg.mozilla.org/mozilla-central/rev/7044260eb573
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
Agree with yuoo2k. Some users have complained of this hotkey in Chinese user community.We have to use keyconfig extension.
We should have a check for this in Litmus FFT
Status: RESOLVED → VERIFIED
Flags: in-litmus?
in-litmus-  this changed to ctrl+e  besides we're trying to eliminate keyboard shortcuts from BFT's
Flags: in-litmus? → in-litmus-
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.