Configurable Keyboard Shortcut for TabCandy

RESOLVED DUPLICATE of bug 592183

Status

Firefox Graveyard
Panorama
P1
normal
RESOLVED DUPLICATE of bug 592183
8 years ago
2 years ago

People

(Reporter: Martin, Assigned: aza)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b4pre) Gecko/20100815 Minefield/4.0b4pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b4pre) Gecko/20100815 Minefield/4.0b4pre

On my Mac, Alt-Space opens the TabCandy window.

I am used to Alt-Space as keyboard shortcut for non-breaking space . Since I do more and more writing in the browser, I accidentally open TabCandy all the time.

http://en.wikipedia.org/wiki/Non-breaking_space#Keyboard_entry_methods

Reproducible: Always

Steps to Reproduce:
1. Type a text including a non-breaking space.
2. Enter nonbreakable space by using Alt-Space
Actual Results:  
TabCandy window appears.

Expected Results:  
A non-breaking space should appear, not TabCandy window.

Comment 1

8 years ago
wow, that's impressive...

At a minimum, the keyboard shortcut should not trigger TabCandy when the focus is in an input field.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

8 years ago
I nominate one of the F keys. F4/F12 would work.

Comment 3

8 years ago
For anyone who uses an input-method editor (basically anyone who does not use a language with Roman charaters; which is probably 33% of the world- Arabic, Chinese, Japanese, Korean, Thai, Vietnamese, Hebrew, etc.) will normally invoke an IME with alt-space.

Invoking the IME is done in all applications in the OS, not just the browser, so Panorama/TabCandy needs to be able to have the keyboard shortcuts configurable beyond alt-space.

In fact the ideal situation would be for non-English or non-Roman-character browsers to have a different default keyboard shortcut than Alt-space because alt-space will be used to invoke the IME.  That or to change the default globally to some other key combination that will not affect a very significant portion of our users.
Blocking+ per comment #3. Marking blocking final as this change likely doesn't require extensive test coverage in beta.
blocking2.0: --- → final+
(In reply to comment #1)
> wow, that's impressive...
> 
> At a minimum, the keyboard shortcut should not trigger TabCandy when the focus
> is in an input field.

Yeah, that's not right. But it's a separate issue - can you file a new bug for that?
Version: unspecified → Trunk

Comment 6

8 years ago
(In reply to comment #5)
> (In reply to comment #1)
> > wow, that's impressive...
> > 
> > At a minimum, the keyboard shortcut should not trigger TabCandy when the focus
> > is in an input field.
> 
> Yeah, that's not right. But it's a separate issue - can you file a new bug for
> that?

bug 591190 filed.
(Assignee)

Comment 7

8 years ago
Blocking final is right, we will need to work through this with the UX group. As Gen mentioned, this will at the very least need to be configurable.
Assignee: nobody → aza
Duplicate of this bug: 591728
OS: Mac OS X → All
Priority: -- → P1
Hardware: x86 → All
Blocks: 598154

Comment 9

8 years ago
I suggest to change the default shortcut.

Alt+Space should not be used on any OS, because it's the third level of Space key on Macs, and it usually invokes the window menu in Win and Linux.

Ctrl+Alt+Space should not be used on Windows, because it equals AltGr+Space there.

Ctrl+Space seems to currently be used on Windows and Linux, and that's fine. What about Cmd+Space for Macs?

Comment 10

8 years ago
IMO, this should be marked as WONTFIX, because keyboard shortcuts are usually not customizable in Firefox. Instead, bug 592183 should be fixed properly.

Comment 11

8 years ago
(In reply to comment #10)
> IMO, this should be marked as WONTFIX, because keyboard shortcuts are usually
> not customizable in Firefox. Instead, bug 592183 should be fixed properly.

That's possibly an invalid argument since most, if not all, other shortcuts in Firefox do not interfere with or override what could be considered global shortcuts, as it should be.

Comment 12

8 years ago
That's why I said the bug 592183 should be fixed properly. :)
All points raised in this bug really are about bug 592183 as far as I can see.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 592183

Comment 14

8 years ago
Duplicate bug, removing blocking.
blocking2.0: final+ → ---
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.