If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

panorama keyboard shortcut should not trigger when in textfields

RESOLVED INVALID

Status

Firefox Graveyard
Panorama
P2
normal
RESOLVED INVALID
7 years ago
2 years ago

People

(Reporter: philippe (part-time), Assigned: aza)

Tracking

Dependency tree / graph

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
The Tab Candy keyboard shortcut (option-space) should NOT open Tab Candy when the focus is in an input field

STR
1. start typing in an input field / textarea
2. press option space (standard OS X key combo for a non-breaking space)
3. %%6$## </swear>

AR. tab candy opens…
ER. Input a non-breaking space

(filed per bug 587505 comment 5)
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
OS: Mac OS X → All
Hardware: x86 → All
Summary: Tab Candy highjacks non-breaking space key combo → panorama keyboard shortcut should not trigger when in textfields
Created attachment 470310 [details] [diff] [review]
v1
Assignee: nobody → dietrich
Attachment #470310 - Flags: review?(dolske)

Comment 2

7 years ago
And also see Bug 591190,
Panorama should ignore keypress of ENTER(DOM_VK_RETURN) while IME composition .

Comment 3

7 years ago
Oops , Sorry, in comment #2
s/Bug 591190/Bug 587243/
blocking2.0: ? → betaN+
Comment on attachment 470310 [details] [diff] [review]
v1

getting first-review from ian.
Attachment #470310 - Flags: review?(dolske) → review?(ian)
Comment on attachment 470310 [details] [diff] [review]
v1

Looks good.  Adding Aza for UI.
Attachment #470310 - Flags: ui-review?(aza)
Attachment #470310 - Flags: review?(ian)
Attachment #470310 - Flags: review+
(Assignee)

Comment 6

7 years ago
I'm worried that this sets up a modality... you are used to using option-space to invoke Panorama and then all of a sudden it stops working. I doubt it will be obvious that it is because you are in a textarea that Panorama appears broken.

To put it another way, it is very frustrating that Flash eats key presses. How many times have you become annoyed that you can't use the standard keyboard shortcut for "Back" because Flash gobbles it up? Would you be able to use the keyboard shortcut while writing in Gmail or any other email client? During the middle of leaving a comment on Bugzilla?
Dueling frustrations.

The root of the problem is that the current keyboard shortcut is an extremely common one (as evidenced by the volume of bugs filed about it). We could ditch this patch in favor of fixing fixing bug 587505 and/or changing the default shortcut.
(In reply to comment #7)
> The root of the problem is that the current keyboard shortcut is an extremely
> common one (as evidenced by the volume of bugs filed about it). We could ditch
> this patch in favor of fixing fixing bug 587505 and/or changing the default
> shortcut.

Agreed. Fixing bug 587505 is one thing, but having a smarter default is also important. As discussed in bug 592183, perhaps something command-y like command/alt-[...] would be better and less likely to conflict with OS/IMEs.
(Reporter)

Updated

7 years ago
Duplicate of this bug: 593428
Assignee: dietrich → nobody
Priority: -- → P2
See also bug 593139 which is for this bug, but for xul:richlistbox
Assignee: nobody → aza

Comment 11

7 years ago
Sorry for creating a duplicate earlier [bug 593139].

This is a nasty bug!

TabCandy should not eat option-space, since this is the only way to enter a non-breaking space.

Either tell us how to disable tab-candy, or how to change the shortcut.
Blocks: 597043
Depends on: 592183
This won't be valid when bug 592183 is fixed.
(In reply to comment #12)
> This won't be valid when bug 592183 is fixed.

That bug summary sounds like it's just a shortcut change. Does that patch also fix this problem?
(In reply to comment #13)
> That bug summary sounds like it's just a shortcut change. Does that patch also
> fix this problem?

The reason we have this bug is that user wants to input a non-breaking space into textfields but  alt+space is used to toggle the panorama UI.  Now, we are changing it to  ccmd/clt + e which wouldn't affect any input characters so this won't be valid when the patch for bug 59183 lands IMO.
I think this is now INVALID given the fix for bug 592183 (shortcut is now Cmd+E, which doesn't conflict with any common input field shortcuts).
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Comment 16

7 years ago
Bug invalid, removing blocking
blocking2.0: betaN+ → ---
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.