Redhat 7 users must install compat-libstdc++6.2-2.9.0.9

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
19 years ago
16 years ago

People

(Reporter: bugzilla, Assigned: verah)

Tracking

Details

(Whiteboard: relnote-user)

(Reporter)

Description

19 years ago
In order to be able to run either the netscape installer of netscape 6 on RedHat version 7, you must install the 
Standard C++ libraries for Red Hat 6.2 backwards compatibility. You can find the package on the RedHat 7 
installation CD or at the following address: http://www.redhat.com/swr/i386/compat-libstdc++-6.2-
2.9.0.9.i386.html
(Reporter)

Updated

19 years ago
Keywords: relnoteRTM
(Reporter)

Updated

19 years ago
Summary: Redhat 7 user must install compat-libstdc++6.2-2.9.0.9 → Redhat 7 users must install compat-libstdc++6.2-2.9.0.9
Whiteboard: relnote-user
(Assignee)

Comment 1

18 years ago
This information is in the RTM release notes for Netscape 6. Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Reopening. Netscape 6 is not the only release from mozilla.org! It needs 
relnoting in other release notes too.

Gerv
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I have redhat 7.2, installed compat-libstdc++-6.2-2.9.0.16, but get this when I
try to install netscape 6.2:

"fatal error [-618]: couldn't open xpistub library" comes in a popup. the
installer says "Extracting libplc4.so...". This is not the web installed, but
the one with all xpi files in it.

Comment 4

17 years ago
This also applies for Debian testing (woody) using the installer. Though in
woody, it is libstdc++2.9-glibc2.1 from "oldlibs" that must be installed.
My redhat 7.2 problem was solved by someone on irc, I had to remove the libsafe
rpm , which not only fixed the mozilla/netscape installer, but also fixed a
building error (see bug 83200 for info on the libsafe issue)
*** Bug 107368 has been marked as a duplicate of this bug. ***
*** Bug 112478 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
I would strongly suggest the deprecation of libstdc++ 2.9.0/2.10.0 due to the
fact that the GNU Libstdc++ people have abandoned libstdc++-v2 and all support
around it.

It would be wise to build mozilla around libstd++ 4.0.0 (libstd++-v3) instead. 

As per the faq on the GNU Libstdc++ site states.

Comment 9

17 years ago
*** Bug 162379 has been marked as a duplicate of this bug. ***
*** Bug 165926 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
does this mean setting 
export LD_ASSUME_KERNEL=2.2.5
?

Comment 12

16 years ago
*** Bug 144856 has been marked as a duplicate of this bug. ***
The URL given here (and in the 1.2b release notes) is a dud.  The library's 
available from rpmfind.net at the following URL:  
ftp://ftp.rpmfind.net/linux/redhat/7.3/en/os/i386/RedHat/RPMS/compat-libstdc++-6.2-2.9.0.16.i386.rpm
I'm sure there's another RedHat URL that would work, as well.
Blocks: 181045

Comment 14

16 years ago
*** Bug 181991 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
*** Bug 191462 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
*** Bug 194456 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
info already in relnotes -> wfm
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.