If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When forwarding emails from the Sent folder the program sends it from a different account POP/Global inbox.

RESOLVED DUPLICATE of bug 327713

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 327713
7 years ago
2 months ago

People

(Reporter: Gerardo, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Thunderbird/3.1.2

I have 2 accounts: A and B, default being "A". When forwarding emails from the Sent folder belonging to account A they are sent as being sent by account B. 

Reproducible: Always

Steps to Reproduce:
1.open sent folder
2.select an email
3.click forward

Actual Results:  
it shows From: an account different that the one that received the email:
From B 

Expected Results:  
it should have been From A
This WFM wit Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b6pre) Gecko/20100902 Thunderbird/3.2a1pre.

Can you try in -safe-mode (http://support.mozillamessaging.com/en-US/kb/Safe+Mode) ?

Anything in Tools -> Erro console when this happens ?
(Reporter)

Comment 2

7 years ago
no errors reported in Error Console Safe Mode
And so you have the issue in safe-mode too ?
(Reporter)

Comment 4

7 years ago
Yes the same issue happens in Safe Mode...
Can you describe the types of accounts involved (ie, pop, imap etc ...)
(Reporter)

Comment 6

7 years ago
i have only two pop accounts, no other. both are gmail
(Reporter)

Comment 7

7 years ago
i have only two pop accounts, none other. both are gmail
Aureliano can you try to reproduce ?
(In reply to comment #8)
> Aureliano can you try to reproduce ?
WFM too

Mozilla/5.0 (Windows NT 6.1; rv:2.0b6pre) Gecko/20100907 Thunderbird/3.2a1pre ID:20100907032401

Gerardo do you use "All Folders" view or "Unified Folders" view?
Do you have these two accounts on "Global Inbox" or are them distinct?
(Reporter)

Comment 10

7 years ago
Aureliano, I use All Folders view. Re the other question I guess the 2 accounts are in Global Inbox as they both are in the same Inbox folder. They are however two distinct pop accounts with different email addresses.
Str :

1) New profile
2) create first gmail pop account
3) create second gmail pop account
4) modify account to use global inboxes
5) Forward an email with the second account

Emeail is sent from first account.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: When forwarding emails from the Sent folder thr program sends it from a different account → When forwarding emails from the Sent folder the program sends it from a different account POP/Global inbox.
Component: General → Mail Window Front End
QA Contact: general → front-end
(In reply to comment #11)
> Str :
> 
> 1) New profile
> 2) create first gmail pop account
> 3) create second gmail pop account
> 4) modify account to use global inboxes
> 5) Forward an email with the second account
> 
> Emeail is sent from first account.

Does account column for this message is empty on Global Inbox?
Accoutn columns says 'Local Folders'

Comment 14

7 years ago
This is a similar issue.

I have 3 accounts, A, B, and C. A shows on top in the All Folders list. C is the default. 

If I do a Reply All (or just Reply) to a message in the Sent folder of C it picks the From address of a different account (A). 

Doing a Reply on a message in *Inbox* works well: it picks up the sender address of the account being used, in this case C.

This is not great. Yesterday I did not pay attention to the From address and sent an email from the wrong address, which was a private one.

This was on Linux, v. 3.1.3.
(Reporter)

Comment 15

7 years ago
yes, indeed it is the same problem.
pls tell me what it means to modify account to use global indexes.

anyhow, since this a bug that is laso reported by another user, shouldn't Thundebird fix it as part of the updates?
(In reply to comment #15)
 
> anyhow, since this a bug that is laso reported by another user, shouldn't
> Thundebird fix it as part of the updates?

We need to understand why and figure a fix out. That might eventually happen.

Comment 17

7 years ago
I have exactly the same problem.

I actually have 4 accounts, A, B, C and D in chronological order in which the accounts were added. All are POP accounts. B and C are legacy, non-active accounts which I just keep for reference purposes - so in settings I have deleted the from address so that TB won't even attempt to contact a server. Account D is the account I mainly use. However, when forwarding from the global Sent box it almost always defaults to account B for the From and consequently I get an error as no email address is specified. However, it sometimes sets the From as account A which is a problem as this is an active account but the wrong one - sometimes I miss this which is a problem.

Running Win XP Pro 32 bit, happens in safe mode, currently on TB3.1.4 but has been happening with all versions of TB at least since 3.0 (and possibly before but I can not recall for sure). I had not filed a bug as I could find no discernible pattern for when TB chooses the correct From (rare), account B (by far most common) or accounts A or C (rare).
There are four kinds of "Preset From: is different from user's thought".
(1) bug 327713 : Preset From: of reply always bases on X-Account-Key:
                 instead of owner of folder in which mail is held.
(2) If From:/To:/CC: contains mail addresses defined as identitity,
    Reply-Self works upon reply.
(3) Because "Local Folders" doesn't have associated identity, main identity of
    default account is used upon new mail creation.
    So, if "Local Folders" is currently selected upon new mail creation,
    it occurs.
(4) If a folder is "folder to save sent mail copy", automatic column swapping
    of "From(Sender)" and "Recipient" was done till Tb  2.
    IIRC, this caused internal swapping of From: and To:.
    It's similar to "Unified Who" column, different implementation though.
    If this kind of internal swaping is still active, preset From:
    may become different from user's thought.
For (4), check next please.
(1) Copy mail in Sent folder to ordinal folder of same account.
(2) Do same operation(Forward, Reply etc.)
Is preset From: same as Sent?

To all problem reporters in this bug:
Which case are you talking about?
FYI.
Bug 327713 seems applicable to "Forward" too, instead of Reply only phenomenon.

Comment 20

7 years ago
Hi Wada,

To be honest it is a bit difficult to understand what you are talking about because it is very technical, probably one would need to know the source code to grasp it. 

And you are talking about the possible causes of the problem while the bug reporters are talking about the effects of the problems. It is difficult for a normal user to know the causes, but the effects are obvious (and repeatable).

My problem could possibly be #4 in your list. What I can say is that in its effects it seems to be the same as user Duncan, and possibly the same as other users too (and that is why I put a comment in this bug instead of starting a new bug report).

I did the test you suggested for #4:
1. Copied sent email to Inbox
2. Did Forward, Reply, etc.

I got the same problem as when the email was in the sent folder, meaning that it picked the wrong From address.
(In reply to comment #20)

> To be honest it is a bit difficult to understand what you are talking about
> because it is very technical, probably one would need to know the source code
> to grasp it. 

To be honest, if a people really reads thru bug I pointed(and understand, not merely see or look texts in the bug), I can't imagine reason why a people can not check at least X-Account-Key: header of mail source by himself, even if he is never techinically matured people.
And, to be honest, if a people really read bug I pointed and checked mail source, I can't imagine reason why he can not state about at least "his problem is same as, or different from, bug I pointed".

Have you really read Bug 327713 I pointed?
Please note that here is not support forum nor Help Center nor Customer Service Center. Here is for reporting Tb's bug(flaw in code of Tb is really exist) and for requesting(or forcing by pressure from we users) developers to fix Tb's bug.

Comment 22

7 years ago
Sorry, I was a bit unkind.

I looked at the bug you mentioned. There is a workaround suggested there, which is the add-on "Correct Identity". I installed it and so far it seems to work.

Thanks for your help.
(Reporter)

Comment 23

7 years ago
Piscium, I installed the add-on Correct Identity and it works fine. I had to configure it so that the forward always sends with from the account A, so it might give me problems when forwarding from account B, but I don't use that so much.
Thanks!

Comment 24

7 years ago
Hi Gerardo,

I too had to change the default configuration in order for it to work well.

Basically I set each individual account to use its correct address, and _unticked_ the box that says "attempt to find and use an identity that appears in its recipient list".

Good that it worked for you too!
For Gerardo's case and Piscium's case.
As you use Global Inbox with Global Inbox Owner=Local Folders, and it sounds Sent folder only issue(sent mail by Tb only issue), phenomenon is probably next.

(i) Tb doesn't write X-Account-Key: header for sent mail,
    even when sent mail copy is saved in local Sent folder
    which is owned by Global Inbox owner,
    even though Tb currently bases on X-Account-Key: in pre-set From: setting
    for Reply(and Forward too) in order to support Global Inbox easily.
    Known issue. I couldn't reach bug for it again. Still remains in Tb trunk.
(ii) If no X-Account-Key: header or accountN in X-Account-Key: is not defined,
    account name of folder owner is shown at Account column.
    It's reason why "Local Folders" is shown at Account column in comment #13.
(iii) When value of Account column is "Local Folders",
    there is no associated identity because of "Local Folders".
    If mail folder under ordinal account, identitity is defined, so associated
    identities can be used. But it's impossible when "Local Folders".
Phenomenon relevant to Bug 327713 becomes complicated than usual in this case.
Tb looked for me to scan mail.identity.idN.useremail for mail address in From: header. In my test with real mail data, used mail.identity.idN.xxx was first identity which has "mail.identity.idN.useremail==mail address in From: header". When mail data is crafted and From: is changed to non-existent mail address, main identity of default account was used. 

If scan of mail.identity.idN.useremail for mail address in mail headers is executed always, problem like Bug 327713(X-Account-Key:), Bug 264626(X-Identity-Key:), Bug 279846(X-Identity-Key:) disappers...
Above was for ordinal received mail(From: is not identity, To: is identity) and special mail for test(From: is an identity, To: is same identity), with no X-Account-Key: header(emulation of imported mail, mail copied from IMAP folder to Local Folders).
If identities are set in both From: and To:, "Reply-Self" works. It was trick that "first identity of mail address in mail header" was set in my test.
Sorry for my confusion.

If ordinal sent mail, From: is an identity, To: is not identity, no X-Account-Key, and Local Folders in your case.
In this case, main identity of default account is used. It's ordinal phenomenon of Bug 327713(special case of "no X-Account-Key: and Local Folders" though).
Oh, "Global Inbox" seems Gerardo(bug opener)'s case and Comment #11 case by LUDO only.
To  Piscium and Duncan:
Do you use Global Inbox? If no, you are probably looking very ordinal phenomenon of Bug 327713 and funny-for-user phenomenon by "Reply-to-myself" feature for mail with identity in both From: and To:/CC:.

(In reply to comment #24)
> and _unticked_ the box that says "attempt to find and use an identity that appears in its recipient list".

It's probably killing of "Reply-to-myself" feature.

Comment 28

7 years ago
I am not sure about what "Global Inbox" means - I have little experience with Thunderbird - but as I have 3 accounts, each with its folder tree (Inbox, Sent, Trash, etc), it seems likely my inbox is not global.

It may be the case that this bug is a duplicate of bug 327713, and if so this bug can be closed.

But it is more interesting to talk about bug 327713. It has been open for 4.5 years. The technical side of it seems to have been well covered, yet the bug still has no one assigned to it.

One might wonder why that is so. It is possible that it is considered low priority. Or maybe it is unglamorous. Maybe if Lady Gaga would mention that bug in one of her videos, and had the bug number printed on her T-shirt, the next day there would be 5 developers queuing up to work on it! Maybe the way to have the bug fixed is to send an email to Lady Gaga suggesting just that! :-)

And there is the "Correct Identity" add-on. It has been created specifically to address the bug. There have been over 70,000 downloads. Likely each person downloaded it more than once as a new version of Tb gets released. Let's say each person downloaded it 10 times. This means that bug 327713 affected 7000 people. But the fact that there is a workaround means the developers have less incentive to fix it.

Just to conclude, these were just some of my reflections (I am a bit of a philosopher). Many thanks to the developers of Tb and the "Correct Identity" add-on for making them available to the public. And life is beautiful.
(In reply to comment #28)
> I am not sure about what "Global Inbox" means (snip)
> as I have 3 accounts, each with its folder tree (Inbox, Sent,
> Trash, etc), it seems likely my inbox is not global.

You are right. "use Global Inbox or not" is set via Server Settings/Advanced of POP3 account. If "use Global Inbox" is enabled, accout is hidden at folder pane.

As I wrote in comment #25, account name, which Tb will use to determine pre-set From: for Reply/Forward, is shown at Account column(With Tb 3.1, it's shown even for IMAP folder).
  X-Account-Key: exists. accountN in it exists:
    account name of accountN
  No X-Account-Key:, or X-Account-Key: exists but accountN in it doesn't exist:
    account name of account who owns folder in which mail is held
  Roughly, (A) if shown account name is not "Local Folders", main identity of
  the account(may be sub-identity in some cases) is used,
  and (B) if "Local Folders", main identity of default account is used.
If pre-set From: is different from your thought, check Account column value in your trouble shooting. And check mail addresses in From:/To:/CC:/Reply-To: and so on, and check whether your mail addresses are placed in such headers or not, in order to rule out phenomenon due to "Reply Self" feature, please.

By the way, I' not a developer. I'm a helper of QA team people, and a nightly fleak some times :-) freak
(In reply to comment #28)
> It may be the case that this bug is a duplicate of bug 327713, and if so this
> bug can be closed.

Piscium, I also think same problem as that bug. But I'm not sure Reply case and Forward case is absolutely same problem.
Setting dependency to bug 327713 and keep this bug open.

To developers: Close this bug as dup of that bug if same issue, please.
Depends on: 327713
Duplicate of this bug: 580640
Duplicate of this bug: 604652

Comment 33

7 years ago
This bug is also in Seamonkey and has been there for four years. Also there is no "use Global Inbox or not" option.

Updated

7 years ago
Duplicate of this bug: 640032
Blocks: 699681

Comment 35

5 years ago
This is REALLY serious :) I have been using TB (18) for a month or so, having been forced to drop Outlook Express. I've just discovered that when I forward messages to clients, the email/account that gets used is one for an adult site that I also maintain, and generally don't wish my other clients to know about ! Thanks guys :(

I'm sure that many other TB users have private / family / professional email addresses that they do not wish everyone to have access to ! The whole point of separate emails/account is to keep things separate !

Comment 36

5 years ago
@N Brooks: I highly recommend the "Identity Chooser" add-on which helps avoid such mistakes by making you choose which identity to use every time, as well as highlighting the email header in a certain colour (chosen by you) for each email account.  

Piscium also mentioned the "Correct Identity" add-on" above; I don't recall whether I've tried that one.

But yes, it would be really nice if this bug were fixed.

Comment 37

4 years ago
All, this happened to me as well.  Emails were going out from the wrong sender and it is SO UNPROFESSIONAL when your business emails go out with your personal address.  Worse, you don't even know until you start to get business responses in your personal email.

Anyway, for me the fix was neither the "identity chooser" or the "correct identity".  It was Tools | Account Settings | (Choose Account) | Outgoing Server (SMTP) ... change this from default or global or whatever it says now to the particular settings for that account.  

Hope this helps someone...IT WAS DRIVING ME CRAZY!

Comment 38

4 years ago
This is a duplicate of 327713
Duplicate of this bug: 724792
This issue is not a "support" issue, but a severe bug! And this bug exists since more then 3 years ....
 

Here you can see the incomming mail page: 

http://mail2vip.com/vippages/thunderbird%20transferts%20with%20false%20sender%20address/1%20received%20mail.jpg

you see the receiver address on two places and then I click to the transfer button. 

Then I get this page: 

http://mail2vip.com/vippages/thunderbird%20transferts%20with%20false%20sender%20address/2%20mail%20transfer%20screenl.jpg

you can see that the sender address has changed. This is not a systematic issue .. some times thunderbird uses the right sender address, some times not. 

The sender address must be every time the receivers address ... in this case the rd01@....

Do you want also screen shots for the other issues? 

When does you solve this bug instead of a lot of stupid formalityies???? 

brainstuff
FYI.

For "Sent" folder of "Local Folders" case.
1.  When sent mail copy, X-Account-Key: header is not written to the sent mail copy.
     So, in X-Account-Key: based identity selection, Tb tries to fall back to ;
     - Identity of Default Account (primary identity of mail.accountmanager.defaultaccount)
2.  If the "primary identity of mail.accountmanager.defaultaccount" is not available,
    (e.g.  mail.accountmanager.defaultaccount == "Local Folders", RSS feed account, Hidden account by Global Inbox use, etc.)
     Tb tries to fall back to  "first account in mail.accountmanager.accounts".
So, if "first account in mail.accountmanager.accounts" !== mail.accountmanager.defaultaccount, "funny identity selection for user" may happen.

How to keep "first account in mail.accountmanager.accounts" === mail.accountmanager.defaultaccount.
i.   Change default account to appropriate one via Account Manager UI.
ii.  Via Config Editor of Tb(option settings in Tb, Agvanced/General/Config Editor),       .
     change "first account in mail.accountmanager.accounts" to account which is set in mail.accountmanager.defaultaccount.
     (You can freely change order in mail.accountmanager.accounts)
iii. Restart Tb.

Comment 42

3 years ago
Just use the highlighted account for new composed emails, or the folder an email is residing in for replies or forwards, and there wouldn't be a problem. Get rid of the X-Account-Key rubbish !!!
@david and Wanda ... no need to complicate the problem: the receivers email must be the sender email and the reply email. Also in the case when the original email comes trough a "forwarder" 
 
Exemple: a incomming mail comes to aa@bbb.com then I reply to the sender, and the sender will have aa@bbb.com as REPLY address (not the account mail where I receive a forwarded mail or an other mail address). 

Exemple 2: a incomming mail comes to aa@bbb.com then I transfer the mail to a third person: then the receiver will have aa@bbb.com as REPLY address (not the account mail where I receive a forwarded mail or any other mail address). 


You can see on my screencopys that Thunderbird does associate wrong email adresses to some transferred mails.  

thanks 
brainstuff

Comment 44

3 years ago
Surely the idea of multiple accounts is that an account is setup for each 
email identity that the user has, ie Home, work, charity etc. 
Then it make sense to keep the mail relating to that identity in folders 
in the relevant account, ie any work related emails would be kept in the 
work\inbox, or work\sent etc. 
Emails could get there by either downloading from different pop servers, 
or by dragging from another account if all incoming mails are consolidated to one server.

Composing a new message when a certain account is highlighted works correctly, 
ie the correct formatting is selected (text/html) and the correct from address 
is selected. 

When it comes to replying or forwarding a message that is highlighted, 
it should work the same way, BUT IT DOESNT !!

Please correct me if I am wrong, but I believe the solution is blatantly obvious and very simple:
1 Ignore the X-Account-Key, or add an option to ignore the X-Account-Key
2 When replying to a message, or forwarding a message, use the same subroutine that creates a new message. 
   That correctly Opens a new edit window
   Uses the correct formatting 
   Uses the correct signature, CC and Bcc addresses
   Uses the correct From address 

To cater for different setups/users then it would be sensible to have some options 
that the user could select in their preferences.
(In reply to David from comment #44)

What is essential differences of your claim from already opened(and pointed by Depends on: field of this bug) Bug 327713?
@wanda  reply to your reply on (In reply to David from comment #44)

This bug exists since years...The system must be simple: I receive an email on the account xxxx@xxxx.com and when I forward this mail (or when I reply ) then thunderbird must use the xxx@xxx.com mail address as sender address and as reply address .

It is non sense to use an other email address. 

What is the reason that you do not want to correct this problem? If you find the issue in a lot of complaints ... please take note that there are a lot of users who are not happy wit this and if you have the time, when you have solved the issue, do store all complaints in one report.

This kind of "bug-report" program is not a very good platform to handle such stupid errors: it is needed that a developper works together with an user who is concerned by the problem. I am probably one of the users with the most mail accounts and the best is to contact me to test all corrections.  

It is also not possible to handle some problems as an isolated-problem.

Comment 47

2 years ago
I've got exactly the same problem and although TB-version is rised to 38.3.0 the error is still there...:

Sended Mails are stored in the 'sent'-folder.

If I want to use a sent email as a template to send it to another recipient by forwarding the opened (sent) mail, TB is of course not able to use the 'to'-adress as 'from' within the new mail, because the sent-mail's 'to'-adress is not mine.

So TB should assign the standard-account as 'from', but it uses always the same, but wrong adress that is not the standard one. If I correct the from-adress manually, signature that should be added is missing and not inserted.

Forwarding of incoming mails is working correct and assigning the right accounts. But Forwarding of sent mails is buggy.

The mentioned addon to correct identity doesn't help!

5 years of software-development - and still the same error... Why?!

Updated

2 months ago
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 327713
You need to log in before you can comment on or make changes to this bug.