If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

D2D/DirectWrite are no longer ON by default for every Intel graphic card

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Build : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100906 Firefox/4.0b6pre

Since this build, D2D/DirectWrite are no longer ON by default, even if "Use hw acceleration when enable" is ticked.
I tried the workaround :
* gfx.font_rendering.directwrite.enabled set to true
* mozilla.widget.render-mode set to 6
but only DirectWrite is enabled.

Adapter Description: Mobile Intel(R) 4 Series Express Chipset Family
Vendor ID: 8086
Device ID: 2a42
Adapter RAM: Unknown
Adapter Drivers : igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version : 8.15.10.2189
Driver Date: 7-28-2010
This is probably caused by blacklisting of intel hardware...
Lookinh at the driver date I thought that's recent enough to not be broken, but I might be wrong.
The driver versions that are blacklisted are less than 15.7.9.2182.  So that driver certainly qualifies for blacklisting, though perhaps we just don't understand Intel's driver versioning (e.g. are the first two numbers relevant?).
(Reporter)

Comment 4

7 years ago
The Intel Graphic Media Accelerator 15.7.9.2182 (Vista & 7) is a suite that contains :
+ the graphic driver : 8.15.10.2182
+ the audio HDMI driver : 6.10.1.2182
The blacklisting must be done according to the graphic driver version.

For Windows XP, the last graphic driver version is 6.14.10.5284

Comment 5

7 years ago
Mine was broken as well.

From the about:support page:

Adapter Description: Mobile Intel(R) 965 Express Chipset 
FamilyVendor ID: 8086
Device ID: 2a02
Adapter Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version: 8.15.10.1930
Driver Date: 9-23-2009

It's the latest available for Windows 7 on 64-bit.
(Reporter)

Updated

7 years ago
Duplicate of this bug: 594353

Comment 7

7 years ago
Ok i just bypassed the blacklisting for X3100, 
i downloaded the lasted 8.15.10.1930 drivers for windows 7

firstly

i edited igdlh.inf and changed the line DriverVer=09/23/2009,8.15.10.1930 to DriverVer=01/09/2010,15.7.9.2182

then i installed the driver through device manager and i ignored the windows security alert for signed drivers

although windows and firefox reported the driver info i inserted firefox continued to refuse to activated direct2d

then i changed the [Intel.Mfg]


i deleted everything except from the line that matches my hardware, in my case %iCRGD0% = i965GM0, PCI\VEN_8086&DEV_2A02 and changed 2A02 to 2A42

guess what, firefox enabled Direct2D since it cant find its blacklisted item

http://www.imagebam.com/image/75753e96915693

i suppose that blacklisting is through device id and not driver version

after the above, D2D score came back to normal
fishie is well above 55-60fps and psychedelic counts 1400+

Comment 8

7 years ago
Yes, it seems that the Intel Drivers are being blacklisted based on the incorrect version number? Any plans to check the pertinent values instead (ie - 8.15.10.2182
, not 15.7.9.2182)? Perhaps only check that last block of number, not the whole string?

Comment 9

7 years ago
no, with the procedure above it seams that is the hardware-id that is blacklisted not thw drivers date.

otherwise when i changed drivers date minefiled should activate d2d but it didn't

Comment 10

7 years ago
Dunno how you got that to work. My graphics chip already was hardware-id 2A42 (it's a 4500HD), so I can't change that in the igdlh64.inf file. Doesn't appear to be based on driver version either as mentioned in Comment #3, since I DID do step one and changed my driver version line to read:

DriverVer=07/19/2010,15.7.9.2182

Despite all this, it's still not allowing Direct2D or DirectWrite:

Adapter Description: Mobile Intel(R) 4 Series Express Chipset Family
Vendor ID: 8086
Device ID: 2a42
Adapter RAM: Unknown
Adapter Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version: 15.7.9.2182
Driver Date: 7-19-2010
Direct2D Enabled: false
DirectWrite Enabled: false
GPU Accelerated Windows: 1/1 Direct3D 9

Any ideas?

Comment 11

7 years ago
first make sure that gfx.font_rendering.directwrite.enabled is set to true and mozilla.widget.render-mode is set to 6

next change 2A42 to something else say 2A41 and try again
(Reporter)

Comment 12

7 years ago
This behavior is a consequence of bug 591486 and bug 593529 fixes.

In widget/src/windows/GfxInfo.cpp, the following line : 
    DRIVER_LESS_THAN, V(15,17,9,2182) },
should be replaced by :
    DRIVER_LESS_THAN, V(8,15,10,2182) },
in order to have D2D ON for recent Intel card (HD, 4 series) on Windows Vista & 7.
For Windows XP compatibility, more changes are needed (see comment 4).
For older Intel card compatibility (910, 915, 945, 965, ...) , also (see comment 5)
Moreover, Intel device ID list seems to be incomplete.
Summary: D2D/DirectWrite are no longer ON by default for mobile intel 4 series express chipset family → D2D/DirectWrite are no longer ON by default for every Intel graphic card

Comment 13

7 years ago
why not replace with DRIVER_LESS_THAN, V(8,15,10,1930);

1930 is the latest windows 7 x32/7x64 driver for Intel Media Accelerator (GMA965, 945 etc).

Comment 14

7 years ago
(In reply to comment #13)
> why not replace with DRIVER_LESS_THAN, V(8,15,10,1930);
> 
> 1930 is the latest windows 7 x32/7x64 driver for Intel Media Accelerator
> (GMA965, 945 etc).

the latest driver for intel is  8.15.10.2182

Comment 15

7 years ago
(In reply to comment #14)
> (In reply to comment #13)
> > why not replace with DRIVER_LESS_THAN, V(8,15,10,1930);
> > 
> > 1930 is the latest windows 7 x32/7x64 driver for Intel Media Accelerator
> > (GMA965, 945 etc).
> 
> the latest driver for intel is  8.15.10.2182

Can you please link to the webpage where you found this new driver? For my card (G965), the latest available driver is, as given on Intel's website, 8.15.10.1930 .

Comment 16

7 years ago
You are correct, 10.1930 is the latest for 965. 10.2182 is the latest for the Mobile Intel 4 Series Express Chipset though (GM4500HD). The problem is that Intel does NOT have a single driver version for all their chipsets like ATI and NVIDIA do. Unless some devs want to actually figure out a matrix that maps the actual card versions to the latest exact driver versions, I'd prefer if they just provided a pref of some type to force on DirectWrite and Direct2D no matter what (an "ignore blacklist" as it were). If the user is confident that the driver works, and wants to take the risk, then let us turn it on.
Note that laptop users are often dependent on their vendor keeping the drivers up-to-date, as the latest official drivers will refuse to install saying the device was not certified for those drivers (bypassing the installer is probably possible, but not something the average user should be expected to be able to do). Of course, that doesn't change the fact that older drivers will be broken, so maybe the point is moot.
(In reply to comment #16)
> I'd prefer if they
> just provided a pref of some type to force on DirectWrite and Direct2D no
> matter what (an "ignore blacklist" as it were). If the user is confident that
> the driver works, and wants to take the risk, then let us turn it on.

One problem is that a lot of users will Google around, find some Web page that tells them to turn stuff on, then they turn it on and Firefox is broken, hence Firefox sucks. We can't make this too easy.

Comment 19

7 years ago
(In reply to comment #18)
> 
> One problem is that a lot of users will Google around, find some Web page that
> tells them to turn stuff on, then they turn it on and Firefox is broken, hence
> Firefox sucks. We can't make this too easy.

Perhaps provide a compile flag()or whatever its equivalent in windows). It is much safer for me to compile Firefox with ignored blacklist than to change fake my device id and driver version that might potentially break other applications.
(In reply to comment #18)
> (In reply to comment #16)
> > I'd prefer if they
> > just provided a pref of some type to force on DirectWrite and Direct2D no
> > matter what (an "ignore blacklist" as it were). If the user is confident that
> > the driver works, and wants to take the risk, then let us turn it on.
> 
> One problem is that a lot of users will Google around, find some Web page that
> tells them to turn stuff on, then they turn it on and Firefox is broken, hence
> Firefox sucks. We can't make this too easy.

Yeah, I'd make it an environment variable with a really annoying value; something like MOZ_GFX_DISABLE_BLOCKLIST=I_KNOW_THIS_WILL_BREAK_ME.

Comment 21

7 years ago
That seems a bit extreme a "solution" to me. I have no intention of setting up a personal Windows build environment just to re-enable acceleration that was working fine up until a week ago. And I would feel even less comfortable using a community build in place of an officially provided Mozilla executable. I was using nightlies with DirectWrite and Direct2D enabled MORE often on my GMA4500HD laptop than on my desktop with a Radeon 5750 card. There were actually fewer graphical anomolies on the Intel card than on my desktop system with the ATI chip. Since most users with Intel chips will never come onto bugzilla and create or comment on tickets in regards to these being disabled for them, could the devs at least make a concession to take the chips off the blacklist that commenters on here verify as working?

Comment 22

7 years ago
(In reply to comment #21)
> That seems a bit extreme a "solution" to me. I have no intention of setting up
> a personal Windows build environment just to re-enable acceleration that was
> working fine up until a week ago. And I would feel even less comfortable using
> a community build in place of an officially provided Mozilla executable. I was
> using nightlies with DirectWrite and Direct2D enabled MORE often on my
> GMA4500HD laptop than on my desktop with a Radeon 5750 card. There were
> actually fewer graphical anomolies on the Intel card than on my desktop system
> with the ATI chip. Since most users with Intel chips will never come onto
> bugzilla and create or comment on tickets in regards to these being disabled
> for them, could the devs at least make a concession to take the chips off the
> blacklist that commenters on here verify as working?

when i edited drivers details i did so just to get sure that my GMA965 was blacklisted.
i know that my GMA965 has no trouble running with acceleration but i also know that GMAXXX where XXX<965 (945,915 etc) that use the same driver as 965 are having problem with acceleration because they don't support DirectX 10.

My acceleration worked fine until mozilla blacklisted it and works fine with my custom drivers.

why not blacklisting using the Adapter Description instead of Driver Version ?
Much more safe and of course why not add an option to enable D2D anyway with a caution notice ?
(Reporter)

Updated

7 years ago
Depends on: 594877
(Reporter)

Comment 23

7 years ago
It is fixed by bug 594877 fix.
For that, you need to have the latest graphic driver version for your Intel GMA.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 24

7 years ago
My Direct2D is still not working. Should I file a new bug?

From about:support page



  Application Basics

        Name
        Firefox

        Version
        4.0b7pre

        User Agent
        Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100916 Firefox/4.0b7pre

 
  Modified Preferences

      Name

      Value

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage_override.buildID
        20100916030904

        browser.startup.homepage_override.mstone
        rv:2.0b7pre

        extensions.lastAppVersion
        4.0b7pre

        network.cookie.prefsMigrated
        true

        places.history.expiration.transient_current_max_pages
        64104

        privacy.sanitize.migrateFx3Prefs
        true

  Graphics

        Adapter Description
        Intel(R)  G965 Express Chipset Family

        Vendor ID
        8086

        Device ID
        29a2

        Adapter RAM
        Unknown

        Adapter Drivers
        igdumdx32

        Driver Version
        8.15.10.1930

        Driver Date
        9-23-2009

        Direct2D Enabled
        false

        DirectWrite Enabled
        false

      GPU Accelerated Windows
      1/1 Direct3D 9
You need to update your Intel driver, or ask your vendor for an updated driver. Anything but the very newest driver has serious bugs.

Comment 26

7 years ago
I have the very latest driver available. The version is 8.15.10.1930, which is the latest available from Intel's website. http://bit.ly/dt09KE
 There is no vendor I can ask from, as I build my PC myself.
 I reinstalled my driver, started with a new profile, and Direct2D is not enabled. Even after trying to change the preferences in about:config, only DirectWrite can be enabled, and Direct2D still remains disabled.
Indeed 8.15.10.1930 should be good. It might be that you hit a bug in the blacklisting code that I just wrote, but from a look at my code I can't see what I did wrong. If you have a debugger and can step through it, to see what's wrong, that would be awesome (I don't have intel hardware). That's in GfxInfo::GetFeatureStatus(), in GfxInfo.cpp starting at line 549.
See patch attached to bug 585832, although I dont really see how that could have ended up blocking D2D in your case.
Note:

        Direct2D Enabled
        false

        DirectWrite Enabled
        false

      GPU Accelerated Windows
      1/1 Direct3D 9

So D3D9 is being turned on just fine, just d2d is not.  So this is not a blocklist issue -- if it was, D3D9 would also be disabled.  Can you try with a clean profile?
OK, I made some investigation and here are my results.

I have two laptops with Intel graphics, both running Windows Vista SP2.


Laptop 1:
---------

Extract of "Troubleshooting Information"

  Application Basics
    Name: Firefox
    Version: 4.0b7pre
    User Agent: Mozilla/5.0 (Windows NT 6.0; rv:2.0b7pre) Gecko/20100922 Firefox/4.0b7pre

  Modified Preferences
    gfx.font_rendering.directwrite.enabled: true
    mozilla.widget.render-mode: 6

  Graphics
    Adapter Description: Mobile Intel(R) 965 Express Chipset Family
    Vendor ID: 8086
    Device ID: 2a02
    Adapter RAM: Unknown
    Driver Version: 7.15.10.1666
    Direct2D Enabled: false
    DirectWrite Enabled: true
    GPU Accelerated Windows: 1/1 Direct3D 9

So the graphics adapter (2a02) is recognized as "IntelGL960_1", belonging to the "IntelGMAX3000" family [1]. My driver version is 7.15.0010.1666 (seen in DirectX diagnostics and apparently well recognized as "7.15.10.1666"), which should pass on Vista (I'm on SP2) according to the block list [2].


Laptop 2:
---------

  Application Basics
    Name: Firefox
    Version: 4.0b7pre
    User Agent: Mozilla/5.0 (Windows NT 6.0; rv:2.0b7pre) Gecko/20100925 Firefox/4.0b7pre

  Modified Preferences
    gfx.direct2d.force-enabled: true
    gfx.font_rendering.directwrite.enabled: true
    mozilla.widget.render-mode: 6

  Graphics
    Adapter Description: Mobile Intel(R) 4 Series Express Chipset Family
    Vendor ID: 8086
    Device ID: 2a42
    Adapter RAM: Unknown
    Adapter Drivers: igdumdx32 igd10umd32
    Driver Version: 8.15.10.2202
    Driver Date: 8-25-2010
    Direct2D Enabled: false
    DirectWrite Enabled: true
    GPU Accelerated Windows: 1/1 Direct3D 9

Note that, in this laptop, I even used "gfx.direct2d.force-enabled" to force a different code path in order to try enabling D2D. I've also noticed I'm able to get WebGL as per bug 585832.

So my final guess is that if attachment 476323 [details] [diff] [review] had been applied as-is (and not the "safe" version actually - see bug 585832 comment 6), this will actually be fixed. :-)

Basically, that would mean relaxing checks a bit, using for Direct2D [3] the same same approach made for D3D/WebGL (replacing the check made):

-            if (status != nsIGfxInfo::FEATURE_STATUS_UNKNOWN &&
-                status != nsIGfxInfo::FEATURE_AVAILABLE)
+            if (status == nsIGfxInfo::FEATURE_BLOCKED ||
+                status == nsIGfxInfo::FEATURE_NOT_AVAILABLE)


I'm not sure if this or bug 585832 should be reopened with this in mind, but I'm setting a dependency on that one. :-)


[1] http://mxr.mozilla.org/mozilla-central/source/widget/src/windows/GfxInfo.cpp#439
[2] http://mxr.mozilla.org/mozilla-central/source/widget/src/windows/GfxInfo.cpp#498
[3] http://mxr.mozilla.org/mozilla-central/source/gfx/thebes/gfxWindowsPlatform.cpp#287
Depends on: 585832
(Reporter)

Comment 31

7 years ago
Helder,

>     Direct2D Enabled: false
Try with a fresh profile because mozilla.widget.render-mode is no more used.

> Basically, that would mean relaxing checks a bit, using for Direct2D [3] the
> same same approach made for D3D/WebGL (replacing the check made):
D2D, D3D and WebGL are 3 different features.
But it is an interesting question : 
D2D is disabled if D2D status is FEATURE_NOT_SUGGESTED
WebGL is enabled if WebGL status is FEATURE_NOT_SUGGESTED
Helder,

If things still don't work after Scoobidiver's suggestion of using a clean profile, that could mean that you have found a bug in my blacklisting code.

Notice that "relaxing" the check in the same way that I did for WebGL won't help here, since the blocklist sets the status as FEATURE_BLOCKED

Since you seem (in comment 30) to able to run this in a debugger (right?), could you then please help me by getting a debug build, e.g. from

ftp://ftp.mozilla.org/pub/firefox/tinderbox-builds/mozilla-central-win32-debug/

setting a breakpoint at the start of GfxInfo::GetFeatureStatus() which should be at GfxInto.cpp line 549, and step though the execution of this function. Since you're getting blocked, that means that it wrongly believes that your card should be explicitly blocked. So somewhere in that function, something goes wrong. You should eventually reach line 601 which is:

      match = driverVersion < info->version;

this is a good point to break and print the values of the various local variables here...  driver versions are 64 bit values, split in 4 16-bit numbers, so e.g. in your case (version modulo 2^16) should be 1666.
(In reply to comment #31)
> >     Direct2D Enabled: false
> Try with a fresh profile because mozilla.widget.render-mode is no more used.

Just did (again) with the most recent build available [1]. I forgot to mention that I had already made a several attempts in order to avoid potential interference. Just in case, I went through the steps again:
 1. Create a fresh new profile - no good;
 2. Disable all add-ons manually ("Microsoft .NET Framework Assistant") seems to be added every time a new profile is created - no good;
 3. Disable all plug-ins manually (Adobe Flash, Java, PDF reader, etc.) - no good;
 4. Set "gfx.direct2d.force-enabled" to true - no good;
 5. Set "gfx.font_rendering.directwrite.enabled" to true - DirectWrite gets enabled.

"no good" means:
  Direct2D Enabled: false
  DirectWrite Enabled: false
  GPU Accelerated Windows: 1/1 Direct3D 9

I've also tried reversing steps 4 and 5 but nothing happened. No matter how, stubborn Direct2D doesn't get enabled no matter how... :-(

As you can see from comment 30, my driver version(s) shouldn't be blocked. I did all these attempts in laptop 2, which has a "2A42" identifier, which for Windows Vista requires driver version "8,15,10,2182" [2] - my installed version is "8.15.10.2202" which is even greater than the required (although the operator comparison code looks good).

Will it be best to hold for bug 594045 to check afterward if this is really due to blacklisting? (I know I should already have attempted to create a debug build and "really" see what's happening...) :-|


> > Basically, that would mean relaxing checks a bit, using for Direct2D [3] the
> > same same approach made for D3D/WebGL (replacing the check made):
> D2D, D3D and WebGL are 3 different features.
> But it is an interesting question : 
> D2D is disabled if D2D status is FEATURE_NOT_SUGGESTED
> WebGL is enabled if WebGL status is FEATURE_NOT_SUGGESTED

Yes, that was the main conclusion from my crawling. ;-)



(In reply to comment #32)
> Helder,
> 
> If things still don't work after Scoobidiver's suggestion of using a clean
> profile, that could mean that you have found a bug in my blacklisting code.

No, they didn't (see above).


> Notice that "relaxing" the check in the same way that I did for WebGL won't
> help here, since the blocklist sets the status as FEATURE_BLOCKED

Yeah, no matter how I analyze the code I can't find a code path which would make things break.


> Since you seem (in comment 30) to able to run this in a debugger (right?),

Nope, but I will. :-)


> could you then please help me by getting a debug build, e.g. from
> 
> ftp://ftp.mozilla.org/pub/firefox/tinderbox-builds/mozilla-central-win32-debug/
> 
> setting a breakpoint at the start of GfxInfo::GetFeatureStatus() which should
> be at GfxInto.cpp line 549, and step though the execution of this function.
> Since you're getting blocked, that means that it wrongly believes that your
> card should be explicitly blocked. So somewhere in that function, something
> goes wrong. You should eventually reach line 601 which is:
> 
>       match = driverVersion < info->version;
> 
> this is a good point to break and print the values of the various local
> variables here...  driver versions are 64 bit values, split in 4 16-bit
> numbers, so e.g. in your case (version modulo 2^16) should be 1666.

Will do, I just can't promise when will I be able to setup a proper build environment to see what's going on...


[1] Mozilla/5.0 (Windows NT 6.0; rv:2.0b7pre) Gecko/20100925 Firefox/4.0b7pre
[2] http://mxr.mozilla.org/mozilla-central/source/widget/src/windows/GfxInfo.cpp#499
[3] http://mxr.mozilla.org/mozilla-central/source/widget/src/windows/GfxInfo.cpp#549
[4] http://mxr.mozilla.org/mozilla-central/source/gfx/thebes/gfxWindowsPlatform.cpp#288
(In reply to comment #33)
> Will do, I just can't promise when will I be able to setup a proper build
> environment to see what's going on...

You dont need a build environment since we provide debug builds, see the link I gave above; you only need a debugger (I'm assuming from your comments that you're a developer ;-) )

But if somehow this is not practical for you to do, I will try fooling my Firefox into believing I have your intel GPU and will try stepping through it myself ;-)
(In reply to comment #34)
> You dont need a build environment since we provide debug builds, see the link I
> gave above; you only need a debugger (I'm assuming from your comments that
> you're a developer ;-) )

Yeah, I've already downloaded the build but I guess now I need to setup (and download) symbols [1], as well as the source code in order to debug properly [2] (or am I missing something?).

I'll try to resume tomorrow, as I don't have enough bandwidth today.


> But if somehow this is not practical for you to do, I will try fooling my
> Firefox into believing I have your intel GPU and will try stepping through it
> myself ;-)

Thanks, that will at least help figuring out if the problem actually lies in the blacklisting code or in a later step, during actual creation/capabilities check, in "VerifyD2DDevice" (during "cairo_d2d_create_device_from_d3d10device" [3] or "cairo_d2d_create_device" [4]).


I'll also ask a co-worker which has Windows 7 installed in order to try figuring out if there's some OS interference. :-)


[1] https://developer.mozilla.org/en/Using_the_Mozilla_symbol_server
[2] https://developer.mozilla.org/en/Debugging_Mozilla_on_Windows_FAQ
[3] http://mxr.mozilla.org/mozilla-central/source/gfx/thebes/gfxWindowsPlatform.cpp#400
[4] http://mxr.mozilla.org/mozilla-central/source/gfx/thebes/gfxWindowsPlatform.cpp#405
I've just been informed of bug 594976 which is about to be landed... this could easily explain the issues you're having here. Can you retry a nightly the day after it's actually landed (probably tomorrow)?
Nevermind. I'm pretty sure that this has been fixed by:

http://hg.mozilla.org/mozilla-central/rev/b07c0925efe5

Can you confirm (on tomorrow's nightly?)
(In reply to comment #37)
> Nevermind. I'm pretty sure that this has been fixed by:
> 
> http://hg.mozilla.org/mozilla-central/rev/b07c0925efe5

Nope, no good. :-|


> Can you confirm (on tomorrow's nightly?)

I've been trying since a few days and no good. Again, I'm using the 20101006 nightly [1] and I'm starting to suspect of a completely unrelated issue: as stated in (comment 35), I've asked two co-workers with Windows 7 installed, one of which with the exact same hardware and the other only for comparison purposes. Somehow surprisingly, both got Direct2D enabled without any effort (I've asked the one with the exact same hardware to update his driver first, due to the blocking list). I'm currently considering either an OS-specific or a specific DirectX version issues. Once I'm able to figure it out, I'll provide further information and/or post a new bug to avoid further spam on this one. ;-)


[1] Mozilla/5.0 (Windows NT 6.0; rv:2.0b7pre) Gecko/20101006 Firefox/4.0b7pre

Comment 39

7 years ago
(In reply to comment #37)
> Nevermind. I'm pretty sure that this has been fixed by:
> 
> http://hg.mozilla.org/mozilla-central/rev/b07c0925efe5
> 
> Can you confirm (on tomorrow's nightly?)

Direct2D is still disable on my config (Intel G965/ X3000) as of 16-Oct-2010. Force enabling Direct2D doesn't works also. DirectWrite is enabled when manually set. Direct3D9 is enabled by default.
(In reply to comment #35)
> > You dont need a build environment since we provide debug builds, see the link I
> > gave above; you only need a debugger (I'm assuming from your comments that
> > you're a developer ;-) )
> 
> Yeah, I've already downloaded the build but I guess now I need to setup (and
> download) symbols, as well as the source code in order to debug properly
> (or am I missing something?).
> 
> I'll try to resume tomorrow, as I don't have enough bandwidth today.

I've tried to setup things but I keep getting the "no symbols loaded" for Firefox-related code in my debugger. I've tried to follow the instructions [1] [2] [3] (I'm used to Visual Studio although I may fallback to WinDbg if needed), but still no good. I'll resume as time permits.


[1] https://developer.mozilla.org/en/Debugging_Mozilla_on_Windows_FAQ
[2] https://developer.mozilla.org/en/Using_the_Mozilla_symbol_server#Using_the_symbol_server_in_Microsoft_Visual_C.2b.2b_2005.2b
[3] https://developer.mozilla.org/en/Using_the_Mozilla_source_server#Using_the_source_server_in_Visual_Studio
Sorry that it's so hard to make use of our debug builds, I didn't realize (since i use my own builds) :(
Blocks: 605053
(In reply to comment #39)
> Direct2D is still disable on my config (Intel G965/ X3000) as of 16-Oct-2010.
> Force enabling Direct2D doesn't works also. DirectWrite is enabled when
> manually set. Direct3D9 is enabled by default.

Given that you didn't confirm it, I'm assuming that your information given in
comment 24 is still updated (naturally minus the Firefox version, which I hope
you have been updated as new builds become available).

You are probably suffering from the same issue as I am (see between comment 30
and comment 38). I've just reported bug 605053 (depending on this one) to try
to deal with this. :-)


(In reply to comment #41)
> Sorry that it's so hard to make use of our debug builds, I didn't realize
> (since i use my own builds) :(

No problem, if/when I can make things right I might even blog about it... ;-)
But, then again, I must have about 15+ drafted blog entries like that I haven't
yet found the time to finish/publish! :-D
You need to log in before you can comment on or make changes to this bug.