TabCandy/Panorama buttons (Close & Search) should behave like buttons and be unified.

VERIFIED FIXED in Firefox 4.0

Status

defect
P2
normal
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: hansschmucker, Assigned: smartell)

Tracking

({ux-userfeedback})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100916 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100916 Firefox/4.0b7pre

The first time I saw the new buttons I actually thought they were rendering glitches (they don't resemble any button shape I know and they don't have any feedback for hover). Next thing I was trying to "pull" on the search icon to draw out the search bar. Then I clicked on it trying to focus it (still assuming it was a glitch and expecting to be able to get keyboard focus). At that stage I realized it was a button.

It's debatable whether the TabCandy buttons should have an OS-look or a style that's more in line with the rest of the interface, but they must be identifiable as buttons.

Reproducible: Always
Keywords: ux-feedback
Priority: -- → P4
Not sure if Aza has been in contact with Martell about this but he had some nice mockups that fixed this problem. Making the buttons look buttony and the panorama icon look depressed(active).
(Reporter)

Comment 2

9 years ago
That's great. Another thing would be the positioning, which is likewise un-buttony :)

Buttons on Windows are typically grouped together, not floating around 3cm apart and half covered by ... well I'm not sure what's supposed to be covering them, seeing as the TabCandy area isn't inset like normal window content.
Assignee: nobody → aza

Comment 3

9 years ago
http://mozilla.seanmartell.com/tabcandy/

* Need to unify the buttons as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: P4 → P1
Summary: TabCandy/Panorama buttons (Close & Search) should behave like buttons → TabCandy/Panorama buttons (Close & Search) should behave like buttons and be unified.
Target Milestone: --- → Firefox 4.0
(Reporter)

Comment 4

9 years ago
One thing to remember is that the TabCandy button inside the TabCandy is supposed to be linked to the button in the normal interface. So my vote would go towards styling them identically. Possibly mirror position as well. Likewise, we have a search field in the normal interface and mirroring shape and position wouldn't hurt, would it?

Updated

9 years ago
Blocks: 597043
OS: Windows 7 → Windows XP
Priority: P1 → P3

Comment 6

9 years ago
Awaiting designs from Sean Martell.
Assignee: aza → smartell
OS: Windows XP → All
Priority: P3 → P2

Updated

9 years ago
Blocks: 594429
Duplicate of this bug: 600191

Updated

9 years ago
Duplicate of this bug: 603297
Sean, is http://mozilla.seanmartell.com/tabcandy/ the most recent iteration? Should we go ahead and implement this design now?
I believe we still need to unify the two buttons.
(In reply to comment #10)
> I believe we still need to unify the two buttons.

Aza, Sean, what is the status of this task? Are we waiting on a new design, or should we start to implement Sean's latest?
Still waiting for Sean's implementation.
(Assignee)

Comment 13

9 years ago
Is the only change unifying the two buttons styles?  That should be a simple copy/paste of the styles within CSS. Or is it something more involved than that?
No, it is making them into a unified control. Right now it looks disjoint (which is my own fault as I spec'ed 'em that way): there are these two random buttons. It makes sense to pull them together so we just have one target in the upper right.
(Assignee)

Comment 15

9 years ago
Could I get a revised spec example of exactly how it should work?  Also, what happens if people customize their tabstrip and move the panorama button?  That would break the "same position" toggle idea.
While this is probably orthogonal to the buttonization of the search button, I just thought this looked cool and potentially relevant. Enjoy.

http://twitter.com/#!/PhilippAntoni/status/2418600778407936

Comment 17

9 years ago
bug spam (moving to b10)
Blocks: 608028

Comment 18

9 years ago
bug spam
No longer blocks: 597043

Comment 19

9 years ago
This bug has been languishing, so I took a whack at it.

Essentially I reproduced the styling of a group. In terms of functionality, I would think that you could never cover the button pane with a tab or group.
Attachment #498414 - Flags: ui-review?(aza)
Depends on: 598375
Kevin, this looks great.

Sean, can you take a gander and make any adjustments?
Comment on attachment 498414 [details]
Unified Panorama/Search button... area

Flipping the UI review flag over to Sean M, as Aza's given his $.02.
Attachment #498414 - Flags: ui-review?(aza) → ui-review?(smartell)
bug 598375 has now landed, which unifies the buttons, hopefully addressing the main concerns of this bug as well. We haven't added hover states, but considering how long this bug has been open, it's probably not going to happen. 

Resolving this bug; if we still want hover states, let's start a fresh bug for it.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Attachment #498414 - Flags: ui-review?(smartell)
I see a thin line is seen on the right edge of the window on today's build. STR:

Open an app tab in a new window
Enter, exit and re-enter panorama using panorama button
Hit the right arrow button on keyboard

Is this bug causing it or a new bug should be filed?
(Assignee)

Comment 24

8 years ago
Looks good.

On the OSX version, it looks as if the CSS style used for the unified button matches the tab group CSS style. Would it be possible to change it to how the side elevated buttons look in: http://mozilla.seanmartell.com/tabcandy/ ?
(Assignee)

Comment 25

8 years ago
Not how they are grouped, just the actual style of the button.
(In reply to comment #25)
> Not how they are grouped, just the actual style of the button.

Let's spin up a new bug for that. I think that can happen purely within pinstripe. Bug 626666.
(In reply to comment #23)
> I see a thin line is seen on the right edge of the window on today's build.
> STR:
> 
> Open an app tab in a new window
> Enter, exit and re-enter panorama using panorama button
> Hit the right arrow button on keyboard
> 
> Is this bug causing it or a new bug should be filed?

Please file a new bug. Make sure to include what OS you're on (I can't reproduce this on my Mac).
Depends on: 627113
verified with nightly build of minefield.
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.