Closed Bug 598112 Opened 12 years ago Closed 12 years ago

UseAsyncPainting, always return FALSE because plugin mRunning == FALSE

Categories

(Core Graveyard :: Plug-ins, defect)

x86
Linux
defect
Not set
normal

Tracking

(blocking2.0 beta7+)

RESOLVED FIXED
Tracking Status
blocking2.0 --- beta7+

People

(Reporter: romaxa, Assigned: romaxa)

References

Details

Attachments

(2 files)

I found that recent change with new UseAsyncPainting, does not work correctly, because mRunning check
http://mxr.mozilla.org/mozilla-central/source/modules/plugin/base/src/nsNPAPIPluginInstance.cpp#881

is FALSE.
Attachment #476888 - Flags: review?(roc)
Blocks: 556487
Looks like try server is happy.with this fix
blocking2.0: --- → ?
Attachment #476888 - Flags: approval2.0?
blocking2.0: ? → betaN+
Attachment #476888 - Flags: approval2.0?
Depends on: 598262
this cause permaorange of 597742.
https://bugzilla.mozilla.org/show_bug.cgi?id=598262 - here is the new bug about it
Josh can you check this?
See comment in bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=598262#c4
Assignee: nobody → romaxa
Status: NEW → ASSIGNED
Attachment #477126 - Flags: review?(joshmoz)
Attachment #477126 - Flags: review?(joshmoz) → review+
blocking2.0: betaN+ → beta7+
http://hg.mozilla.org/mozilla-central/rev/94b9c4cb2312
http://hg.mozilla.org/mozilla-central/rev/9b2c5eb8641e
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
It seems that these two patches triggered this bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=599476
Oleg?
Summary: UseAsyncPainting, always return FALSE becuase plugin mRunning == FALSE → UseAsyncPainting, always return FALSE because plugin mRunning == FALSE
Blocks: 586162
Blocks: 583475
Depends on: 599476
(Looks like Oleg's on it, over on bug 599476)
Depends on: 601212
Depends on: 601315
Depends on: 602190
Depends on: 603397
Depends on: 606481
It looks like this caused bug 606481.
Depends on: 629472
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.