Last Comment Bug 598406 - Silverlight not supported by i386/x86_64 universal binary on Mac OS X 10.6
: Silverlight not supported by i386/x86_64 universal binary on Mac OS X 10.6
Status: VERIFIED FIXED
[Input][in b8 relnotes]
: relnote
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: All Mac OS X
: -- normal with 11 votes (vote)
: ---
Assigned To: Josh Aas
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
: 563173 609285 610519 614812 617873 620153 620214 (view as bug list)
Depends on:
Blocks: 639095
  Show dependency treegraph
 
Reported: 2010-09-21 12:09 PDT by Josh Aas
Modified: 2011-03-04 19:01 PST (History)
32 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
Netflix screenshot. (132.61 KB, image/tiff)
2011-01-14 11:02 PST, Mary
no flags Details

Description Josh Aas 2010-09-21 12:09:01 PDT
Silverlight currently only supports the Carbon event model.

We are planning to ship an i386/x86_64 universal binary with x86_64 as the preferred architecture on Mac OS X 10.6. The x86_64 binary cannot load Silverlight in-process because Silverlight is i386-only, and we do not support putting Carbon event model plugins out of process.

As a result of this the i386/x86_64 is unable to load Silverlight when running in x86_64 mode on Mac OS X 10.6.
Comment 1 Sunil 2010-09-21 12:17:30 PDT
Thanks for the notification Josh. The Silverlight team is tracking to understand all the issues surrounding enabling this scenario in the Firefox 4.0 release timeline. 

Should any issues that arise as questions for Mozilla be tracked in this thread?

Regards,
Sunil
Comment 2 Josh Aas 2010-09-21 12:28:41 PDT
(In reply to comment #1)

> Should any issues that arise as questions for Mozilla be tracked in this
> thread?

Sure, though for technical issues with NPAPI and your transition you can also email me directly. Thanks.
Comment 3 Josh Aas 2010-11-08 06:53:31 PST
*** Bug 609285 has been marked as a duplicate of this bug. ***
Comment 4 Aakash Desai [:aakashd] 2010-12-01 11:49:57 PST
Seeing a lot more silverlight comments from osx users since beta 7 went out: http://input.mozilla.com/en-US/search/?q=silverlight&product=firefox&version=&date_start=11%2F12%2F2010&date_end=&os=mac
Comment 5 Marcia Knous [:marcia - use ni] 2010-12-01 11:52:52 PST
*** Bug 614812 has been marked as a duplicate of this bug. ***
Comment 6 Ed Lee :Mardak 2010-12-09 00:50:14 PST
*** Bug 563173 has been marked as a duplicate of this bug. ***
Comment 7 Ed Lee :Mardak 2010-12-09 00:50:20 PST
*** Bug 617873 has been marked as a duplicate of this bug. ***
Comment 8 Ed Lee :Mardak 2010-12-09 00:58:01 PST
*** Bug 610519 has been marked as a duplicate of this bug. ***
Comment 9 Ed Morley [:emorley] 2010-12-31 15:51:40 PST
*** Bug 620214 has been marked as a duplicate of this bug. ***
Comment 10 Ed Morley [:emorley] 2010-12-31 15:55:15 PST
*** Bug 620153 has been marked as a duplicate of this bug. ***
Comment 11 Mary 2011-01-14 11:01:30 PST
Chatted with Marcia.  I'm not sure this is useful, but will share my experience.  When I go to stream I get a "thanks for installing, please restart your browser" type of message.  I haven't installed anything and my plugins are up-to-date.
Comment 12 Mary 2011-01-14 11:02:41 PST
Created attachment 503910 [details]
Netflix screenshot.
Comment 13 RC 2011-01-14 11:04:51 PST
(In reply to comment #11)
> Chatted with Marcia.  I'm not sure this is useful, but will share my
> experience.  When I go to stream I get a "thanks for installing, please restart
> your browser" type of message.  I haven't installed anything and my plugins are
> up-to-date.

I think this is the most quickly recognized symptom, good to have it in the bug for others to see... maybe (maybe), cut down on dupes.
Comment 14 John Washbush 2011-01-29 21:12:52 PST
Folks ... I am running OS X 10.6 on a Mac Pro and until this afternoon, everything was fine.  Today I removed FireFox 3.x, which ran OK but was crashing from time to time, and I installed FireFox 4.0 Beta. With the Beta installed, I cannot get Silverlight to work. I consistently get a message asking me to install Silverlight instead.  It is installed, it worked OK with FireFox 3.x earlier today, and it works OK with Safari and with Chrome. The combination of 4.0Beta and Silverlight is a problem.   

I just thought you would like to know

John Washbush
John@Washbush.Com
Comment 15 John Washbush 2011-01-29 21:45:51 PST
PS ... I failed to mention that starting 4.0Beta in safe mode, with all add-ons disabled, had no effect.  

John
Comment 16 James Rome 2011-01-30 06:10:37 PST
It is the 64-bit problem. So how is this going to be fixed before 4.0 is released?
Aafari, for example, has an option to start it in 32-bit mode.
Comment 17 Josh Aas 2011-01-30 07:58:19 PST
We're working with Microsoft on a fix.
Comment 18 Alice Wyman 2011-01-30 12:51:41 PST
(In reply to comment #16)

> Aafari, for example, has an option to start it in 32-bit mode.

So does Firefox 4:
Open the Applications folder in Finder and locate the Firefox application icon.
Hold down the control key while you click the Firefox icon and select Get Info from the list of menu items. In the "Firefox Info" window, click the box in front of "Open in 32-bit mode" so that it is checked. Close the "Firefox Info" window and then restart Firefox 4. 

The above workaround has been posted to the support.mozilla.com forum  and KB:

https://support.mozilla.com/questions/768234

https://support.mozilla.com/kb/Using%20the%20Silverlight%20plugin%20with%20Firefox
Comment 19 Mike Beltzner [:beltzner, not reading bugmail] 2011-02-08 14:06:36 PST
This no longer blocks as bug 628651 gives us a work-around that isn't dependent on their schedule. That said, I expect they'll ship before we do.
Comment 20 Josh Aas 2011-02-14 16:55:51 PST
Microsoft released the updated version of Silverlight 4 with Firefox 4 for Mac OS X compatibility today.

http://timheuer.com/blog/archive/2011/02/14/silverlight-february-2011-update-gdr3.aspx
Comment 21 Ed Lee :Mardak 2011-02-14 17:04:04 PST
Verified!

Silverlight 4.0.51204.0 resulted in the notification bar from bug 628651

Installed from http://go.microsoft.com/fwlink/?LinkId=149156

Silverlight 4.0.60129.0 = SUCCESS!
Comment 22 juan becerra [:juanb] 2011-02-16 10:42:38 PST
Confirming what Mardak said, on the latest nightly, with the latest Silverlight.

Note You need to log in before you can comment on or make changes to this bug.