Tab groups just made me go hulk on my browser

RESOLVED DUPLICATE of bug 604381

Status

defect
P1
normal
RESOLVED DUPLICATE of bug 604381
9 years ago
3 years ago

People

(Reporter: stechz, Assigned: iangilman)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Posted image Screenshot
Using nightly, tab groups come up and nothing is clickable. The screen looks corrupted and I can only click and drag to make new groups. No tabs are visible. Nothing gets me out of groups view. I restart my browser. It comes up again.

I finally escaped the death trap by pressing Mac-T. I am scared for my tabs now, and I hope they're OK.
Found this in my error console:
Error: tabview assert: tabItem must be a TabItemUI_onTabSelect([object XULElement])@chrome://browser/content/tabview.js:7188
([object XULElement],[object Event])@chrome://browser/content/tabview.js:7108
((function (tab) {if (tab.ownerDocument.defaultView != gWindow) {return;}self.onTabSelect(tab);}),0,[object Array])@resource:///modules/tabview/AllTabs.jsm:127
([object Event])@resource:///modules/tabview/AllTabs.jsm:125
updateCurrentBrowser()@chrome://browser/content/tabbrowser.xml:827
onselect([object Event])@chrome://browser/content/browser.xul:1
set_selectedIndex(8)@chrome://global/content/bindings/tabbox.xml:654
set_selectedPanel([object XULElement])@chrome://global/content/bindings/tabbox.xml:673
set_selectedIndex(8)@chrome://global/content/bindings/tabbox.xml:394
set_selectedItem([object XULElement])@chrome://global/content/bindings/tabbox.xml:426
set_selectedTab([object XULElement])@chrome://global/content/bindings/tabbox.xml:106
set_selectedTab([object XULElement])@chrome://browser/content/tabbrowser.xml:1877
loadOneTab("about:blank",(void 0))@chrome://browser/content/tabbrowser.xml:1007
BrowserOpenTab()@chrome://browser/content/browser.js:7073
oncommand([object XULCommandEvent])@chrome://browser/content/browser.xul:1

Source File: resource:///modules/tabview/AllTabs.jsm
Line: 131
Dupe of bug 604376, but this has more information.
blocking2.0: --- → ?
Assignee: nobody → ian
Priority: -- → P1
Blocks: 604376
No longer blocks: 604376
Duplicate of this bug: 604376
This behavior does not occur in the 10/12 nightly. Starts in the 10/13 nightly.
(In reply to comment #4)
> This behavior does not occur in the 10/12 nightly. Starts in the 10/13 nightly.

... so it's gotta be in here:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2593c8c8af8b&tochange=f6e81dd5a125

Digging in.
Blocks: 597043
Here are the patches that landed that day, sorted from what I think is most likely to cause this problem down to least likely:

Bug 595374 - Panorama doesn't go back to the right tab if it was an app tab r=dietrich, a=blocking
Bug 597218 - It shouldn't be possible for app tabs to be hidden r=dao, a=blocking
Bug 587043 - Closing the tabcandy window closes the browser [r=dietrich,a=block2.0]
Bug 597601 - Clicking in the empty space in a group should not take you into a tab [r=dolske,a=beltzner]
Bug 589304 - When tabs are small enough to hide the close icon, stack tabs r=dolske, a=beltzner
Bug 600741 - make search test more robust r=dolske, a=test
Bug 595875 - Removed all Utils.log in all tabview tests [r=dolske, a=beltzner]

In fact, only the top two really seem like likely candidates. 

I've looked through the patches, and I haven't found a smoking gun. I also can't repro the problem. 

Someone who has the problem, could you share your sessionstore.js data file with me? Alternately, you could reset your local repo to 56403a9ae8b6 and then try applying the above patches one by one to see if you can find the guilty party.
Dupe of bug 604381 (which also explains why not everyone is seeing this)
Yep, I checked and I'd set javascript.options.methodjit.chrome = true. Setting it to false resolve the problem.

Resolving duplicate against bug 604381 since that one has got all the right people cc'd on it.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 604381
Canceling blocking request on this dupe.
blocking2.0: ? → ---
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.