The default bug view has changed. See this FAQ.

Mozilla doesn't add time to the day

RESOLVED WONTFIX

Status

mozilla.org
Miscellaneous
--
major
RESOLVED WONTFIX
17 years ago
a year ago

People

(Reporter: Eric Hodel, Assigned: Mitchell Baker)

Tracking

({highrisk})

Details

(Whiteboard: bugday0420, URL)

(Reporter)

Description

17 years ago
Its now 0300 PDT and I'm very tired.  If Mozilla added more hours to the day I
wouldn't have to get up at 0600 PDT to help my gf with homework.  I spend so
much time working on the Lizard with Sidebar panels, hangning out on
irc://irc.mozilla.org/#mozillazine and irc://irc.mozilla.org/#sidebar that I
just don't have time to do my own work.

I'm setting platform to other because there is no "space-time continuum"
platform, I'm also setting the OS to other because I don't know what OS the
universe runs on.

Leaving this unconfirmed because Moz may actually be adding hours to the day,
but I am unable to detect it without doing some physics calculations that would
further deprive me of sleep.

I think this should go in the component "Live Connect", but I'm too tired to try
to figure that out.

Setting Severity to major because I want sleep _now_.  (Maybe I should stop
filing bugs and just go to sleep, nah.)

Comment 1

17 years ago
get rid of the gf, then we can help you ;p. maybe blake will want her?

Comment 2

17 years ago
Making this bug as blocking bug 51015 because there would most likely have to be
a major disruption of the space time contium (sp?) before Microsft would start
using Mozilla.  This same disruption should allow us to add more hours.

How do you code this up?  Can XUL handle it, or do we have to go lower level?
Blocks: 51015

Comment 3

17 years ago
Adding myself to cc: list since I think I will be encompassing standards 
compliance to include GMT measurements.  Also confirming bug as I have the same 
issue on current builds.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

17 years ago
doron: getting rid of the gf is not an option, sorry.  There's no way I would
give her up.

However I did recall seeing an article at http://theonion.com about an
overclocker who created a rift in the time-space continuum by cranking his
processor up so fast that it executed instructions before they arrived.  I can't
find the article now though.

We should try to get the Mozilla to render content before it is downloaded, that
may cause a similar effect...

Comment 5

17 years ago
Point well taken.  Written up as an RFE.

http://bugzilla.mozilla.org/show_bug.cgi?id=60787
(Reporter)

Comment 6

17 years ago
adding bug 60787 as dependency
Depends on: 60787

Comment 7

17 years ago
try this for inspiration, Eric:)
http://bbspot.com/News/2000/5/clock_rift.html
I do believe, this is the story you are talking about.
yet, to boost creativity, i would suggest: loading mozilla before user clicks
the icon. No more whining how IE loads faster.

Comment 8

16 years ago
not gonna get to this any time soon so I'm reassigning it.
Assignee: asa → drbrain-bugzilla
Blocks: 59921

Updated

16 years ago
Blocks: 95849

Comment 9

16 years ago
"i would suggest: loading mozilla before user clicks the icon."

Works for me.  In Mozilla for Windows:
Edit > Preferences... > Advanced
Turn ON Quick Launch

Updated

15 years ago
Blocks: 123456

Updated

15 years ago
No longer blocks: 123456

Updated

15 years ago
No longer blocks: 59921

Comment 10

15 years ago
Comment #8 is a prime example of why this bug is so important.

Comment 11

15 years ago
THis should be marked invalid as Bugzilla is not the place for silly jokes its 
for decvelopers and bug finders
would be nice but is INVALID for obvious reasons
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 13

15 years ago
Reopening...this isnt hurting anyone and isnt asssigned to anyone and finally
its one of my favorite bugs.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 14

13 years ago
Bravo.

Comment 15

13 years ago
Marking Future because the physics of using binary code and xml to alter space
time, or at least slow down the rotational velocity of Earth's axis, is not well
understood and needs reserch. And quite possibly someone will know how to do
this in the future.
Target Milestone: --- → Future
Product: Browser → Seamonkey
Blocks: 283284

Comment 16

12 years ago
lol :DDDDDDDD

Comment 17

11 years ago
(In reply to comment #15)
> Marking Future because the physics of using binary code and xml to alter space
> time, or at least slow down the rotational velocity of Earth's axis, is not well
> understood and needs reserch. And quite possibly someone will know how to do
> this in the future.

The extraterrestrial beings responsible for this crop circle,
http://lug.oregonstate.edu/index.php/Projects/Firefox/Firefox_Circle, likely have knowledge of warp travel that may prove useful here.
Setting highrisk, as temporal manipulations and extraterrestrial contact are both inherently dangerous.
Keywords: highrisk
(In reply to comment #15)
I'm almost three years in the future at the moment, so hopefully this comment was useful:

I think Travis's idea was a good way to approach this. In the future, we've now got a shiny Firefox curled around much of the globe, so we just need to decrease its shininess gradually over time. This will increase the friction between the Firefox and Earth and will slow Earth's rotation, increasing the length of each day.

The heat caused by the friction can be radiated away from the Firefox's tail. If that's not sufficient, we might be able to collaborate on a fix with the IceWeasel guys.

Perhaps we could reuse some code from the older version of the Firefox logo? ( http://www.hicksdesign.co.uk/journal/spot-the-difference ) It seems a lot less shiny and so presumably would provide more Firefox-Earth friction.

Note however that this approach is currently limited to Earth until we can get Firefoxen curled around other planets, which is blocked by bug 262173 comment 6. Fortunately, this won't be too much of a problem for Mars, since its day is already 24 hours 37 minutes, or Mercury and Venus (58 and 248 days respectively).

But by the time we get to Ceres and Jupiter, whose days are only 9 hours 4 minutes and 9 hours 55 minutes respectively, we're gonna need a better fix, such as the planet-agnostic humping interface described by bug 262173 comment 6.
Depends on: 262173
Assignee: drbrain-bugzilla → general
Status: REOPENED → NEW
Priority: P3 → --
QA Contact: doronr → general
Target Milestone: Future → ---

Updated

8 years ago
Flags: wanted1.9.2?
Flags: blocking1.9.2?
Flags: wanted1.9.2?
Flags: blocking1.9.2?

Updated

7 years ago
Assignee: general → mitchell
Component: General → Miscellaneous
Product: SeaMonkey → mozilla.org
QA Contact: general → miscellaneous
Version: Trunk → other

Updated

7 years ago
Whiteboard: bugday0420
I see no reason to keep this bug open.
Status: NEW → RESOLVED
Last Resolved: 15 years ago6 years ago
Resolution: --- → WONTFIX
This is actually more relevant than even given the repaid release cycle. Reopning.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Updated

5 years ago
Depends on: 801310
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago2 years ago
Resolution: --- → WONTFIX
No longer depends on: 60787
No longer depends on: 801310

Comment 22

2 years ago
why are you closing this and removing depends bugs?
You may not want to fix this, but other might want to pick it up... also this type of bugs don't affect normal bug triage, so leave then alone.

Please reopen.
You need to log in before you can comment on or make changes to this bug.