Closed Bug 606909 Opened 9 years ago Closed 9 years ago

Don't put the tab drop indicator above tabs

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 4.0b12
Tracking Status
blocking2.0 --- -

People

(Reporter: vladmaniac, Assigned: dao)

References

(Blocks 2 open bugs)

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

Attached image screenshot
Build ID: 

Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101021 Firefox/4.0b8pre

Prerequisites: 
Clean profile, no extensions
No personas, themes

Steps: 
1. Make sure you have some tabs opened 
2. Enter fullscreen mode (view->fullscreen or F11) 
3. Perform mouse hover() event to trigger the tab bar 
4. Move some tabs around via drag&drop 

Behavior: 
Tab positioning indicator is not available. Can be confusing when having lots of tabs and we are interested in positioning them accurately. 

Note: see screenshot
Whiteboard: regression?
Do you see this issue with Firefox 3.6.11 builds?
This was seen in Trunk only, I'll check out both the 3.6 releases, if you send me a download ftp link.
Summary: Tab positioning indicator does not appear in fullscreen mode → Tab positioning indicator does not appear in fullscreen mode with tabs on top
Bug 544815 and enabled Tabs on Top causes the problem .
Depends on: 544815
Blocks: 544815
No longer depends on: 544815
Keywords: regression
Whiteboard: regression?
Same with Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101025 Firefox/4.0b8pre
blocking2.0: --- → ?
OS: Windows 7 → All
Hardware: x86 → All
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

Works fine in 3.6.12 version. Able to see the tab position indicator.
Worth fixing, not a blocker.
blocking2.0: ? → .x
Blocks: 614311
Attached patch patch (obsolete) — Splinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #500778 - Flags: review?(gavin.sharp)
Blocks: 591504
Summary: Tab positioning indicator does not appear in fullscreen mode with tabs on top → Don't put the tab drop indicator above tabs
Duplicate of this bug: 614311
Duplicate of this bug: 624146
Attached patch patch v2Splinter Review
mirrored the arrows for Windows and Linux
Attachment #500778 - Attachment is obsolete: true
Attachment #503217 - Flags: review?(gavin.sharp)
Attachment #500778 - Flags: review?(gavin.sharp)
No longer blocks: 614311
Duplicate of this bug: 626652
(In reply to comment #11)
> Created attachment 503217 [details] [diff] [review]
> patch v2
> 
> mirrored the arrows for Windows and Linux

I am not sure what this means, but am assuming the patch hasn't landed yet as I am not seeing any changes in the Hourly builds and the patch status still says "review?".  I would like to see this land before the RC, please, as this is a major functionality loss.  Tab sliding / movement can come later (as was stated in the other bug report).
Duplicate of this bug: 628032
How is this not a blocker? Just wondering, since this makes drag and drop near unusable with any guaranteed accuracy.
Mozilla, what is the current status of this bug, please?

Patch version 2 has said "Review?" and Gavin needs to see for the past couple weeks now.  Will a patch land soon?

I would like to see this land by the time RC is released, because remember Mozilla, Microsoft is going to release their browser BEFORE you and they already have full screen tab reordering in their beta versions of Internet Explorer 9.  If the patch is ready, why is it taking so long for it to land?
This became more problematic with tabs in the title bar. It doesn't make sense for bug 591504 to block, where the indicator would initially be missing, but for this not to block, where the indicator is constantly missing.
-> Renominating for blocking.
blocking2.0: .x → ?
Thank you... finally.
Blocks: 591050
Dao, I disagree with comment 17. Bug 591504 affects the browser in all states, whereas this bug is only in the state where the browser is maximized.

That said, I'd happily approve a safe patch.
blocking2.0: ? → -
Does this at least have approval to land?
Attachment #503217 - Flags: review?(gavin.sharp)
Attachment #503217 - Flags: review+
Attachment #503217 - Flags: approval2.0+
(In reply to comment #19)
> Dao, I disagree with comment 17. Bug 591504 affects the browser in all states,
> whereas this bug is only in the state where the browser is maximized.

I believe the maximized state is what most users on Windows will see. We should get data on this.
http://hg.mozilla.org/mozilla-central/rev/2534b939914d
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b12
Putting the indicator arrow beneath the tab seems like a bad idea to me. Unless the tab preview is transparent (it's not for me), the arrow will be obscured 50% of the time.

IMHO a better solution would be to keep the arrow at the top of the tab, but draw it inside the tab bar instead of outside of it. Essentially, revert what was checked in and just change the margin-top to be 0px.
(In reply to comment #23)
> Created attachment 510093 [details]

This is better but doesn't solve all the problems. A more contrasting arrow may be used.
The primary concern was to get the indicator back. Please file new bugs for concrete suggestions as to how it could be styled better.
I do not see why this needs to be spread across multiple bugs to reach the same end. Especially given this is continued discussion on the exact same issue, and IMHO it is a discussion that should have happened here before landing in the first place.

Filed Bug 631881
(In reply to comment #25)
> The primary concern was to get the indicator back. Please file new bugs for
> concrete suggestions as to how it could be styled better.

I agree - please do NOT back this bug out until people have a chance to see what the new tab indicator looks like, as this patch took four months to land.
Can't we do it Chrome style where they slide around in the tab bar?  I think that would be more visually effective.
(In reply to comment #28)
> Can't we do it Chrome style where they slide around in the tab bar?  I think
> that would be more visually effective.

That would be Bug 455694
Verified fixed with Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110209 Firefox/4.0b12pre

With the default behavior on Windows 7 our existing Litmus tests should cover the tab drop indicator, which is now placed below the tab bar.
Status: RESOLVED → VERIFIED
Flags: in-litmus-
You need to log in before you can comment on or make changes to this bug.