Status

enhancement
RESOLVED WONTFIX
19 years ago
10 years ago

People

(Reporter: numizmatyka, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wontfix?][Hixie-P0])

Reporter

Description

19 years ago
Sometimes Messenger downloads twice the same message. And then we need an option 
to search for duplicates and to hide them (eg. Edit|Show/Hide duplicates) - not 
delete or move them but just hide them. And an second option Edit|Select all 
dups.
P.S. Don't know what category, but maybe filtering?

Updated

19 years ago
QA Contact: esther → laurel
Reporter

Comment 1

19 years ago
It dups when "Leave mail on server" is checked.

Comment 2

19 years ago
Marking NEW...though not sure if this is taken care of or not.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter

Comment 3

19 years ago
It is also good, when somebody mail-bombs you. One click, and 5000 messages
reduced to 1.
Depends on: 59368
Blocks: 66425

Comment 4

19 years ago
I believe that this bug is a duplicate of the bug 9413.
Not sure.  Bug #9413 is (now) about removing exact duplicates (body + all
headers inc. MsgID) _automatically_ that land in the same folder, which is a
no-brainer.

Although you would pretty much always expect exact duplicates to land in the
same folder, that's not entirely guaranteed for different reasons.  And you
might also want to search for near duplicates (ie those with identical bodies
but not headers).  Hence a manual inter-folder tool like this seems to describe
would definitely have uses.

Comment 6

19 years ago
Oh, OK, I agree. But if this feature is implemented, then resolving bug #9413
would not be as critical.
And vice versa.  I'd rather see the other one first, personally.
OS: Windows 98 → All
Hardware: PC → All

Comment 8

18 years ago
reassigning to naving
Assignee: gayatrib → naving
This would kick ass. I just accidentally duplicated 4000 e-mails. :-/
Whiteboard: [Hixie-P0]

Comment 10

17 years ago
*** Bug 139382 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago

*** This bug has been marked as a duplicate of 158032 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE

Comment 12

17 years ago
marking verified as a duplicate.
Status: RESOLVED → VERIFIED

Updated

17 years ago
Blocks: 195158

Updated

17 years ago
No longer blocks: 66425
Product: MailNews → Core

Comment 13

13 years ago
How can this be a duplicate of bug 158032 if comment 0 says he wants to _hide_, not _delete_ dupes?
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
Summary: [RFE] Filtering: search duplicated messages → [RFE] hide duplicated messages
Well, why would you want to hide duplicates, but not delete them? Bug 9413 also implemented a few other options...
Assignee: naving → nobody
Status: REOPENED → NEW
Priority: P3 → --
QA Contact: laurel → filters
Product: Core → MailNews Core
Summary: [RFE] hide duplicated messages → Hide duplicated messages
sounds like a bad idea. 
wontfix?
Whiteboard: [Hixie-P0] → [wontfix?][Hixie-P0]

Comment 16

10 years ago
Yeah, I think that would be confusing. But what would be nice is a way to find duplicates and manipulate them (e.g., select all duplicates, and then you could delete them). Probably add-on fodder.
Marking WONTFIX for hiding of the duplicates.  The real issue (to me) seems to be that we're duplicating messages, I assume there is a bug already for that.
Status: NEW → RESOLVED
Closed: 17 years ago10 years ago
Resolution: --- → WONTFIX

Comment 19

10 years ago
(In reply to comment #17)
> https://addons.mozilla.org/en-US/thunderbird/search?q=duplicat&cat=all&advancedsearch=1&as=1&appid=18&lver=any&atype=0&pp=20&pid=5&sort=&lup=

You rang? :-)

Anyway, what constitutes a dupe is kind of tricky, which is why my extension has a review dialog as the default. You compare different attributes of messages in different scenarios.
You need to log in before you can comment on or make changes to this bug.