Mail sometimes wedges and won't delete anymore

RESOLVED FIXED

Status

MailNews Core
Backend
P2
major
RESOLVED FIXED
17 years ago
10 years ago

People

(Reporter: Mike Pinkerton (not reading bugmail), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+ 2/13])

Attachments

(3 attachments)

21.53 KB, application/x-zip-compressed
Details
285.84 KB, text/plain
Details
946 bytes, patch
(not reading, please use seth@sspitzer.org instead)
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
(not reading, please use seth@sspitzer.org instead)
: approval1.4+
Details | Diff | Splinter Review
(Reporter)

Description

17 years ago
After using mail for a while, sometimes the mail window will just stop deleting
email. Neither hitting backspace nor clicking the delete button will do
anything. Sometimes the delete button is disabled, other times it is enabled but
does nothing.

Hyatt has seen this on win32, both at work and at home. I see it on macOS too.
It happens more frequently to hyatt. Happens with both ns6 builds and current
mozilla builds. Closing the window and reopening it seems to un-wedge it, but
it's still very annoying.
(Reporter)

Updated

17 years ago
Keywords: nsbeta1

Comment 1

17 years ago
There've been reports of this periodically throughout seamonkey (I don't know
bug numbers off-hand) and unfortunately most of the cases nobody can reproduce
when we get down to it.

 
QA Contact: esther → sheelar

Comment 2

17 years ago
We should investigate some more but there's a good chance we still might not be
able to find it.
Priority: -- → P2
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.8
(Reporter)

Comment 3

17 years ago
this happened to me today when i did the following:

I was in a folder (bugs, not my inbox) and hit "get mail". It took a while in
the background to complete getting the mail, and once it finished, i could no
longer delete messages. Mind you, i'd been deleting them straight for over an
our (vacation email!).

This time, I had to quit the app to get it to work. Simply closing the mail
window and reopening it didn't fix it like normal. 

Comment 4

17 years ago
are you using imap or pop3?
(Reporter)

Comment 5

17 years ago
sorry: imap, and an opt build from 12/15.

Comment 6

17 years ago
Here is how to reproduce it for build 2001010908.
1. Prerequiste, have some email saved in Drafts folder.
2. Quit and restart Mozilla. Probably no necessary.
3. Compose an email, click on Save(or use Ctrl-S as I do) say 3 times.
4. Now there should be 3 copies of the saved emails, use "Delete" button to
delete these one by one. This should work.
5. Now try deleting the earlier ones in the same folder, Drafts. It does not
work. Mozilla does not show these until I double click and open in a new window.

Also, I have many emails in my Drafts folder which I cannot delete. I can attach
the related files including "Drafts" and "Drafts.msf", though the Drafts folder
is around 2.7 meg. Also note, there is no Drafts.sbd.

I have a duplicate bug at <a HREF="show_bug.cgi?id=64653"> bug 64653
</a>


Thanks
Amit

Comment 7

17 years ago
For me, this happens quite easy in "big" folder (around 80-100 mails), selecting
multiple messages to delete, especially if I repeat that some times or select,
say, a block of 2/3 of the messages in the folder.
This is Mozilla build 2001-01-14-21 Linux.

Comment 8

17 years ago
It seems for me that it happens every time Mail has failed to delete some
message, e.g. I have a message without a "To: " line (It only went to Bcc
addresses - "undisclosed-recipients;"), which I can't delete somehow. If I try
to, Mail also fails in every successing try to delete messages in this folder or
other folders. Another message, which has a big attachment (3MB), crashes Moz
when selected. If I select a range of messages in the folder which includes that
one, the whole delete process seems to fail, and further deleting is blocked.
If I close Mail window and re-open Mail, it doesn't work again. I have to close
Moz and lauch the whole app again.

Comment 9

17 years ago
Robert, I'm guessing you're talking about pop3 local mail, and not IMAP? And
Amit, are you using IMAP or POP? My guess is that what's happening to the pop
users is that we're locking the local folder in question, and not clearing the
lock when the delete operation fails. Only shutting down and restarting will
clear the lock. This means there are two bugs - the cause of the delete
operation failing, and the fact that we're not clearing the lock afterwards.
(this is an in-memory lock, not an on-disk lock).

Comment 10

17 years ago
bienvenu: er, yes, this is local mail folders here (pop3 and other local
folders, e.g. sent).
Is this originally an imap bug? (I now realized pinkerton seems to be talking
about imap)
If yes, then me and amit_ch@yahoo.com (which appears to be talking about the
same problem than me) seem to be at the wrong bug and there should perhaps be a
different one for our issue, right?

Comment 11

17 years ago
yes, I suspect this is a different bug. We had a bug about delete failing that
was marked fixed, I think, but there are so many reasons that delete can fail
that it's probably worth opening a new bug instead of re-opening the old one.
I'll do that and add you to the cc list.

Comment 12

17 years ago
Sorry for the delay.
Yes, my comment was regarding POP3 on Linux.

Amit
(Reporter)

Comment 13

17 years ago
this happens for both me and hyatt with IMAP

Comment 14

17 years ago
moving to mozilla0.9
Target Milestone: mozilla0.8 → mozilla0.9

Comment 15

17 years ago
marking nsbeta1- and moving to future milestone.  If we can reproduce this
easily then we can reconsider this.
Keywords: nsbeta1 → nsbeta1-
Whiteboard: [nsbeta1+] → [nsbeta1+ 2/13]
Target Milestone: mozilla0.9 → Future
(Reporter)

Comment 16

17 years ago
just because it's not easily reproducable doesn't mean it doesn't happen every 
day to poor hyatt, his wife, and a lot of the time to myself.

i strongly urge reconsidering. this bites a lot of people.
Keywords: nsbeta1- → nsbeta1

Comment 17

17 years ago
marking nsbeta1-.  This might get fixed in the outliner rewrite.  Let's see if
this keeps happening when that lands.
Keywords: nsbeta1 → nsbeta1-

Comment 18

17 years ago
mike are you still running into this? I still haven't been able to reproduce it yet.

Comment 19

17 years ago
No, please close it. I did not run into it on .81

Comment 20

17 years ago
Maybe this was fixed with the mailnews perf. branch?

Pinkerton, has this occured to you any time lately?
(Reporter)

Comment 21

17 years ago
i haven't seen this recently, though the trunk has been so spotty i haven't been 
able to use it much. i'll ask hyatt if he's seen it.

Comment 22

17 years ago
I'm still seeing this bug - build 2001052904, win95, pop - might be a duplicate
to bug 74591 where I have added more comments and a list of other mail delete bugs.

Comment 23

16 years ago
Created attachment 73138 [details]
A wedged Inbox.

This bug sounds the closest to what I'm seeing.  Basically when I try to delete
four specific email messages from my inbox the email viewer wedges.  Wedges
basically means that the email doesn't delete and the viewer gets stuck viewing
the "deleted" email.  Selecting another folder unsticks the viewer.  When I
return to the inbox, the "deleted" message is still there.  Also moving the
email to another window also causes the viewer to wedge.  I downloaded the
email with Mozilla ~0.9.4.  When I couldn't delete the mail, I upgraded to
Mozilla 0.9.8.	I'm currently running Windows 2000 Pro with all the latest
patches.  I deleted/moved all the email except the for messages.  I also
emtpied the trash and compacted the folder.  The only thing it is the four
email, and my bugzilla registration(which I moved to another folder).  Good
luck

Comment 24

16 years ago
Just a additional note, I have not seen this happening at all. Use to happen a
lot with mails in Drafts folder, etc.
I would consider it fixed as I use both POP3 and IMAP extensively. Current using
0.98 on linux

Regards
Amit

Comment 25

16 years ago
I have it *a lot* with IMAP (delete model: move to trash). I am curretly using
BuildID 2002041303 (trunk) on RedHat Linux 7.2. 

Right now I have a folder and I am trying to delete all the messages from it. I
have it all highlighted and none of the delete methods (Delete button, context
menu, Del key, etc) do not seem to do anything. As I said, I get this kind of
behavior a lot. Usually I just have to press delete 3-4 times and it works, but
not always. The IMAP server I am talking to is Courier IMAP (on localhost). 

I am resetting the milestone to get the "Future" reevaluated - IMHO it's a
pretty nasty bug that needs to be fixed fast.
Target Milestone: Future → ---

Comment 26

16 years ago
While I was typing the above comment, the messages got deleted, so it may be
just an issue of Mozilla not doing the deletion right away, but somehow queuing
it for much later...
(Reporter)

Comment 27

16 years ago
i've seen this come back recently, but i can't find what trips it. i have to
close the main window and reopen it to fix it. brade and akkana have both said
they see this too.

we need to re-evaluate this bug. it just started happening again w/in the last
month or so.
Keywords: nsbeta1

Comment 28

16 years ago
I haven't seen this in a very long time. Aleksey, could you try attaching a
protocol log when the problem happens? Your problem sounds a bit like the url
queueing+chaining mechanism is failing in some situations - the trick is
figuring out how to reproduce the problem. Are you deleting messages rapidly? Is
there anything special about the message you read before deleting messages
(e.g., inline images or something). Does this happen when deleting messages from
a folder that's having messages filtered into it at the same time? Also, is it
possible you're running into one of the various problems where the commands are
not getting enabled when they should (e.g., the delete button is disabled)? If
you tab into the thread pane and do a select all, the delete command will not
get enabled. I have a fix for all the selection problems but I can't check it in
until the tree opens.

Comment 29

16 years ago
Nope, I haven't seen this one.  
(Reporter)

Comment 30

16 years ago
i left mail running overnight (as i normally do) and when i came in this morning
it wedged after deleting a few emails with the following on the console:

###!!! ASSERTION: move/copy already in progress: '!m_copyState', file
nsImapMailFolder.cpp, line 6361

###!!! ASSERTION: move/copy already in progress: '!m_copyState', file
nsImapMailFolder.cpp, line 6361

###!!! ASSERTION: move/copy already in progress: '!m_copyState', file
nsImapMailFolder.cpp, line 6361

###!!! ASSERTION: move/copy already in progress: '!m_copyState', file
nsImapMailFolder.cpp, line 6361

so it obvisouly thinks it's busy, but nothing is happening. i am deleting out of
my inbox, which has filters on it, fwiw.

Comment 31

16 years ago
Yes, that means we think the trash folder is busy having a message deleted into
it for some reason. A protocol log would be useful. Once you're in that
situation, you have to shut down and restart before you can delete again, I
believe. (closing the mail window is probably not sufficient)
(Reporter)

Comment 32

16 years ago
problem is, once i get into that situation, i can't get a protocol log w/out
shutting down and restarting ;) i'll try to remember to run with imap logging,
but i'm sure that the one time i don't is when it'll happen ;)

Comment 33

16 years ago
> you have to shut down and restart before you can delete again, I believe

See comment #26 - while I was serching Bugzilla for this bug and adding a
comment into it the problem have cleared (and the messages got deleted). Very
often I just hit delete several times and the message finally gets deleted (not
sure if it's the first click on Delete that works after a delay, or the last
one). In fact, I *never* had to restart because of this problem - although I see
it a lot, it always goes away on its own... Of course, may be I am just seeing a
different problem...

Comment 34

16 years ago
Aleksey, I saw your comment, which is why I made my comment. There are a two
possibilities - one is that we *falsely* think we're in the process of moving a
message to the trash (e.g., we started moving a message to the trash and it
failed/was aborted but we never cleared the state that said we're moving a
message to the trash). In this case, you have to shut down to clear the state.
The other possibility is that we *are* moving a message to the trash, and in
this case, you do have to wait until the move is finished before deleting
another message. You might be seeing a variant of the second case where the move
stalls for a long time but eventually finishes.
(Reporter)

Comment 35

16 years ago
this morning i didn't actually have to quit to get it to unwedge. i switched to
another folder and came back and was able to keep going with deletes. It's like
i tripped something that caused it to realize it really wasn't busy.

Comment 36

16 years ago
*** Bug 140046 has been marked as a duplicate of this bug. ***

Comment 37

16 years ago
Mike,
Which delete model are you using? Do you have your imap account delete model to 
mark it as deleted or move it to trash?
(Reporter)

Comment 38

16 years ago
my delete model is to move to the trash.

Comment 39

16 years ago
marking nsbeta1- per mail triage.
Keywords: nsbeta1 → nsbeta1-

Comment 40

16 years ago
Delete has stopped working on the inbox of a fresh install of rc3 on Linux
(which was installed as root and run as a user). Switching to an install of
today's nightly build and installing it as the user does not fix the problem.
This is a major, major annoyance.

Comment 41

16 years ago
Removing Trash.msf and restarting restored deletability. I don't know what the
.msf files do, but if having one corrupted breaks major functionality like this,
then using one for Trash, in particular, may be a bad idea. The corruption in
this case happened under rc3.

Comment 42

16 years ago
i quite often see a problem where the delete button and others don't work.
this happens after using quick search. selecting more than one message makes
the button come to life again. I'm pretty sure that my problem is always
triggered by quicksearch. i'm pretty sure this bug pre-dates quicksearch.

I don't recall seeing it be enabled but do nothing.

I use linux, imap and have a whole lot of mail in my inbox.

Comment 43

16 years ago
This seems to be related to another bug - that emptying trash deletes Trash - at
which point deleting anything fails. It appears the only safe time to empty
trash is just before exiting Mozilla entirely, in which case the next session of
Mozilla at least sometimes correctly recreates Trash. In other sequences a stray
Trash.msf can be left around, which appears to create its own problems. This is
on Linux, both rc3 and the current nightly build.

Comment 44

16 years ago
hmm. odd. I've never had this problem and I delete trash several times per day.

does it make any difference if you use a build thats not installed as root?

Comment 45

16 years ago
you're all seeing different problems, I would guess. Empty trash is supposed to
delete the trash, but the problem is that it's not able to recreate it, which
sure sounds like a permissions problem. The quick search problem is a command
updating/selection problem, and I suspect is fixed on the trunk

Comment 46

16 years ago
I have the same problem. I have 2 mailboxes (which gives a lot of iffy behaviour
btw, but I'm not sure if this problem relates to having 2 mailboxes)

If I selected more then 1 message, either by using SHIFT or CTRL, be it all
unread, read or a mix, and I hit the DELETE button then in the bottom right the
progress twisty thing starts up but no mail is actually being deleted.

If I select a single mail item and press DELETE if will not delete.

I have to quit the mail windows and open it again before I can delete again.
Note I do not have to shutdown Mozilla completely, only the mail window.

I have this problem on the 1.1 latest release.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a) Gecko/20020611

Comment 47

16 years ago
Ren, that's a different problem, and one that was fixed on 06/14, so you need to
get a newer trunk build, one from after 06/14

Comment 48

16 years ago
When trying to delete or move emails to another folder, the mozilla "M" just
cycles and the emails are never deleted or moved.  Clicking the Stop button
doesn't do anything.  This seems to happen most often when I try to move or
delete an email with attachments.

Comment 49

16 years ago
Jason, as I said before, that's a different problem, and one that was fixed on
06/14, so you need to get a newer trunk build, one from after 06/14

I mentioned a problem similar to this in bug 90539, but I think it may be more
applicable here. 

I'm running 2002092608 on Win2k and sometimes the "Delete" button on standalone
message windows will work, but it seems to do nothing much of the time.
Occasionally, closing the standalone window and deleting the message from the
mailbox-list ends up working. 

Even then on the mailbox-list, delete doesn't always take affect. In those
cases, I find that I can only close Mozilla and restart it to be able to delete
messages once again. 

This only started happening within the last few days, but it now occurs for me
on two of my machines on which I run Mozilla for mail. 

I'm using IMAP, if that's of any help. 

Updated

16 years ago
QA Contact: sheelar → stephend

Comment 51

16 years ago
Running Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20020926

Another datapoint on this, adding evidence that an uncleared LOCK is involved.

1) First startup after boot, with OR without Quickstart, mail spins the growler
but doesn't connect.  Acts as though blocked from internet.
*Quit* completely, restart (and nothing else), mail connects successfully and
retrieves POP mail.  *But* when shutting down, even tho' the quickstart is
disabled and there's no Mozilla showing on the taskbar/tray, Windows indicates a
Mozilla.exe that won't respond and can't be shut down; clicking <End Now>
doesn't allow to shut down.  Bringing up ProcessInspector shows a Mozilla
process -- murder it!  Wait a few moments, it's back again and now trying to
murder it gets "access denied."  Requires to log off.  Sometimes requires to
pull the plug.

2) The VERY FIRST message I try to move/delete in fullscreen mode moves OK, then
the Inbox wedges completely and no Move or Delete succeeds.  *EXCEPT* I built a
filter and ran the new "Run Now" functionality -- and the message moved.  Moves
and deletes from 3-pane are all OK.

3) Tried to compact Inbox; seemed to work, but then the population of Inbox
doubled, with every message duplicated.  Messing around with this in 3-pane
gives very confusing results indicating not every item listed points to an
actual message in Inbox.  Shut down Mozilla completely, tried deleting
Inbox.msf, got Sharing Violation.  Logged out as me, logged back in as someone
else, found "my" Inbox.msf, still getting Sharing Violation so the LOCK survives
logout.  Reboot, don't start Mozilla, try again, still getting Sharing Violation
(LOCK survives reboot) -- obviously *not* an in-memory lock.  Had to go to
Safe-Mode-Command-Line to delete the dam' thing.  All the "duplicated" inbox
entries vanish.  There was also an Inbox.sbd empty directory and an nstmp1.msf -
I deleted both as well.
Hypothesis: Inbox.msf is locked, compact copies [active entries from] the .msf
to nstmp1.msf then tries to empty or delete Inbox.msf -- and fails; but then the
content of nstmp1.msf is being copied into Inbox.msf giving the "duplicated" items.

New with this build is that the "wedging" is 100% repeatable.  It happens every
time I run Mozilla, no exception.

Comment 52

16 years ago
2) was a very recent regression that should be fixed in today's build.

1) I don't know about this one.

3) Navin should look into. 

There's no lock on disk. If Inbox.msf is still in use, that means you had quick
launch turned on, and the lock in memory was still active.

Comment 53

16 years ago
<blockquote>There's no lock on disk. If Inbox.msf is still in use, that means
you had quick launch turned on, and the lock in memory was still
active.</blockquote>

Umm, no, I have Quickstarter OFF because I tho't it would help the
First-Time-Freeze symptom.  And the lock definitely survives logging off as
user#1 and logging back on as user#2.  Anyway, if it were a simple lock then the
move/delete from 3-pane would also fail, /nicht wahr/?

ANOTHER, weirder, datapoint: If I create a new folder, the *very first* Move
after returning to the main window succeeds.  Then it wedges again.

I'll try on a new build tomorrow.
As mentioned in comment #50, 2002092608 was giving me all kinds of problems with
delete not working all of a sudden. However, as alluded to by Bienvenu in
comment #52, today's builds (2002100104, for instance) are *much better*.

I didn't want to say anything until I could be sure -- but, after having used
the bulid all day, I haven't had a single problem with delete (and, with the
previous build, I was running into the delete-problem every 15 minutes or so).

Bienvenu: What was the bug number to the regression that you mentioned in
comment #52?

Comment 56

16 years ago
With respect to <http://bugzilla.mozilla.org/show_bug.cgi?id=63550#c55>:

#1; [First Launch freezes] NEW Bug#172176

#3: [Mozilla Won't Die] NEW Bug#172173

#2: Greatly improved in 2002-10-01.  But maybe not althogeher gone; I just now
read a message from my Inbox and deleted it in Standalone.  The standalone
display did *not* change; however when I exit Standalone the message is gone
from 3-pane.  ALSO, before reading the message the "unread" count in 3-pane was
incorrect - but it was OK after using and exiting Standalone.

Comment 57

15 years ago
The main 1.2beta download (2002101612 on WinME) doesn't allow me to delete ANY
messages from an IMAP server, and all of my move and delete filters are
non-functional.  This worked adequately in 1.01, although delete would sometimes
go away there too.  I've removed and cleared the registry and reloaded 1.2b, set
up all my mailboxes again and _still_ got the same problem after deleting just
one message.

I really, really wanted to like the Mozilla mail client ... but the truth is
that it simply doesn't work. Screw stability, it just doesn't work.  And having
the developers so focused on building several different GUIs doesn't improve the
situation, when the backend code is what needs their attention.

Comment 58

15 years ago
Joe, could you attach an imap protocol log of a failed delete or move?  If moves
are failing, this sounds to me like something very specific to your imap server.

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap


Comment 59

15 years ago
Except it doesn't happen with any other IMAP client, including Communicator 4. 
Everything else can read and write from the mailbox just fine.

Comment 60

15 years ago
I'll attach an IMAP communication as soon as I can get the problem to replicate.
 I used Outlook Express to clean up the folder, delete all the mail that was
collecting and actually get some work done.  I reopened Mozilla today for the
first time this week and it appears to be working fine now.  I'll keep an eye on
it.  It might have something to do with mailbox size .. we'll find out.

Comment 61

15 years ago
Related to bug 182808?

Comment 62

15 years ago
Sorry, I keep meaning to update this but time has been real short.  The problem
started reoccuring the very next time I opened the mailbox and persists today.

Of special note -- Netscape 7 DOES NOT have this problem.  Can we find whatever
patch was applied to that release and integrate it?

Comment 63

15 years ago
Re bug 182808 - seems related, but I don't have any trouble viewing messages at
all, at any time.  So it's hard to say that it's a confirm match.

He does mention a point worth nothing -- not sure if it is related.  "Get
Messages" does NOT work once Delete goes bye-bye.  I have to close the browser
and reopen it 
	-OR-
If I open a (shared) mailbox that I haven't yet authenticated to, the mail in my
main inbox is usually refreshed when I come back.  But no amount of Get
Messages, Get All Messages, etc etc etc will cause it to check for new mail.

Comment 64

15 years ago
Just FYI this bug doesn't appear on 1.3alpha on Linux.  Don't know if it is the
platform switch or the version update.

Comment 65

15 years ago
Just as an FYI, mail borks on me frequently for a couple of reasons; bugs
existing, the easiest way to fix most of these problems is either a) switch to
another folder and back or b) go offline and back online via either the File
menu or the icon in the bottom right corner.

The reason my folders wedge are primarily emails with embedded NULLs, broken
charsets, or something funky with packet loss.  I don't move my emails to Trash,
I mark them deleted and then purge.
reassigning QA and dev contacts
Assignee: mscott → sspitzer
QA Contact: stephend → esther

Comment 67

15 years ago
I don't move them to trash either.  I can't delete them because the delete
button is grayed out, and the delete key does nothing.  Right-click and delete
is also grayed out.

Not to you, but why hasn't this problem gotten solved yet? As I noted before,
this is NOT a problem with Netscape!  How hard is it to merge the patches
they've applied back into this branch?

Comment 68

15 years ago
Sounds like my problem, repeatable (1.3a, win'95, all IMAP folders):
0. Can't pin down previous behaviour.
1. Delete message, message stays and folder wedges (any folder, includin Inbox.)
2. Able to open other folders, return to wedeged folder, still wedged.
3. Close mozilla, restart, crashes with windows page fault.
4. Restart again, OK.

Comment 69

15 years ago
Happens to me all the time.

If I delete a message (or messages) then I have to quit/restart Mozilla before
any more message delete functions will work.

It didn't happen to me before Mozilla 1.2.

Comment 70

15 years ago
Seems to be fixed in 1.2b.

Comment 71

15 years ago
Sorry! Meant 1.3b!

Comment 72

15 years ago
I am running on Linux Mandrake 9.0 talking to an IMAP server. I have had the
'wedge' problem on both 1.3a and now have it again on 1.3b. The behavior I'm
seeing matches the various comments - delete (through keyboard, mouse, button or
menu) stops working, the mail client wedges, it will no longer display messages
(I can click on different messages but nothing will happen) and I'm just suck.
Sometimes if I switch folders and go back and wait a little bit the problem will
clear itself up. Other times if I switch folders and go back to my inbox and
click on a message the wrong message will display and delete still won't work.
Eventually (in the second case) the system will return to full wedge and stop
showing new messages. I also notice that when I switch folders the order of the
messages when I go back to the inbox will have changed. Other times I have to
completely shut down mozilla and then bring it back up, but that isn't
guaranteed to work. Basically I feel like there is a little random number
generator attached to Mozmail that decides when I'm allowed to delete messages.

Comment 73

15 years ago
Are you guys able to mark messages read/unread when this happens (and so that
the changes stick)? One problem we have with IMAP folders is that we don't
handle READ-ONLY, which happens especially with UW-IMAP when there is another
connection having the folder open and busy.

Comment 74

15 years ago
I can mark the mail as read or not read at will. It doesn't seem to alter any of
the previously described behaviors.

Comment 75

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030224

A variation on the theme:
1. Open stand-alone mail msg window, find a msg to delete;
2. Press <DEL>: it works -- msg window changes to next or prior message;
3. Find a msg to reply to, <CTL>+R, Send reply -- back to msg window;
4. Press <DEL>: nothing.  &Edit,&Delete: nothing.

Need to close the window & go back to 3-pane. 
Re-open stand-alone.  Works again.

Comment 76

15 years ago
A naive mozilla user (me) upgraded from 1.2.1 to 1.3, and now:

1. can only delete a single mail message before the delete operation stops working

2. messages do not appear in the browser window.

Comment 77

15 years ago
I've only noticed this problem since upgrading to 1.3, and it's very easy to
reproduce (it happens every time). I have the experience where it works once,
then doesn't let me delete any mail again until I exit and restart.  I can't
drag mail to the Trash folder, either, but I can drag it to any other folder. 
Intestingly enough, if I try dragging it to Trash, then to a different folder,
then Undo the second drag, instead or returning the mail to my Inbox, it returns
it to Trash (!).

I'm using POP for the server.

Comment 78

15 years ago
A-ha! If I delete my inbox.msf and trash.msf files, then restart, the problem
disppears. I'm not sure which file was responsible, but I can provide the
apparently corrupt .msf files if so desired.

Comment 79

15 years ago
thank to Gordon Farell (comments #77 & 78), I could solve the problem. Deleting
the inbox and trash .MSF files works OK.
Just want to add :
when the delete function was frozen, i also could not view other message than
the last one viewed (execpt by double-clicking on the msg title to open a msg
window).
NB: i "upgraded" from N4.75 to M1.3, then i got that problem
Hope this helps.

Comment 80

15 years ago
My experience is consistent with #76. Upgraded from Mozilla 1.2.1 to 1.3 and
have since had the same delete trouble (Win98SE, POP3, account inbox).

I can delete exactly one time (I can select multiple messages and delete them
all however) after which delete ceases to function and the view pane wedges. I
can unwedge by selecting another folder and returning but cannot restore delete
functionality without shutting down mozilla and restarting. I have deleted ALL
.msf files, suspecting an upgrade artifact, to no effect.

I have a fairly hefty amount of stored mail which may be a related issue since
the owner has been unable to reproduce this bug. I would be happy to try
experiments to narrow down the conditions at the owner's direction.

Comment 81

15 years ago
I can confirm that deleting the .msf files gets rid of the problem for .. a
session, maybe half a session.  Never more.

Guys, Gals -- what is the problem preventing this from being patched?  It's been
a common problem for every single Mozilla release in the last year.  And perhaps
more significantly, NETSCAPE MAIL DOES NOT EXHIBIT THIS PROBLEM.

So for every single Netscape release, someone finds and fixes this bug from the
Mozilla code.  Why won't don't we reintegrate the patch back into Mozilla?  How
hard is that?

This is ridiculous.  This has been reported and re-reported for over a year. 
There's been zero effort at fixing it.

Mozilla wants people helping with development.  Right.  But then they leave us
with a component that is so non-functional that I can only affort to leave
Mozilla on one of my systems (windows, at that!) because I actually have to get
work done when I'm working on the other systems.

Comment 82

15 years ago
1) there's been a lot of effort at fixing this - it appears in other bugs. There
was also a fix in necko recently that fixed a lot of instances of this.
2) this is the first I've heard that this isn't happening in Netscape builds. It
is NOT the case that there's a special fix in the Netscape builds, I promise you.
3) Do you have a protocol log exhibiting the problem? That might be helpful.

Comment 83

15 years ago
Yeah, it's been working in Netscape builds for some time now.  I reported this
back in summer of last year, when I switched from Mozilla 1.2a on a system to
Netscape .. 6.01? I think and it solved the mail problems.  Ever since then,
EVERY Mozilla release has this same mail problem and EVERY Netscape release doesn't.

I was actively testing Mozilla once upon a time, but these days I'm running
Netscape on all systems but one since I actually do need to get work done, and
that involves my e-mail quite a bit.  When the Delete function doesn't work, the
filters that move mail to sub-folders also don't work .. and I can't parse
through 1200 messages a day looking for the ones I need.

How do you get a protocol log on Windows, again?

Comment 84

15 years ago
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

Netscape builds tend to be behind Mozilla builds, both in features and bug
fixes, but also in new bugs :-(

Comment 85

15 years ago
Since moving the bulk of my stored mail to the "Local Folders" account, I have
not had a recurrence of this bug in Mozilla 1.3

Comment 86

15 years ago
I recently switched from 1.0 to 1.3 on Windows2k.

My observation of delete key problems is as follows:

In 1.0 I was in the habit of using the tab key to switch from the panel that
lists the emails to the panel view of the individual email. In other words, I
would scroll through the list of emails with the arrow keys, then by hitting tab
I would activate the individual email window and use the arrow keys to scroll
through the email itself.

I have noticed that hitting tab from the list panel now takes me to the subject
line of the individual email, then the date line, and only on the third tab to
the full panel of the individual email. When I tab three times like this, the
delete key no longer works. If I click directly on the mail in the list panel,
then click with the mouse in the individual email panel, the delete button works
fine.

Comment 87

15 years ago
Created attachment 122980 [details]
IMAP log file

This is an imap log file as requested in the ticket.  I opened up Messenger,
opened up 2 different inboxes and tried to delete a message in each.  Nothing
happened - delete is grayed out.

If you need something different, tell me exactly what you want me to do.

Comment 88

15 years ago
Joe, it looks to me like you never managed to delete a message, so it's not the
case that mail got wedged - more that delete was simply not enabled. Is delete
ever enabled for you? I'm wondering if it's an ACL problem. I notice that you
had a failed logon attempt for both accounts. What version of Mozilla were you
running for that most recent log? 

Comment 89

15 years ago
Put another way, does the ACL info we're retrieving from the ACL command match
your user and server name?

Comment 90

15 years ago
> Joe, it looks to me like you never managed to delete a message,
> so it's not the case that mail got wedged - more that delete was
> simply not enabled. Is delete ever enabled for you?

Are you reading this ticket?  The problems I'm experiencing are exactly what
everyone here experienced.  Delete is grayed out and unavailable.  If you go in
and delete the *.msf files and you'll get the ability to delete mail again.  For
one or two messages.  Maybe 5 minutes if you are really lucky.  Then the delete
button just goes grey again, and you're hosed.

Likewise, filters to move or delete mail will likewise work until the delete
button goes gray.

Sorry for the sarcasm at the top, but please just scroll up and read what we are
all reporting.

> I'm wondering if it's an ACL problem. I notice that you
> had a failed logon attempt for both accounts.

For some reason, Mozilla opens up the mail client and waits silently.  It
doesn't prompt for my password until I open say, Inbox, and click on a message.
 Perhaps it tries to connect at startup and fails silently?

Netscape doesn't do this.  And I _NEVER_ select to save my password, so that
isn't it.

ACL problem in what sense?  Inside Mozilla, maybe.  On the IMAP server?  No. 
Works in Netscape 6.x and 7.x.  Works in every other IMAP client I can find,
including some **** web-based clients. ONLY Mozilla has grief with this.

> What version of Mozilla were you running for that most recent log? 

4.1 alpha.  Immediately after doing this test, I uninstalled the alpha and
installed the beta but the problem remains unchanged.

> Put another way, does the ACL info we're retrieving from the ACL command
> match your user and server name?

I'm not sure what you mean.  I'll try and read the file and see if I can figure
it out.... [goes away]

Seems I already deleted that file.  I'll try again with 1.4b and see...[away]

Do you mean this?

-781143[346f5f0]: 34627a0:mail.isite.net:S-INBOX:SendData: 16 getacl "INBOX"
-781143[346f5f0]: ReadNextLine [stream=346d448 nb=0 needmore=1]
-781143[346f5f0]: ReadNextLine [stream=346d448 nb=54 needmore=0]
-781143[346f5f0]: 34627a0:mail.isite.net:S-INBOX:CreateNewLineFromSocket: * ACL
INBOX jrhett@lizardarts.com lrswipcda anyone p


Yeppers, that's my mailbox and those are my rights.  List, Read, .... in short,
everything.  And "anyone" has only "post" (to make sendmail happy)

Looks right to me.  If you are referring to something else, clue me in.

Comment 91

15 years ago
Lots of people are experiencing very different problems in this bug, believe me.
People who are having problems with local mail folders aren't having the same
problem as people with imap mail folders, for example. People with Cyrus servers
may have a different problem (though your Cyrus server doesn't seem to insist on
making all folders sub-folders of the INBOX). Broadly speaking, there are three
classes of problems:

1. We can't find the Trash folder at all, or we don't think the Trash is the
trash - in this case, the Trash folder won't have a special icon in the folder list.
2. A delete operation fails in such a way that we think a delete is still going
on, and we don't allow future deletes until the first one finishes, or you shut
down and restart.
3. The URI for the Inbox doesn't quite match the folder name (e.g., INBOX vs
Inbox) and when cleaning up after a delete, we can't find the matching delete
operation and we refuse to do more deletes because we think there's still a
delete going on. AFAIK, this has only affected POP3/Local folders.  I'm not sure
if this was fixed or not.

Each of these have different symptoms, though the end result is the same - you
can't delete. In the first one, you can never delete. In the second one, you can
delete for a while, and then it stops working. In the third one, you can delete
once and then it stops working. Doing a multiple delete (more than one message
at a time) can be another factor. So that's why it's important to know if a
delete ever worked during a session. If you start up, and delete is disabled,
then it rules out a whole class of potential problems.

Re the acl, yeah, that's the one. Bear in mind that other mail clients may not
even use ACL. The one wild guess I had was that you specified your user name in
mixed case for the account, and the server still allowed you to log on (the wild
and highly unlikely part), but gave us back acl with a lower case user name, and
when we're looking up acl, we use the user name you specify, and it doesn't
match the user name as returned by the ACL.
(Reporter)

Comment 92

15 years ago
as the original reporter of this bug, I believe my problem falls into (2). i've
noticed that if i give it enough time, eventually i can delete again w/out a
restart of the mail client. 

also note this hasn't happened to me in a while (using a mach-o build from march
2003).

Comment 93

15 years ago
I checked with Seth #3 was fixed for local folders. I've never heard of it
affecting IMAP folders.

I looked more into the enabling/disabling of the delete button for imap folders.
We will only disable it if we think there's no selection (in which case, lots of
commands should be disabled on the toolbar and in the menus), or if we think you
don't have the right ACL. The stand-alone message window (the one you get if you
double click on a message) has sometimes had problems with thinking there's no
selection, but I don't know of any current issues.

Comment 94

15 years ago
From your description, it is hard to say whether this #1 or #2.  One of the
mailboxes has a special icon for Trash, and the other doesn't.

Also, deletes NEVER work unless I delete the mailbox.msf file.  After that, they
work for a short period of time.  Is this #1 or #2?

And if there are 3 different problems, should we split this out to 3 different bugs?

Comment 95

15 years ago
Created attachment 123193 [details] [diff] [review]
patch for acl problem.

This is the proposed fix for problem Joe Rhett is seeing. If you edit your user
name for your imap server, the ACL stuff stops working :-( Thanks to Joe for
helping me track this down.
Comment on attachment 123193 [details] [diff] [review]
patch for acl problem.

r/sr/a=sspitzer

can you assert if GetServer() fails?  (it shouldn't fail, right?)

this is the second GetUsername / GetRealUsername bug I've seen recently.  (one
more, from ch.ey, about GetHostName, GetRealHostName())

I think we have to audit the code.
Attachment #123193 - Flags: superreview+
Attachment #123193 - Flags: review+
Attachment #123193 - Flags: approval1.4+

Comment 97

15 years ago
GetServer shouldn't fail - I don't think we'd ever get here if it did fail.

I think in addition to auditing the code, we should do more thorough testing of
editing the user name and host name

Comment 98

15 years ago
Fix for Joe Rhett's problem checked in. I'm going to mark this fixed. We should
take any remaining problems to new bugs, since this one is way overloaded. Joe,
the fix should be in tomorrow's mozilla build.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 99

15 years ago
Please post the new bug numbers for #1 "We can't find the 'trash' folder" and #2
"Delete operation fails without reporting it completed" to this bug when the new
bug reports are created.

Comment 100

15 years ago
they're not new bugs; they're bugs that have been marked fixed a long time ago.
The trash one is particularly ancient.

the most relevant recent bug is this one, which was fixed for 1.4 and backported
to 1.3.1:
http://bugzilla.mozilla.org/show_bug.cgi?id=192780

Comment 101

15 years ago
In version 1.3.x for variant 2 of this problem with POP3/Local folders it seems
to be fixed BUT, now I get a HANG sometimes when copying to the Sent folder, and
sent messages can get cued up waiting for the folder to be free again.  Some
messages complain that they can copy to Sent when they have, and some never get
sent.
You got a file locking / synchronizing problem here that may be the root of all
these problems.
GP

Comment 102

15 years ago
One bug that might cause such problems is bug 200181. Especially true if you're
using uw-imapd and have possibly multiple mail clients accessing the folders.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.