Closed Bug 649051 Opened 9 years ago Closed 9 years ago

window doesn't resize properly for all landscape keyboards leading to hidden UI

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(firefox5+ fixed, status2.0 unaffected, fennec5+)

VERIFIED FIXED
Firefox 5
Tracking Status
firefox5 + fixed
status2.0 --- unaffected
fennec 5+ ---

People

(Reporter: blassey, Assigned: mbrubeck)

References

Details

(Keywords: regression)

Attachments

(1 file)

More specifically, it doesn't pan to the last 3 or 4 items because the window doesn't resize. 

this is easier to reproduce with the patch on bug 614355
To me this is an other case that could be resolved with bug 585680
Depends on: 585680
What device(s) does this affect?  I think this is the same underlying problem as bug 649688; I can reproduce it on G2 but not on Galaxy Tab.
Blocks: 614355
Summary: awesome screen doesn't pan with non-fullscreen landscape keyboards → window doesn't resize properly for all landscape keyboards leading to hidden UI
Duplicate of this bug: 649688
Duplicate of this bug: 629246
Duplicate of this bug: 626355
tracking-fennec: ? → 2.0next+
Duplicate of this bug: 651895
Duplicate of this bug: 653073
The duplicate bug 649688 was marked tracking-firefox5+ so I am nominating this one now.  This is a regression from Firefox 4 that affects Firefox 5

Bug 649688 contains a preference-only patch to revert this behavior, which is one option for Aurora if we decide this needs to be fixed for Firefox 5.
Assignee: nobody → mbrubeck
Duplicate of this bug: 653693
tracking-fennec: 2.0next+ → 6+
tracking-fennec: 6+ → 5+
One suggested workaround was to detect when the keyboard overlays Fennec, detect the keyboard's size, and resize the Fennec UI ourselves.

We can detect if the keyboard is active using InputMethodManager.isActive, and we can detect that it's overlaying Fennec by checking whether the Fennec window is resized.  However, I haven't found a way to detect the size of the keyboard.
I haven't found a feasible plan to fix this in time for Firefox 5 beta.  Unless we have a good plan soon, I'd like to again propose this patch (originally from bug 649688) to go back to the fullscreen landscape keyboard except on larger, tablet-sized devices.

This bug makes many web pages and parts of our own chrome unusable in landscape mode.  It has generated many duplicate bug reports.  Even our own feedback web page gets hit by this bug, and this was noticed by a user on the nightly channel:
http://input.mozilla.com/en-US/opinion/1994406

While the fullscreen keyboard has plenty of disadvantages, it at least lets users consistently see what they are typing, and it matches the default behavior of other Android apps (so users who don't like it probably avoid typing in landscape mode anyway).  I do think we should switch to the non-fullscreen keyboard on all devices as soon as we have a better workaround for this bug.
Attachment #530064 - Flags: review?(blassey.bugs)
Duplicate of this bug: 655712
Attachment #530064 - Flags: review?(blassey.bugs) → review+
Landed on mozilla-central (Firefox 6):
http://hg.mozilla.org/mozilla-central/rev/b486f0b4a30d

I'll request approval-mozilla-aurora after this has gotten some testing in Nightly.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 6
Comment on attachment 530064 [details] [diff] [review]
patch: revert to fullscreen keyboard on smaller devices

Requesting approval-mozilla-aurora.  This is a regression from Firefox 4, and this patch is a preference-only change that avoids the regression by disabling the feature on affected devices.  This patch has already landed on m-c.  Brad has started on a real fix that should let us re-enable the feature in a future version.
Attachment #530064 - Flags: approval-mozilla-aurora?
Attachment #530064 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Pushed to Aurora for Firefox 5:
http://hg.mozilla.org/mozilla-aurora/rev/cf2c29fc1d65
Target Milestone: Firefox 6 → Firefox 5
Verified fixed on central
Mozilla/5.0 (Android; Linux armv7l; rv:6.0a1) Gecko/20110511 Firefox/6.0a1 Fennec/6.0a1

Will also verify on next aurora nightly
 
Tested on a Nexus One, albeit I did not change the default threshold, I now see a revert of the prior full-screen keyboard as expected.

Can anyone verify moz-central nightly on a tablet for correct behavior?
Verified the keyboard does not cover the screen in landscape w/ Ideos s7 tablet Mozilla/5.0 (Android; Linux armv7l; rv:6.0a1) Gecko/20110512 Firefox/6.0a1 Fennec/6.0a1
Status: RESOLVED → VERIFIED
Blocks: 659202
You need to log in before you can comment on or make changes to this bug.