Closed Bug 658885 Opened 9 years ago Closed 7 years ago

XUL progress meters are (still) clipped incorrectly

Categories

(Core :: Widget: Win32, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: jimm, Assigned: jimm)

References

(Blocks 1 open bug)

Details

Attachments

(4 files, 4 obsolete files)

No description provided.
Attached image downloads
Attached file html version
Strange, the html version looks ok.
Attached file progress tags
So, for some reason, the chunk is painted with an offset of two pixels. One is expected: it's because the progressbar widget has a one pixel border but I can't find why there is a second pixel involved here. (both margins and borders size are ok)
Duplicate of this bug: 661375
(In reply to comment #5)
> So, for some reason, the chunk is painted with an offset of two pixels. One
> is expected: it's because the progressbar widget has a one pixel border but
> I can't find why there is a second pixel involved here. (both margins and
> borders size are ok)

Then just change the code to use one more pixel!  If that doesn't work, then revert the code back and try something else.
Just noticed this after updating to Firefox 6.0.

Is this perhaps related to bug 392672?
(In reply to Samuel Coleman from comment #8)
> Just noticed this after updating to Firefox 6.0.
> 
> Is this perhaps related to bug 392672?

Unfortunately not.
Duplicate of this bug: 707073
Depends on: 726144
This is pretty easy to fix through some tweaks to widgetRect/clipRect down in the theme code.
Attached patch adjust rect (obsolete) — Splinter Review
Assignee: nobody → jmathies
Attached patch adjust rect (obsolete) — Splinter Review
added vertical meter support
Attachment #598104 - Attachment is obsolete: true
Attachment #598105 - Attachment is obsolete: true
Attached patch fix (obsolete) — Splinter Review
Attached patch fix v.1 (obsolete) — Splinter Review
cleanup and testing on xp.
Attachment #598884 - Attachment is obsolete: true
Comment on attachment 599100 [details] [diff] [review]
fix v.1

I've rolled these changes in with bug 658829.
Attachment #599100 - Attachment is obsolete: true
No longer depends on: 726144
Blocks: 726144
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.