Cannot attach non-file attachments from command line

RESOLVED FIXED in Thunderbird 7.0

Status

defect
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

Tracking

(Blocks 1 bug)

Trunk
Thunderbird 7.0
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Steps to reproduce
1/ Try starting TB from commandline with following commmand:
thunderbird -compose attachment=http://www.google.co.uk/

Expected result
1/ TB opens with compose window and www.google.co.uk web page attached.

Actual result
1/ TB errors with message "An error occurred while creating a message compose window. Please try again." and then exits when acknowledged.

Note
There is an issue with sending non-ascii web pages but that is bug 663183
Blocks: 663183
This was initially fixed in SM in bug 617011 with additional work now happening in bug 662698 - I will look at porting those changes back to TB once review process has been completed on SM.
Depends on: 617011, 662698
This patch ports the fix from SeaMonkey bug 662698:
* Handles web page attachments from command line.
* Checks for file existence before attaching and if does not exist prompt.
* General code simplification.
Attachment #538791 - Flags: review?(mbanner)
Comment on attachment 538791 [details] [diff] [review]
Port commandline attachment fix from SeaMonkey

Switching request as protz reviewed some of the code this is replacing
Attachment #538791 - Flags: review?(mbanner) → review?(jonathan.protzenko)
Hi Ian,

I fail to understand how this fixes "* Handles web page attachments from command line.". Is that implied by resolveURI? In that case, a comment would be welcome...
(In reply to comment #4)
> Hi Ian,
> 
> I fail to understand how this fixes "* Handles web page attachments from
> command line.". Is that implied by resolveURI? In that case, a comment would
> be welcome...

A comment in here or a comment in the code?
Changes since last version:
* Extra comments to explain what resolveURI does.
Attachment #538791 - Attachment is obsolete: true
Attachment #538791 - Flags: review?(jonathan.protzenko)
Attachment #540930 - Flags: review?(jonathan.protzenko)
Comment on attachment 540930 [details] [diff] [review]
Port commandline attachment fix from SeaMonkey with extra comments [Checked in: Comment 8]

Review of attachment 540930 [details] [diff] [review]:
-----------------------------------------------------------------

While I haven't tested this, it is small enough that I trust it works. Plus, it's a port from a Seamonkey bug.
Attachment #540930 - Flags: review?(jonathan.protzenko) → review+
Comment on attachment 540930 [details] [diff] [review]
Port commandline attachment fix from SeaMonkey with extra comments [Checked in: Comment 8]

http://hg.mozilla.org/comm-central/rev/4d2abb43abcb
Attachment #540930 - Attachment description: Port commandline attachment fix from SeaMonkey with extra comments → Port commandline attachment fix from SeaMonkey with extra comments [Checked in: Comment 8]
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 7.0
You need to log in before you can comment on or make changes to this bug.