Closed Bug 66391 Opened 21 years ago Closed 17 years ago

Mail filters should allow moving mail from local folders and POP inboxes to imap folders

Categories

(MailNews Core :: Filters, defect, P3)

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 210614
mozilla1.2alpha

People

(Reporter: michele, Assigned: sspitzer)

References

Details

(Keywords: dataloss)

When filtering mail from a POP Inbox to an IMAP folder (this is a two mail
account scenario), messages are always lost. This is different from bug #45693
(mail is not lost when moving it manually, but is lost if filtered even when
moving it to an authenticated IMAP host).
IMAP inbox gets bolded and Unread count increased but when selecting that IMAP
folder that new message is not displayed in the thread pane, never shows up even
after a restart.  Happens whether filtering to IMAP Inbox or other user created
IMAP folder.

Nominating for fix in next release.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: nsbeta1
Changed to All platforms.  Confirmed using jan24 commercial trunk build.
Message does show up in the INBOX file on disk for the IMAP server, but is never
shown in mail window thread pane.
OS: Linux → All
Hardware: PC → All
marking nsbeta1+ and moving to mozilla0.9.  reassigning to bienvenu.
Assignee: gayatrib → bienvenu
Priority: -- → P2
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9
this fix here is to disallow this filter action. That would be a front end
thing, wouldn't it?
I tried this, and there is no data loss anymore - the message simply wasn't
filtered. So I'm changing the summary and reassigning to Gayatri - pop3 msg
filters should not all imap folders as filter targets.
Assignee: bienvenu → gayatrib
Summary: Mail is lost when filtering to an IMAP folder. → Pop3 msg filters shouldn't allow move to imap folder
OK. But why are we not allowing filters from POP to IMAP -- Because it currently
doesn't work or is there another underlying reason?  I'm just curious.
It has never been supported.
Wow. I did not know that...you learn something new every day!
Target Milestone: mozilla0.9 → mozilla0.9.1
Depends on: 77232
No longer depends on: 77232
Blocks: 77232
gayatrib, Are you working on this one ? If not, I will take it, please let me know.
moving to 0.9.2
Target Milestone: mozilla0.9.1 → mozilla0.9.2
reassigning to naving
Assignee: gayatrib → naving
moving to 0.9.3
Target Milestone: mozilla0.9.2 → mozilla0.9.3
Target Milestone: mozilla0.9.3 → mozilla0.9.4
taking from naving.  (this might eventually go to racham, our master of our
picker templates).
Assignee: naving → sspitzer
slide to 0.9.5
Target Milestone: mozilla0.9.4 → mozilla0.9.5
gravy.  moving out.
Target Milestone: mozilla0.9.5 → mozilla1.0
Blocks: 104166
Keywords: nsbeta1+
Whiteboard: [nsbeta1+]
Priority: P2 → P3
moving to 1.0.1, none of these are 1.0 blockers.
Target Milestone: mozilla1.0 → mozilla1.0.1
Blocks: 122274
Status: NEW → ASSIGNED
Keywords: nsbeta1+nsbeta1-
Target Milestone: mozilla1.0.1 → mozilla1.2
I would like to know if filtering from POP3 accounts into IMAP folders is ever
going to be supported.

BTW: In 1.0 it just does nothing. Should the UI prohibit setting up the filter
instead of letting the user set it up and then silently do nothing?
Can someone please explain more clearly "why filtering POP email to IMAP account
is unsupported"?  I understand that it doesn't work now, and that Mozilla never
has filtered email from an IMAP account to a POP3.  "It's too hard to figure
out" is an acceptable answer :-)
it wouldn't be very hard; it's just never been as important as other things...
I wonder what this bug really want to mean. 
Because now it seems that mozilla does not support to filter a pop msg to a imap
folder. 
Does this bugs to make mozilla  support the funciton that move a msg from pop3
to imap folder in a filter?
I think so, anyway.

This should be a reason to support this functionality....

I'm in the process of planning the deployment of Mozilla to the user community
at work from Outlook 2000. Outlook stores messages sent via IMAP locally....
Whden these messages are importe to Mozilla they remain locally (As I would
expect them to). I can easily move these messages manually to the appropriate
"sent" folder on the server. For those users that had multiple account config.
(6+ accounts) in Outlook moving their newly imported "sent items" messages to
the appropriate "sent" folder on the IMAP server becomes more complicated. Some
simple filters would make this task a breeze, but this lack of functionality
makes it difficult and cumbersome.
I think it says something when there are "0" votes for this bug. Therefore, I
feel that we should change the summary of this bug to "Pop3 msg filters *should
allow move to imap folder" -- Maybe we might get some votes for this bug!!!
In fact, when I reported the bug, the description bug was "Mail is lost when
filtering to an IMAP folder" :)

I agree that changing the summary (and maybe changing the severity to
"enhancement" too?) could be reasonable.

I'd like to stress the fact that, mainly due to this missing feature, I'm no
longer using mozilla to read mail as manually moving messages from POP accounts
to the IMAP server I use for mail storage is a pain.

I reported that bug too, and it got duped to this one. 

I suppose we could change the subject, and call it an enhancement, but I still
don't see why a perfectly reasonable bit of functionality shouldn't be supported.

it works fine with two IMAP folders, and it fails miserably and silently,
sometimes with corruption if the receiving folder is Imap.
*** Bug 189478 has been marked as a duplicate of this bug. ***
I changed the description and the severity of this bug according to the recent
discussion.
Severity: major → enhancement
Summary: Pop3 msg filters shouldn't allow move to imap folder → Mail filters should allow moving mail from local folders and POP inboxes to imap folders
here's what I reported:

http://bugzilla.mozilla.org/show_bug.cgi?id=180094

I know I suggested it, but I don't think this is an enhancement. At least 3
people reported dataloss when trying to filter from pop3 to imap, it works from
IMAP to IMAP (and IMAP to POP3) and the argument that ' it's always been broken,
and is therefore a feature'  doesn't make much sense to me.

at least a relnote would be good. 


Ok.
Severity: enhancement → major
Keywords: dataloss
Hey, if you want to see this enhancement in Mozilla you need to vote for it!!!
The title of this bug doesn't seem to fit very well with the discussion, which
barely mentions Local Folders. The problem I find is that mail filters don't
allow filtering from Local Folders to any other folders including other Local
Folders. Run Filters on Folder simply does nothing when the current folder is in
Local Folders. Is that this bug, or perhaps another bug or enhancement request?
If another one, which one?
(In reply to comment #30)
> The title of this bug doesn't seem to fit very well with the discussion, which
> barely mentions Local Folders. The problem I find is that mail filters don't
> allow filtering from Local Folders to any other folders including other Local
> Folders. Run Filters on Folder simply does nothing when the current folder is in
> Local Folders. Is that this bug, or perhaps another bug or enhancement request?
> If another one, which one?

I agree that this functionality would be very useful.
It is so easy to move stuff from an imap Inbox to Local Folders, and you don't
realise you can't move stuff back again.
Product: MailNews → Core
Bug 210614 has been fixed, which has added the capability to filter incoming 
messages from POP to IMAP.  (Manual filtering to IMAP had been working already.)

Michele Bini, do you still encounter your problem with current builds?  If not, 
please mark this bug as a duplicate of 210614.

(In reply to comment #30 [Peter Kirk])
> The problem I find is that mail filters don't allow filtering from Local
> Folders to any other folders including other Local Folders. Run Filters on
> Folder simply does nothing when the current folder is in Local Folders.
> Is that this bug, or perhaps another bug or enhancement request?
> If another one, which one?

The capability to define filters for Local Folders, and run them on the local 
folders, was implemented in bug 177093.  It is still not possible to run filters 
defined for one account on messages in Local Folders or another account; see
bug 129883, bug 257979, bug 267197.
No response from reporter, duping.

*** This bug has been marked as a duplicate of 210614 ***
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.