Highlight of mailboxes crosses the characters in high-DPI mode

RESOLVED FIXED in Thunderbird 8.0

Status

Thunderbird
Theme
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Tilman, Assigned: Paenglab)

Tracking

(Depends on: 1 bug)

Thunderbird 8.0
x86_64
Windows 7

Thunderbird Tracking Flags

(thunderbird6 fixed, thunderbird7 fixed)

Details

(Whiteboard: [gs][gssolved], URL)

Attachments

(4 attachments)

(Reporter)

Description

7 years ago
Created attachment 543117 [details]
tb5-2.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Click on and/or hover over a mailbox


Actual results:

A rectangle is drawn that crosses the bottom of some characters (the "g"), see screenshot. I am using Windows 7 64.


Expected results:

The rectangles should not cross the characters
(Reporter)

Updated

7 years ago
OS: Other → Windows 7
Hardware: All → x86_64

Updated

7 years ago
Component: Folder and Message Lists → Theme
QA Contact: folders-message-lists → theme
(Assignee)

Comment 1

7 years ago
Created attachment 543178 [details] [diff] [review]
One line patch

I see this only with 125% font size.
This patch changes the height from px to em which scales the treechildren height according the font height.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #543178 - Flags: review?(bwinton)
(Assignee)

Comment 2

7 years ago
Created attachment 543179 [details]
Folderpane with font height 125% with patch

Comment 3

7 years ago
Yes, I didn't see it with normal settings using the Windows 7 default desktop theme either, thus didn't confirm this bug right away...
(Reporter)

Comment 4

7 years ago
(In reply to comment #1)
> Created attachment 543178 [details] [diff] [review] [review]
> One line patch
> 
> I see this only with 125% font size.
> This patch changes the height from px to em which scales the treechildren
> height according the font height.

Yes, it is true, I do use the 125% setting.

Sadly I can't test the patch because I can't find that "messenger-aero.css" file on my system.
(Assignee)

Comment 5

7 years ago
The messenger-aero.css is only in hg. In omni.jar search for messenger.css. The one in chrome\classic\skin\classic\aero\messenger is the right one.
(Reporter)

Comment 6

7 years ago
(In reply to comment #5)
> The messenger-aero.css is only in hg. In omni.jar search for messenger.css.
> The one in chrome\classic\skin\classic\aero\messenger is the right one.

Thanks, that works for me!
(Someone else with different screen settings might want to test whether the change works for 100% and for 150% setting)
(Reporter)

Comment 7

7 years ago
Created attachment 543208 [details]
Screenshot of patch suggestion with 125% - successful IMHO
(Assignee)

Updated

7 years ago
Duplicate of this bug: 668334
Comment on attachment 543178 [details] [diff] [review]
One line patch

Review of attachment 543178 [details] [diff] [review]:
-----------------------------------------------------------------

This looks like it should fix it, so r=me.

But, before you close the bug, did we have similar issues in non-aero builds, or on Mac or Linux?

Thanks,
Blake.
Attachment #543178 - Flags: review?(bwinton) → review+

Comment 10

7 years ago
Does this add a whole bunch of extra padding to the rows? That's what it seems like in the screenshots. I think we should try to avoid that if possible...
(Assignee)

Comment 11

7 years ago
(In reply to comment #9)
> But, before you close the bug, did we
> have similar issues in non-aero builds, or on Mac or Linux?

The problem was introduced with the Vista/Win7 treerow appearance. On XP I'm sure it works.
Keywords: checkin-needed
(Assignee)

Comment 12

7 years ago
(In reply to comment #10)
> Does this add a whole bunch of extra padding to the rows? That's what it
> seems like in the screenshots. I think we should try to avoid that if
> possible...

I've choosen the value which effects in the same height as before on default font size. With bigger fonts the rows are naturally heigher.
(Assignee)

Comment 13

7 years ago
Comment on attachment 543178 [details] [diff] [review]
One line patch

This is only a visual change and shouldn't harm the builds
Attachment #543178 - Flags: approval-comm-beta?
Attachment #543178 - Flags: approval-comm-aurora?

Comment 14

7 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/9127a0af1ca2
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 8.0
Attachment #543178 - Flags: approval-comm-beta?
Attachment #543178 - Flags: approval-comm-beta+
Attachment #543178 - Flags: approval-comm-aurora?
Attachment #543178 - Flags: approval-comm-aurora+

Updated

7 years ago
Depends on: 671611

Updated

7 years ago
Duplicate of this bug: 676193
(Assignee)

Updated

7 years ago
Duplicate of this bug: 678164
Summary: Highlight of mailboxes crosses the characters → Highlight of mailboxes crosses the characters in high-DPI mode

Comment 18

7 years ago
another person probably likes it :)
http://getsatisfaction.com/mozilla_messaging/tags/bug_668494
Whiteboard: [gs][gssolved]
You need to log in before you can comment on or make changes to this bug.