(Mac) Command-Shift-N for New message (non-default format) broken

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
7 years ago
5 years ago

People

(Reporter: kazar, Unassigned)

Tracking

(Blocks: 2 bugs)

All
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Build ID: 20110707182747

Steps to reproduce:

Press Command-Shift-N to open a non-default format new message window, as per the keyboard shortcuts shown on http://support.mozillamessaging.com/en-US/kb/keyboard-shortcuts?s=keyboard&as=s


Actual results:

The keyboard shorcut on Mac for opening a new message window "non-default format" does nothing.


Expected results:

A new message window should open that will allow me to choose what format I wish to send the email in.
(Reporter)

Updated

7 years ago
OS: Other → Mac OS X
(Reporter)

Comment 1

7 years ago
My config details:
Mac 10.6.8 on Intel Core i7 Macbook Pro
cmd-N works right ?
Component: General → Help Documentation
QA Contact: general → help-documentation
It looks like the documentation is wrong for once.

Updated

7 years ago
Assignee: nobody → jenzed
(Reporter)

Comment 4

7 years ago
thanks for pulling this one jenzed. Ludovic, yes Cmd-N works. not sure what your documentation comment means: is the keystroke actually something different, or is the ability to start a new message in non-default format just not really a feature?
My assumption (based on trying this on windows) is that TB no longer offers keyboard shortcuts for non-default formats. The current documentation is severely flawed, e.g. some of the shortcuts mentioned here were listed as many as 3 times claiming to do the different things for the same area. I took a first stab at fixing it, which included removing all "non-default format" shortcuts.

Ludovic, can you comment on the discontinuation of "non-default format" features and their shortcuts? Do we still have the features and/or shortcuts to use them?

Comment 6

7 years ago
this is a bug
Assignee: jenzed → nobody
Component: Help Documentation → Message Compose Window
QA Contact: help-documentation → message-compose
As master of keyboard shortcuts documentation, these are my most recent insights (now fully documented in (1), review pending):

1) Starting a new message in non-default format (Plain text vs. HTML) is fully keyboard accessible only on Windows (from message context menu):

Menu key or Shift+F10 for message context menu, then
hold Shift while choosing any of Reply to Sender, Reply to All, Reply to List, or Forward.

For MAC and Linux, I'm not aware of a keyboard shortcut for context menu (pls let me know if there is one), so you have to right-click for that, then use the Shift-trick.

2) For mouse users only, you can also toggle message format by holding Shift while clicking on any of the following buttons:
Write, Reply, Reply All, Reply List, Forward.

3) Unfortunately, and ux-inconsistent with 1), Shift modifier key does *not* work from the main message menu (needs new bug, I'll do that soon). Surprisingly, it doesn't even seem to be a regression (looking at TB2).

4) Shift modifier key never works for "Edit message as new", and there's no workaround when you start out from a plaintext msg (partially/fuzzily covered by Bug 78794; I'll file new bug for Shift modifier)

5) Bug 687324 - "Shift+Click" on "Compose Message To" menu item does not trigger non-default format for composition: toggle Plain text vs. HTML (mail header contacts' context menu)

6) (This bug) I'm not sure when or if we ever had *real* keyboard shortcuts (Ctrl+Shift+somekey) for starting a new msg in non-default formats, as suggested by this bug.
- No such keyboard shortcuts on 2.0.0.24 (20100228)
- Can't test on 3 or 3.1
- No such keyboard shortcuts on current TB10 or trunk, because some candidates are already taken:
Ctrl+Shift+R = Reply All
Ctrl+Shift+L = Reply List
I believe Ctrl+Shift+N (this bug) or Ctrl+Shift+E would still be available, but it's unlikely we'll implement them without having the corresponding shortcuts for Reply/Reply All/Forward, and imo this is no longer a frequent enough  usecase to justify using shortcuts.

hth

(1) https://support.mozillamessaging.com/en-US/kb/keyboard-shortcuts
(In reply to Thomas D. from comment #7)

> 3) Unfortunately, and ux-inconsistent with 1), Shift modifier key does *not*
> work from the main message menu (needs new bug, I'll do that soon).
> Surprisingly, it doesn't even seem to be a regression (looking at TB2).

Richard aka :paenglab has fixed that in Bug 731673 :)

> 
> 4) Shift modifier key never works for "Edit message as new", and there's no
> workaround when you start out from a plaintext msg (partially/fuzzily
> covered by Bug 78794; I'll file new bug for Shift modifier)

see bug 731688
Jim, can you please verify this bug as invalid, or otherwise wontfix.

As reported in comment 7, number 6), at least since TB2, we've probably never had Shift modifier for *keyboard shortcuts* for writing new messages (perhaps Command+Shift+N in MAC, but I doubt that, too); we only ever offered Shift+mouseclick on respective buttons and menus (and we'll make that work everywhere in bug 975816).

Even Comment 0 doesn't claim this feature was ever working, it only refers to documentation.
Per Ludo's Comment 3 and my comment 5, keyboard shortcuts documentation was erroneous at the time before my revamping of the entire document. In current documentation, in accordance with application reality, we no longer advertise any keyboard shortcuts with shift modifier for starting new messages in non-default format (only shift+mouseclick, but not the real keyboard-only shortcuts).

So this bug is currently invalid.

Otherwise it would be a RFE to introduce Ctrl/Command+Shift+N for "New msg in non-default format", but the RFE would be wontfix (unless we want to reshuffle even more keyboard shortcuts):

a) Corresponding shortcuts with shift for related commands (reply, forward) are already taken:
Ctrl+Shift+R = Reply All
Ctrl+Shift+L = Reply List
So we can't use them for non-default format for Reply to Sender or Forward.
Reshuffle will be very difficult.

b) we can't have Shift modifier for non-default format only for some compose commands like "New message" (Command+Shift+N) or "Edit as New" (Command+Shift+E), but not for other related compose commands like Reply, Forward etc. (would violate ux-consistency, and add more confusion than help).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(squibblyflabbetydoo)
Resolution: --- → INVALID

Comment 10

5 years ago
Switching to WONTFIX, but yeah, this is just something we can't do with the way our keyboard shortcuts are set up. Probably the "right" way to fix this would be to allow toggling between plain text and HTML after you've opened the compose window, but I doubt we'll get to that for a while (I'm waiting for jcranmer to improve more of the backend before I touch anything in compose).
Flags: needinfo?(squibblyflabbetydoo)
Resolution: INVALID → WONTFIX
You need to log in before you can comment on or make changes to this bug.