[rfe] keyboard shortcuts for Tasks/Tools menu items

VERIFIED WONTFIX

Status

()

Core
Keyboard: Navigation
--
enhancement
VERIFIED WONTFIX
17 years ago
16 years ago

People

(Reporter: Jesse Ruderman, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

(Depends on: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Proposed keys for Tasks/Tools menu items:
ctrl-alt-C  cookie manager
ctrl-alt-I  image manager
ctrl-alt-F  form manager
ctrl-alt-P  password manager
ctrl-alt-J  java console
ctrl-alt-V  javascript console  (try to make this key match menu mnemonic...)

Other Ctrl-Alt keys (for reference):
ctrl-alt-T  debug networking stuff (bug 37594)
ctrl-alt-S  toggle status bar (bug 18768)
cltr-alt-F  open fishcam (bug 25369)


See also bug 67416 and bug 32502, two proposals for changing the Tasks menu to 
get rid of the problem of deeply nested submenus.  Bug 67416 takes the items 
that only make sense in Navigator and creates a new Tools menu with them.  Bug 
32502 does a better job of flattening the Tasks menu but leaves it as one menu 
(which would continue to be the same across Mozilla apps).

Comment 1

17 years ago
personally i'd never heard about ctrl-alt-s, i'd give that to the js console.

Eventually we'll have a fullscreen view which i would think is more useful than 
showing/hiding the status bar. As long as you can use View>Toolbars>Statusbar i 
think we're ok.

Comment 2

17 years ago
reassign to german to update spec.. once the spec is updated, I'll add these.
Assignee: alecf → german

Comment 3

17 years ago
These look good to me, and can be used whether or not we redesign the menu 
access points to avoided nested-ness. I wanted to re-assign to Ben as he had a 
number of ideas on restrucutring the access to privacy and security, to make 
sure it's compatible. Ben feel free to send back to me once you looked at it 
and its ready to spec.
Assignee: german → ben

Comment 4

17 years ago
Just for the records: ctrl-alt-s toggles the sticky state in Enlightenment
(at least on my Debian Linux system), so it wouldn't be available there.
Similar with ctrl-alt-i: iconify window.

I just noticed that OS is set to Windows98, do you only want to implement it
there?
(Reporter)

Comment 5

17 years ago
Faniz: thanks for pointing that out.  I hadn't intended these shortcuts to be 
Windows-only.  Do you think Mozilla should use a different set of shortcuts on 
all platforms, or just on Unix-like systems, or just on Enlightenment?

Comment 6

17 years ago
Actually, let's use accel-shift-K[ey] just like we did in nc4.  Fishcam can 
keep accel-alt because it's not a window.

Comment 7

17 years ago
Jesse: actually I don't know. Unfortunately there are too many window managers
on Linux, and I don't know if there is any standard for which keys they use
and which not. (Platform/OS -> All/All now)

    - Stephan.
OS: Windows 98 → All
Hardware: PC → All
(Reporter)

Comment 8

17 years ago
The reason I originally chose Ctrl+Alt+(letter) instead of Ctrl+Shift+(letter) 
for these shortcuts is that Ctrl+Shift+(letter) is usually reserved for an 
action related to Ctrl+(same letter).  For example, Ctrl+Shift+P might be Print 
Setup and Ctrl+Shift+C might be Copy Without Formatting (bug 67142).  Alt+Shift 
might be safe, but I haven't seen too many programs use that.

Cc mpt to see if he has any ideas.

(Btw, I just realized that I used accidentally used Ctrl+Alt+F twice when I 
originally opened this bug... oops.)

Comment 9

17 years ago
I mentioned that to some people at linux world ny but their view was that there 
is a scarcity of key combinations; you can't just reserve shift.

Obviously, if you have a funnction for Ctrl+<Letter> and have a similar 
function that people would also use frequently, it deserves the 
Ctrl+Shift+<Letter> binding.

nc4.7messenger has ctrl-i [tab] and ctrl-shift-i security information.

Comment 10

17 years ago
Ctrl+Alt+anything should be avoided -- leave it for the OS (e.g. Ctrl+Alt+Delete) 
or window manager (e.g. Ctrl+Alt+I).

I don't think any of these things should have shortcuts, because the probability 
of people needing to open them quickly and frequently is less than the 
probability of people opening them by mistake with the keyboard shortcuts.
and there are accel+num shortcuts for tasks such as navigator, mail, composer,
address book... i'm not terribly inclined to implement this request.

aaron, your thoughts?

Comment 12

17 years ago
My thoughts are that unless there's going to be a number of people using a
certain option so frequently that more than one keystroke seems like too much
work, let people type a few keys to go through the menu. How often do most
people bring up the cookie manager? Let them type Alt-T P C, it's not that much
harder. Accelerators should be reserved for the really important stuff.

I think, if it's important enough to have a single keystroke assigned to it,
don't bury it in a deep menu somewhere.

Updated

17 years ago
Depends on: 69954

Comment 13

17 years ago
See www.mozilla.org/projects/accesibility/ui/mozkeyintro.html.
Part of our new modifier key policy is to avoid Ctrl+Alt combinations.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
(Reporter)

Updated

17 years ago
Depends on: 102402
v
Status: RESOLVED → VERIFIED
(Reporter)

Comment 15

16 years ago
*** Bug 129372 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.